VirtualBox

Ticket #3823 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Mouse problems in Ubuntu 9.04 -> fixed in SVN

Reported by: abcuser Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.2.0 Keywords: mouse
Cc: Guest type: Linux
Host type: Windows

Description

Hi,
using VirtualBox 2.2.0 on Windows XP SP3 host and Ubuntu 9.04 as guest I have mouse problems. By the way on the same host I also have Ubuntu 8.10 and have no mouse problems.
I have installed guest additions. I always have to press host key to release mouse from guest - it looks like mouse integration is not working in Jaunty.
There is also one more problem with mouse. Sometimes mouse can't be moved above some horizontal line - like it would be the top of the screen but it is not. The work around is to move mouse up and down several times and then it get up to the top.
Regards

Change History

comment:1 Changed 5 years ago by michael

I am not sure about the second issue. For the first, try deleting the file /var/cache/hald/fdi-cache on the guest, then restarting hal

/etc/init.d/hal restart

then restarting X.Org. (And add a comment to this ticket to say whether it helps!)

comment:2 Changed 5 years ago by jacek

I had exactly the same problem, and your solution worked perfectly.

Thank You!

comment:3 Changed 5 years ago by michael

  • Summary changed from Mouse problems in Ubuntu 9.04 to Mouse problems in Ubuntu 9.04 -> fixed in SVN

Assuming that it is the same problem (which I do assume) it is fixed in our SVN repository.

comment:4 Changed 5 years ago by jonathand131

Same problem after a fresh install of Kubuntu Jaunty (9.04) on Gentoo Linux host.

I've done

rm /var/cache/hald/fdi-cache
/etc/init.d/hal restart

but the problem was not resolved. Rebooting the virtual machine after that make mouse integration works. Perhaps restarting X server could be sufficient.

comment:5 Changed 5 years ago by abcuser

Sorry I haven't tested this... Now I have installed VirtualBox 2.2.2 and problem has disappeared. You can close this problem as solved. Thanks for helping me out.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use