VirtualBox

Ticket #3792 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

XP hangs on startup when rebooted -> Fixed in SVN/3.0.6

Reported by: ToddAndMargo Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi All,

Host CentOS 5.3; guest Win XP-SP3; VBox 2.2.0; nvidia-x11-drv-173.08-1.beta.el5.rf

I have an unattended virtual server that needs to be rebooted at night. Problem: about 1 out of 4 reboots, XP hangs when starting up. When I finally get to it, I find a black screen with assorted vertical lines (mostly red). Powering off the machine and starting it new is always successful.

Also, I can reproduce it every time on my own (attended) workstation.

Many thanks, -T

p.s. I should note that I never have a problem starting up, except when I reboot.

Attachments

VB-WinXP-2009-04-20-18-46-20.log Download (32.8 KB) - added by ToddAndMargo 5 years ago.
XP reboot crash log
vbox.xp.reboot.screen.jpeg Download (225.4 KB) - added by ToddAndMargo 5 years ago.
Screen shot up the boot up crash
virtualbox-reboot-crash.log Download (2.6 KB) - added by markedwards 5 years ago.
VBox.log Download (44.2 KB) - added by ToddAndMargo 5 years ago.
Crash restarting after running Go To Assist Express

Change History

Changed 5 years ago by ToddAndMargo

XP reboot crash log

comment:1 Changed 5 years ago by ToddAndMargo

Guys! This error is starting to drive one of my customers nuts. Any chance of fixing it in 2.2.4?

comment:2 Changed 5 years ago by frank

Does only the guest hang or does the VM hang? Reading your initial report it seems that you are able to power off the machine which wouldn't be possible if the VM hangs but I want to be 100% sure.

Also, could you generate a  core dump while the guest is hanging?

comment:3 Changed 5 years ago by ToddAndMargo

Hi Frank,

The VM is fine. All the VM decorations work fine. The problem is with XP. When you "Restart", XP shuts all the way down and restarts normally. Except, when XP boot back up it hangs with a video shimmer at the spot where you should see the XP splash screen.

I looked at the core dump page. Can you be a bit more specific as to what you want me to do? (It may be Friday or Sunday before I can run it.)

-T

Changed 5 years ago by ToddAndMargo

Screen shot up the boot up crash

comment:4 Changed 5 years ago by ToddAndMargo

Looking over the core dump link you sent me, I am wondering if I still need to do this. Do you want me to force a core dump? The VM is running fine. I attached a screen shot of what XP looks like when it crashes booting back up.

-T

comment:5 follow-up: ↓ 6 Changed 5 years ago by frank

Again the question: Are you able to properly power off the VM when this happens? I assume yes because you said that all VM decorations work fine but I want to be sure. In that case, a core dump would not help.

comment:6 in reply to: ↑ 5 Changed 5 years ago by ToddAndMargo

Replying to frank:

Again the question: Are you able to properly power off the VM when this happens? I assume yes because you said that all VM decorations work fine but I want to be sure. In that case, a core dump would not help.

Hi Frank,

Thank you for jumping on this case. My customer is starting to get steamed over this.

Yes, I can power it off. When this happens, I typically will press the "X" in the decoration, select "power off machine", then go to my "Sun VirtualBox" console and select "start" to get going again. Sometimes I will also have other VM's running -- it makes no difference.

From the attachment I posted, it looks like the graphics driver is not resetting properly, but I could be wrong.

-T

comment:7 follow-up: ↓ 10 Changed 5 years ago by frank

Still not able to reproduce. Wild guess: Does this scrambling during reboot only occur if you restored the guest from a saved state? In your log I saw that the VM was loaded from a saved state before you attempted to reboot it.

comment:8 Changed 5 years ago by markedwards

I see this exact same behavior on a fresh install of Windows XP Professional 32-bit from original OEM disc, VirtualBox 2.2.2 host running on OS X 10.5.7.

It is unrelated to restoring from a saved state, and I can't get it to repeat reliably. I have only seen it on restart after doing Windows Update, but that may be incidental. The only change I have made from the default VM settings for Windows XP is to enable 3D. Everything else is stock.

Googling, I see many reports of this. This is clearly a widespread issue.

Thanks!

Changed 5 years ago by markedwards

comment:9 Changed 5 years ago by markedwards

Adding relevant log lines from an incident that just occurred. Interestingly, there is a line saying:

10:16:10.901 Changing the VM state from 'RUNNING' to 'SUSPENDED'.

even though I did not suspend the VM at that time. I wasn't even at the computer yet.

comment:10 in reply to: ↑ 7 ; follow-up: ↓ 14 Changed 5 years ago by ToddAndMargo

Replying to frank:

Still not able to reproduce. Wild guess: Does this scrambling during reboot only occur if you restored the guest from a saved state? In your log I saw that the VM was loaded from a saved state before you attempted to reboot it.

Not so wild. You called it. I am only able to reproduce this when I restart after restoring from a saved state.

Now at my customer's site, this shimmer on start up after a reboot happens about one a week. The VM (XP-Pro-SP3) is set to reboot a 23:30 every night with the Windows "Shutdown -r" command. This VM is never "Save Stated".

-T

comment:11 follow-up: ↓ 12 Changed 5 years ago by markedwards

I have absolutely seen this issue on a machine that had never been put into a saved state. I did a fresh install of Windows XP SP2 from a CD installer, ran Windows Update, hit reboot, and had the freeze.

As I said, its odd that there is a log entry above that seems to suggest the machine was suspended, as no suspended state was in fact called from the VirtualBox gui. Perhaps this points to a separate but related issue.

comment:12 in reply to: ↑ 11 Changed 5 years ago by ToddAndMargo

Replying to markedwards:

Perhaps this points to a separate but related issue.

Fix the one and I bet you fix the other.

comment:13 Changed 5 years ago by markedwards

Here's some possible evidence -- I have been unable to recreate the crash with 3D turned off. In fact, I'm noticing considerable bugginess all around with 3D. Ubuntu 9.04 crashes with it on as well.

Since turning off 3D, I have rebooted the Windows XP guest many times without incident, including after taking the guest into a saved state.

comment:14 in reply to: ↑ 10 Changed 5 years ago by ToddAndMargo

Replying to ToddAndMargo:

Now at my customer's site, this shimmer on start up after a reboot happens about one a week. The VM (XP-Pro-SP3) is set to reboot a 23:30 every night with the Windows "Shutdown -r" command. This VM is never "Save Stated".

-T

Okay, here is a rub. I was having all kinds of problems with my video driver (CentOS 5.3). I found that an update last week on it had crashed and I was using the stock nVidia driver. So I upgraded from nvidia-x11-drv-173.08-1.beta.el5.rf.i386.rpm to dkms-nvidia-x11-drv-180.51-1.nodist.rf.i386.rpm. It solved a lot of problems, including this one.

Problem: the customer is not using an nVidia card. He has a Supermicro MBD-X7DVL-E-O motherboard with a build in ATI ES1000 Graphics with 16MB video memory. So the problem seem to be isolated to the stock video drivers.

-T

comment:15 Changed 5 years ago by markedwards

Perhaps this is in fact a generic symptom of general video driver issues. I saw it with OS X with 3D enabled, you saw it with this funky nVidia driver.

I haven't had a single incident since disabling 3D support.

comment:16 follow-ups: ↓ 17 ↓ 18 Changed 5 years ago by frank

Ok, it has apparently something to do with 3D support. ToddAndMargo, has your customer enabled 3D support for his VM, that is, does disabling this VM option fix the problem for him as well?

comment:17 in reply to: ↑ 16 Changed 5 years ago by ToddAndMargo

Replying to frank:

ToddAndMargo, has your customer enabled 3D support for his VM, that is, does disabling this VM option fix the problem for him as well?

I will be at his site on Wednesday. This is a the top of the list. I will report back. -T

comment:18 in reply to: ↑ 16 ; follow-up: ↓ 19 Changed 5 years ago by ToddAndMargo

Replying to frank:

Ok, it has apparently something to do with 3D support. ToddAndMargo, has your customer enabled 3D support for his VM, that is, does disabling this VM option fix the problem for him as well?

No. 3D support was off. I increased video memory from 8 MB to 16 MB to see if that will help. Now we wait (it happens about twice a week). I confirmed with the customer that the crash screen was a blank screen with shimmers, like the attachment I uploaded.

comment:19 in reply to: ↑ 18 Changed 5 years ago by ToddAndMargo

Replying to ToddAndMargo:

Replying to frank:

Ok, it has apparently something to do with 3D support. ToddAndMargo, has your customer enabled 3D support for his VM, that is, does disabling this VM option fix the problem for him as well?

No. 3D support was off. I increased video memory from 8 MB to 16 MB to see if that will help. Now we wait (it happens about twice a week). I confirmed with the customer that the crash screen was a blank screen with shimmers, like the attachment I uploaded.

And this morning, crond sent me this "VirtualXP has crashed. Please restart it." So, increasing the video memory had no affect.

I do believe that if we fixed the problem with 3D on, we will also fix this problem as well

comment:20 Changed 5 years ago by ToddAndMargo

I just got a shimmer on reboot on my machine with 3D enables and my fancy new nVidia driver. So, it crashes my computer all the time with the stock drive with 3D enabled and 1 out 10 with 3D enabled and my fancy nVidia driver. My customer is using the stock driver, no 3D and crashes about one out of five. Fix the one and I bet you fix the other.

-T

comment:21 Changed 5 years ago by frank

Any change with VirtualBox 3.0.0?

comment:22 Changed 5 years ago by ToddAndMargo

Hi Frank,

Have not tested it. I have a lot a customers that need the SMP features of 3.0.0, but am too "chicken" to try it until 3.0.2 (I would frequently read the beta forum and all the bugs kind of scared me.) I will report back when 3.0.2 hits, would should be shortly.

-T

comment:23 Changed 5 years ago by ToddAndMargo

I just upgraded a customer from 2.2.4 to 3.0.2. The reboot and freeze problem persisted. But, troubleshooting another problem, I uninstalled the Guest Additions. I noticed I could reboot to my hearts content. Upon reinstalling the Guest Additions, I am still able to reboot to my hearts content.

But, this is only one of three machines with the problem. Please do not close this until I test the other two (their problem is much more severe).

Many thanks, -T

comment:24 Changed 5 years ago by ToddAndMargo

Hi All,

The other two systems can not be upgraded to 3.0.2 at this time due to bug 1778. So they are stuck at 2.2.4. But, all is not lost. My computer (2.2.4) is the one with the most severe problem. So, I tried my work around of uninstalling the Guest Additions, rebooting, and reinstalling the Additions again. On my computer, rebooting would crash every single time, without exceptions. After implementing my workaround, I am now able to reboot till my eyes pop out without a problem. The problem is isolated to faulty housekeeping in the Windows Guest Additions Installer.

So, the workaround is to do a full uninstall of the Windows Guest Additions, reboot, and then reinstall the Guest Additions.

Now for the fix (the workaround *is not* the fix): please have the developers modify the Windows Guest Additions Installer in the following manner. When the installer detects a prevoius installation of the Windows Guest Additions, do a full uninstall before reinstalling the new Additions.

This will cure my problem and cure a whole bunch more that have yet to raise their ugly heads in the future as more and more housekeeping errors cause more and more weird problems.

Many thanks, -T

comment:25 Changed 5 years ago by ToddAndMargo

Update: I can still reboot my own, except when I have been running Go To Assist Express (GTAE). I typially reboot after GTAE as it totally messes up the clip board in XP after it has been running. I get the shimmer on start up.

-T

comment:26 Changed 5 years ago by ToddAndMargo

Update: after uninstalling and reinstalling VBox additions on my customer's machine, he is still shimmering and freezing on boot up after a reboot

comment:27 follow-up: ↓ 28 Changed 5 years ago by sunlover

  • Summary changed from XP hangs on startup when rebooted to XP hangs on startup when rebooted -> Fixed in SVN/3.0.6

The problem should be fixed in upcoming 3.0.6.

comment:28 in reply to: ↑ 27 Changed 5 years ago by ToddAndMargo

Replying to sunlover:

The problem should be fixed in upcoming 3.0.6.

Cool. I will test it as soon as 3.0.6 hits. Thank you! -T (OP)

comment:29 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:30 follow-up: ↓ 31 Changed 5 years ago by ToddAndMargo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Unfortunately, under 3.0.6, this issue is still is not fixed. R-a-t-s!

Steps to reproduce:

1) open a Go To Assist Express (GTAE) session 2) log into some one and transfer a file from them 3) exit the remote customer 4) exit GTAE 5) reboot your computer

A trial to GTAE can be downloaded from:  http://www.gotoassist.com/en_US/entry.tmpl The web page also has their phone number on it. For what you are doing, they may even give you a free account. Let hope. -T

comment:31 in reply to: ↑ 30 ; follow-up: ↓ 32 Changed 5 years ago by sunlover

Then the problem is different to the one that was fixed. Please attach 3.0.6 VBox.log with the hang.

Replying to ToddAndMargo:

Unfortunately, under 3.0.6, this issue is still is not fixed. R-a-t-s!

Steps to reproduce:

1) open a Go To Assist Express (GTAE) session 2) log into some one and transfer a file from them 3) exit the remote customer 4) exit GTAE 5) reboot your computer

A trial to GTAE can be downloaded from:  http://www.gotoassist.com/en_US/entry.tmpl The web page also has their phone number on it. For what you are doing, they may even give you a free account. Let hope. -T

Changed 5 years ago by ToddAndMargo

Crash restarting after running Go To Assist Express

comment:32 in reply to: ↑ 31 Changed 5 years ago by conedltd

We see this problem too, with XP Pro SP3 on Vista Business SP1 host. Running V3.0.6 r52128. (Had the problem some time ago, but seemed to be fixed for a few months. Looks like it came back with V3.0.6, although wasn't tracking release numbers so can't be sure.)

comment:33 Changed 4 years ago by DAPPERsBorg

I would like to add this as well if I may. I installed last week VirtualBox 3.0.8 r53138. Windows 7 Ultimate (final) and Ubuntu 9.04 reboot well. All functions (except 3D acceleration of course) work fine. With Windows XP Pro SP3 (my slipstream CD) installed today, reboots halt with the same results as the original image vbox.xp.reboot.screen.jpeg (by ToddAndMargo on 2009-05-25 05:05:18).

Now I tried disabling 3D acceleration and still halted. I re-enabled it and no change.

Just wanted to add in my comments about this. Thank you.

comment:34 Changed 4 years ago by DAPPERsBorg

Oh, yes, two more things to add to the above....

As ToddAndMargo reported, only on reboot it halts. Never on startup.

Also, my VB is running off Vista Ultimate SP2.

I see a new version (3.0.10) of VB is released with some minor code done (based on the version numbering method). My auto update, set on one day checks, never told me anything. I saw it while reading site pages. Something new to try! As mentioned above, mine is the previous release.

Let us all try it out and report back! Good night and God bless.

comment:35 follow-up: ↓ 36 Changed 4 years ago by viznix

Hey everybody, I just wanted to relay my experience with this issue. Not sure if it will help you all, but it helped me.

I was also having XP hang on reboot. The updates didn't help me. Disabling 3D acceleration didn't help either. What did end up helping me was increasing the Base Memory to 512 and the Video Memory to 16. Maybe I can lower them, but I haven't tried yet.

Hope it helps.

comment:36 in reply to: ↑ 35 Changed 4 years ago by ToddAndMargo

Replying to viznix:

Hey everybody, I just wanted to relay my experience with this issue. Not sure if it will help you all, but it helped me.

I was also having XP hang on reboot. The updates didn't help me. Disabling 3D acceleration didn't help either. What did end up helping me was increasing the Base Memory to 512 and the Video Memory to 16. Maybe I can lower them, but I haven't tried yet.

Hope it helps.

Dude. D-U-D-E! Viznix! You are the man!

I already had 32 meg of video memory, but my RAM was at 352 meg. So, I fire it it up, open a session on Go To Assist Express (GTAE) (just open, not log into anyone), rebooted and got the shimmer. Then I upped my RAM to 512 Meg, fired back up, opened a GTAE session, and rebooted. And what do you know. It worked. I tested twice more and even open three GTAE session once.

You are the man! Thank you!!! -T

Virtual Box: does this give you something or some clue on what to troubleshoot? You could always change the minimum memory on XP to 512.

comment:37 Changed 4 years ago by ToddAndMargo

Viznix: I think you may have solved another bug as well. Thank you!

 http://www.virtualbox.org/ticket/1778#comment:77

-T

Virtual Box: this may be a duplicate of 1778

comment:38 Changed 4 years ago by swt2c

Any hope for a code fix on this one? On one of my machines, I'm not sure I can afford to give the VM 256MB more memory.

comment:39 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use