VirtualBox

Ticket #3785 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

[Regression] Access denied when saving in Visual C++ in shared folders => Fixed in SVN

Reported by: ClementMenier Owned by:
Priority: blocker Component: shared folders
Version: VirtualBox 2.2.0 Keywords: Visual
Cc: Guest type: Windows
Host type: Linux

Description

I have recently upgraded from version 2.1.4 to version 2.2.0. [ Host is Ubuntu Linux 64bits 8.04, Guest is Windows XP ].

While everything was working fine under previous version, I have encountered an issue in using Visual C++ Express 2008 in a project on a shared folder. I cannot save modifications in files. Note that I can however edit the files and save them with Wordpad. Visual C++ however tells me to save my file elsewhere or replies that "Access denied".

Attachments

VBox.log Download (62.3 KB) - added by ClementMenier 5 years ago.
VirtualBox Log

Change History

Changed 5 years ago by ClementMenier

comment:1 Changed 5 years ago by ClementMenier

I have noted a remark in the Changelog concerning the umask respect. If this is important my umask under linux is 0022.

comment:2 Changed 5 years ago by jasondavies

I am also getting the same problem when using Visual C# 2008 Express Edition under WinXP guest in a Mac OS X host.

comment:3 Changed 5 years ago by goberhammer

I can confirm this regression. I'm experiencing same problems with WindowsXp hosted by Ubuntu 8.10.
Everything was ok with VB2.1.4, but after upgrading to 2.2 all my linux ext3 shared folders are non-writable by Visual C# 2008 Express Edition.
Saving files after modifying says to save my file elsewhere or replies that "Access denied". The big problem is that building (compiling) solutions does not work anymore because VS is not allowed to overwrite the final exe file.
If you create a new class inside VS, the file is correctly created with the class code snippet, but is not possible to save it after editing.
Files are perfectly editable using Notepad++ or Wordpad.
If the project folder is copied to some location on th guest drive C:\, everything works again.
Another strange thing is that all the subfolders on the shared folder are marked 'read only' if you look at their properties under explorer. Unchecking 'read only' has no effect.
Despite subfolders being 'read only', you can create, delete, edit, etc files and folders in them with Explorer or FreeCommander

comment:4 Changed 5 years ago by antonio.guadagnin

It's the same problem mentioned in ticket n. 3340.

 http://www.virtualbox.org/ticket/3340

comment:5 follow-up: ↓ 6 Changed 5 years ago by frank

An umask 0022 is correct. Please guys, could you start your VM as follows:

sudo chmod u+s /usr/bin/strace
strace -f -s64 -o ~/strace.log VirtualBox -startvm VM_NAME

then start the guest and perform the shared folders action which is supposed to fail and then compress ~/strace.log and attach it to this defect?

comment:6 in reply to: ↑ 5 Changed 5 years ago by i-nZ

Replying to frank:

An umask 0022 is correct. Please guys, could you start your VM as follows:

sudo chmod u+s /usr/bin/strace
strace -f -s64 -o ~/strace.log VirtualBox -startvm VM_NAME

then start the guest and perform the shared folders action which is supposed to fail and then compress ~/strace.log and attach it to this defect?

I tried doing that and I get an error when trying to start the VM:

VirtualBox: Error -10 in SUPR3HardenedMain!
VirtualBox: Effective UID is not root (euid=1000 egid=100 uid=1000 gid=100)

VirtualBox: Tip! It may help to reinstall VirtualBox.

What is the correct way to get the strace log?

comment:7 Changed 5 years ago by notessensei

The problem not only exists with Visual Studio but also with SmartDraw ( http://www.smartdraw.com). Upgraded from 2.1 to 2.2 Ubuntu 8.10 host WinXP guest. I can open files but not write back. Copying files using explorer or writing with Notepad works well. Upgraded to Ubuntu 9.04 host - problem persists.

comment:8 Changed 5 years ago by marcoc

Maybe the same problem: OpenOffice 3.0 Writer crashes trying to create a PDF file in a shared folder from an open document. A message box with "internal error" pops up and OO exits. This started when I upgraded to 2.2.2 or maybe even before with 2.2.0. Host: Linux Ubuntu 9.04 on AMD x64 dual-core. Guest: Windows 2000 SP4 AMD-V enabled with NP

comment:9 Changed 5 years ago by marcoc

Update: tried to reproduce with strace active, but got a 386MB log file. Just creating a PDF file into a shared folder works fine. What crashes OO is merge-printing to a PDF file in a shared folder.

comment:10 Changed 5 years ago by joha73

I experienced a similar problem with MP3Tag. However here smaller files (5MB) could be created but large files (100MB) not (access error).

By accident I found out that running VB v2.2.2 with Guest Additions v2.1.4 solves the problem. Maybe this hint helps in solving this issue?

comment:11 Changed 5 years ago by notessensei

I can confirm joha73 observation. I removed Guest Additions 2.2.2 and replaced them with Guest Additions 2.1.4 and the problem goes away. So the issue might be in the guest additions. Until the cause is found using 2.1.4 guest additions is a suitable work-around

comment:12 Changed 5 years ago by frank

Hmm, the problem is that I don't have Visual C++ available. I'm still interested in such an strace I mentioned in my last comment. Note that /usr/bin/strace has to be suid to make this work. And it should be possible to compress the resulting logfile very good with 'bzip2 -9' or something like this. You can even send me the compressed file directly by private E-mail to frank _dot_ mehnert _at_ sun _dot_ com.

comment:13 Changed 5 years ago by joha73

Just tried Virtual Box 2.2.4. The problem persists with Guest Additions v2.2.4 but the work-around with Guest Additions v2.1.4 still works.

Frank, how can I do the trace with Mac OS 10.5.7 as the host system? There seems to be a dtrace instead of strace but they seem to be not compatible regarding their options. Sorry, but I have no experience with such traces.

comment:14 Changed 5 years ago by frank

Rodrigo Linfati sent me a log which helped us finding the problem. This is indeed a regression from our previous umask fix. We will fix this problem with the next release.

comment:15 Changed 5 years ago by frank

  • Summary changed from [Regression] Access denied when saving in Visual C++ in shared folders to [Regression] Access denied when saving in Visual C++ in shared folders => Fixed in SVN

comment:16 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use