VirtualBox

Ticket #3760 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Guru meditation (PDMQueueFlush) enabling network connection => Fixed in SVN

Reported by: dogantuncer Owned by:
Priority: major Component: network
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

My Guest is Windows XP Professional SP3 with VirtualBox additions insalled. Host is Windows Vista SP1. I was disabled the network connection on guest machine. And then when i was trying to enable network connections everytime virtualbox crashes.

Attachments

VBox.log Download (227.7 KB) - added by dogantuncer 5 years ago.
Log file
VBox.jpg Download (117.8 KB) - added by dogantuncer 5 years ago.
screenshot
VBox.log.3 Download (242.2 KB) - added by Nick.Westgate 5 years ago.
Log for guru meditation on network enable.
VBox.png.3 Download (42.9 KB) - added by Nick.Westgate 5 years ago.
Screenshot for guru meditation on network enable.
VBox.2.log Download (277.8 KB) - added by sbenotreally 5 years ago.
2.2.4 crash windows xp vm enable network adapter
VBox.enable.network.adapter.crash.focus.log Download (634 bytes) - added by sbenotreally 5 years ago.
crash windows xp vm enable network adapter crash.focus.log
VBox.enable.network.adapter.crash.log Download (280.7 KB) - added by sbenotreally 5 years ago.
crash windows xp vm enable network adapter crash.log
VBox.3.log Download (263.3 KB) - added by JamieJackson 5 years ago.
VBox.png Download (242.7 KB) - added by JamieJackson 5 years ago.

Change History

Changed 5 years ago by dogantuncer

Log file

Changed 5 years ago by dogantuncer

screenshot

comment:1 Changed 5 years ago by Lelik

Unable to reproduce with the same host/guest configuration. Can you try disable/enable connection with Intel Pro/1000 guest network adapter?

comment:2 Changed 5 years ago by dogantuncer

I tried another adapter number but this time it says always limited connection. i have 4 guest already. two of these xp pro, an ubuntu, a windows7. before i update virtualbox to 2.2, netowrk connections of all of them was working troubleless. but when i upgrade to 2.2 windows guests begins can't connect internet. i tried ubuntu and it's troubleless but two winxp and a win7 can't connect after update.

comment:3 Changed 5 years ago by dogantuncer

also my host system's startup is very slow since VirtualBox Host-Only Network added to networks. sorry for my bad english.

comment:4 Changed 5 years ago by dogantuncer

i removed version 2.2 and i back to 2.1.4 and everything is fine now.

comment:5 Changed 5 years ago by frank

  • Summary changed from Enabling network connection to Guru meditation (PDMQueueFlush) enabling network connection

comment:6 Changed 5 years ago by Nick.Westgate

I had the same problem with host Vista Ultimate, guest Server 2003 (SP2 Evaluation Copy).

Will attach guru log and screenshot.

Cheers, Nick.

Changed 5 years ago by Nick.Westgate

Log for guru meditation on network enable.

Changed 5 years ago by Nick.Westgate

Screenshot for guru meditation on network enable.

Changed 5 years ago by sbenotreally

2.2.4 crash windows xp vm enable network adapter

Changed 5 years ago by sbenotreally

crash windows xp vm enable network adapter crash.focus.log

Changed 5 years ago by sbenotreally

crash windows xp vm enable network adapter crash.log

comment:7 in reply to: ↑ description Changed 5 years ago by sbenotreally

Replying to dogantuncer: Guru Meditation -2403 (VERR_TRPM_DONT_PANIC) when enable windows xp sp3 network adapter.

comment:8 Changed 5 years ago by sbenotreally

Circumvention: change adapter type to: Intel PRO/1000 MT Desktop (8254OEM)

comment:9 follow-up: ↓ 10 Changed 5 years ago by JamieJackson

Same symptom with XP SP3 guest on Ubuntu 9.04 host.

Host:
Ubuntu 9.04
Linux venus 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
VirtualBox (PUEL) 2.2.4

Guest:
XP SP3 with Guest Additions
PCnet-FAST III (Bridged) <= enabling crashes the VM

Tried using the Intel PRO/1000 MT Desktop as a workaround, but XP can't seem to find the driver, even if I add an extra NATed PCnet-FAST III (NAT) to let it search the internet for the driver.

How to reproduce:

Enabled NICs:
Adapter 1: PCnet-FAST III (NAT)
Adapter 2: PCnet-FAST III (Bridged adapter, eth0)

NIC Connection Status at XP Guest Startup:
Adapter 1: connected
Adapter 2: disconnected

XP shows:
LAN Connection: Disconnected*
LAN Connection 2: Network cable unplugged

*Actually, I wasn't expecting this to show as disconnected in XP. I think this was working properly before. Oh well, I'll keep going.

Right click LAN Connection, and choose "Enable"

...Cute Guru message shows up, and yields the files which I'll attach in a moment.

Changed 5 years ago by JamieJackson

Changed 5 years ago by JamieJackson

comment:10 in reply to: ↑ 9 Changed 5 years ago by JamieJackson

Replying to JamieJackson:

Guest:
XP SP3 with Guest Additions
PCnet-FAST III (Bridged) <= enabling crashes the VM

BTW, according to my "steps to reproduce" you'll see that this time I was enabling the NAT connection, and that caused error this time. (I think I've also had the problem on bridged connections.)

comment:11 Changed 5 years ago by rsrb

I had same problem and I solved this problem by removing all ethernet interfaces in ghost WinXP Device Manager and restart Win. After reboot Win find all interfaces and now working correct.

comment:12 Changed 5 years ago by danube

Same here on Ubuntu 9 with WinXP as guest. It seems that as soon as more than one network connection is present in the guest, it's not working to re-enable one disabled interface.

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Guru meditation (PDMQueueFlush) enabling network connection to Guru meditation (PDMQueueFlush) enabling network connection => Fixed in SVN

Duplicate of #4510, fixed in SVN.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use