VirtualBox

Ticket #3758 (new defect)

Opened 5 years ago

Last modified 4 years ago

Selecting usb in vbox 2.2 causes guest to crash

Reported by: Perryg Owned by:
Priority: major Component: USB
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Host Vista business all patches and updates installed. VBox 2.2. upgraded since 1.6 at each update interval. I have reinstalled VBox 2.2 running the service as Administrator. This guest was Ubuntu 8.10 (but happens an all other guests as well) Initially I have the USB set with a blank filter. If I set it to use the device at startup it crashes at startup.

Once in the guest I select the device from the devices tab and select it with the following results

This crash happens as soon as VBox tries to load the device program in Vista. I hear the sound of the USB device being stopped in Vista as well as the sound of it being started in the guest. It then crashes.

I must note that I never had this problem in any of the other versions of VBox.

Attachments

Ubuntu810-2009-04-16-12-39-03.log Download (39.8 KB) - added by Perryg 5 years ago.
Ubuntu-Jaunty-Karmic-2010-03-16-11-44-49.log Download (41.6 KB) - added by Perryg 4 years ago.
crash1.txt Download (1.1 KB) - added by Perryg 4 years ago.
crash1.jpg Download (16.7 KB) - added by Perryg 4 years ago.

Change History

Changed 5 years ago by Perryg

comment:1 Changed 5 years ago by Perryg

I could not attach this due to a Trac internal error so here is the Vista problem report:

Product VirtualBox GUI

Problem Stopped working

Date 4/16/2009 11:09 AM

Status Report Sent

Problem signature Problem Event Name: APPCRASH Application Name: VirtualBox.exe Application Version: 2.2.0.0 Application Timestamp: 49dba8b4 Fault Module Name: ole32.dll Fault Module Version: 6.0.6001.18000 Fault Module Timestamp: 4791a74c Exception Code: c0000005 Exception Offset: 0004be16 OS Version: 6.0.6001.2.1.0.256.6 Locale ID: 1033 Additional Information 1: 40b2 Additional Information 2: 43eff0b8396dd9ec770bf84edafb46da Additional Information 3: efee Additional Information 4: 219c22dda9944881028b992bc1f757ed

Extra information about the problem Bucket ID: 1219865916

comment:2 Changed 4 years ago by Perryg

Just checking if this is going to be able to work for me. I have updated through all of the maintenance and enhancement upgrades and nothing has changed. As you can see I am not trying to be pushy, just wondering. Additionally I had only noticed this with a Linux guest but this effect is in both Linux and Windows guests.

comment:3 Changed 4 years ago by frank

  • Version changed from VirtualBox 2.2.0 to VirtualBox 3.0.10

comment:4 Changed 4 years ago by Perryg

Just checking in since it has been a while. Is this getting any where near to working? Should I just give it up? I am up to 3.1.4-B1 and it is still not working.

comment:5 Changed 4 years ago by Perryg

Any word yet? I am seeing more and more complaints on the forum and don't even try to post to them anymore. I personally can live without USB but it would be nice to have.

comment:6 Changed 4 years ago by frank

Perry, can you create a Windows minidump for the current 3.1.4 release?

Changed 4 years ago by Perryg

Changed 4 years ago by Perryg

Changed 4 years ago by Perryg

comment:7 Changed 4 years ago by Perryg

Sorry Frank this is not a host crash it is an app crash. I have debug (VS2005)but no symbols for VBox. All it does say is that it was a violation. I have turned off UAC, added exceptions to DEP, and tried to run VB as admin. All fail.

The USB device then is not available to the guest nor the host. It says that it is busy when you try to access it after the crash and even unplugging it and re-plugging it the host does not see the change. It's like the device is tied to the app crash and Windows has no clue what to do with it.

Procedure: reboot the host. start VBox and select the guest. (no filters checked but present) click device tab and select the USB (thumb drive). Windows tone of released USB device and then tone for USB connected device. Windows installs the device software. App Crash.

I am attaching the latest windows crash reports and the latest log file for the guest as well as a jpeg of the crash indicator.

comment:8 Changed 4 years ago by Perryg

I just noticed something else when viewing the app crash report. It says that the version is 3.1.2! I have 3.1.4 installed and the GAs are 3.1.4. Why would Windows say 3.1.2?

comment:9 Changed 4 years ago by frank

Well, doesn't Windows create an application crash dump as well? We have debug symbols so we are interested in the crash dump.

comment:10 Changed 4 years ago by Perryg

Actually no it does not by default. I am downloading the windows driver kit now to setup Capturing Application Crash Dumps. Huge file. Only way to get ADPlus or DebugDiag. Oh well the more the merrier. Silly Windows. They did away with DrWatson after XP. I'll get you the information today or tomorrow depending on how the install goes.

comment:11 Changed 4 years ago by Perryg

Alrighty I have the dump but it is not a mini dump 59MB + the logfile for ADplus. I can attach everything but the dump which is to large how do we proceed?

comment:12 Changed 4 years ago by frank

Perry, thanks for the dump. Unfortunately, the crash dump looks like the VBoxSVC daemon terminated normally, no crash visible.

Regarding the version problem: Could you check the version of the VBoxSVC.exe binary (file properties / details)? In any doubt you should uninstall VBox and make sure to install VBox 3.1.4. Then try to reproduce the crash.

Btw, your above description of the crash looks like the VirtualBox.exe application crashed ...

comment:13 Changed 4 years ago by Perryg

I am stupid sometimes! I was not thinking right because VBoxSVC goes away instead of reading what I wrote and tied the debugger to the wrong process. VirtualBox_dump.zip is uploaded.

comment:14 Changed 4 years ago by frank

Hmm, still seems like VirtualBox.exe was terminated normally. Did this application actually crash?

comment:15 Changed 4 years ago by Perryg

That's what it says (Windows [see crash1 above]) and the guest does loose connection to the xml. After the app crash the VBoxSVC is missing from the process tree and you need to close the guests and the VBox main GUI (if it was open) then restart the VBox main GUI and everything comes back up and the VBoxSVC is put back in the process tree.

Everything works normally after without a reboot except the USB device says it is busy with another request.

You say that it states it terminated normally! But I did not terminate it nor did I terminate the VBoxSVC. Is there or should I debug a different process? I assume Windows must be terminating the dang thing due to (what it sees) as a violation of some sort. Any ideas where to look?

comment:16 Changed 4 years ago by frank

The .jpg image and you previous statements show that VirtualBox.exe crashed. Are you sure you did the right thing when saving the crash dump? Are you sure that only VirtualBox.exe crashed? If VBoxSVC crashes then VirtualBox.exe can crash as a result as well ...

comment:17 Changed 4 years ago by Perryg

OK I found what the problem was. I have an HP all-in-one printer. Disconnecting that allows the USB to work perfectly, even with a defined USB filter. (thanks for mentioning that I would have never thought about it). Now the problem is how in the heck am I going to be able to use the USB in VBox and one of the worlds most popular printers at the same time?

comment:18 Changed 4 years ago by Perryg

I just re-read this and didn't want you to think I was trying to blame VBox for this. My intention was to say HP has a track record of thinking it is the only device on your computer and was wondering how I was going to fix this. Well after uninstalling all HP software and having to edit the registry to remove over 100 different entries I finally have a great working VBox and the main PC is extremely fast. So the printer goes to my sister. She does not use USB for anything. Thanks for putting me on the right track.

comment:19 Changed 4 years ago by frank

It is still not proved that it is not the fault of VirtualBox but without a proper crash dump the chances for debugging this are quite low. :)

comment:20 Changed 4 years ago by Perryg

Well I don't know how. Windows says it is VirtualBox. VirtualBox says it is fine. What would I need to monitor? I have proven that removing the HP printer fixes this. I also know that it sets up various USB devices IE: SD card reader and the like plus another (non accessible USB emulated drive for itself). I was able to see most of them and their UUID and connect info (with the exception of the mysterious USB drive that it sets up) which is probably the real cause.

comment:21 Changed 4 years ago by frank

Perry, are you able to attach this printer to a Linux host? Does that make VBox on Linux crash as well?

comment:22 Changed 4 years ago by Perryg

I did but I did not try the USB on it at the same time. I will check today with USB and let you know.

comment:23 Changed 4 years ago by Perryg

I have successfully connected the printer to the Linux host and set defined filters for then USB thumb drive and it works as it is supposed to.

The Linux driver version is different then the Windows version and it does not install all the subsets of the Windows install IE: The extra Windows specific USB emulated software.

I tested this with Vista Guest 32-bit, XP guest both 32 and 64, Win 7 Pro 64-bit, Ubuntu 10.04 64-bit.

comment:24 Changed 4 years ago by Perryg

@Frank, I have my theory and will pass it along just in case you want to check it out. HP adds a USB device (emulated) for an SD card reader on the printer. The device can not actually be accessed unless there is something plugged into the card slot of the printer but does show up in the file manager as an actual drive. Trying to select it causes the nothing found please fix if you click on it in the file manager. I can only assume what happens when you check for available USB devices with your software when activating the USB hub the first time. That would also explain why once it fails you can (after the first failure) shut everything VBox down, restart VBox and then it will work ( with no filter) until the next host reboot.

Since I have uninstalled the HP printer and software not only does USB work it works flawlessly even using pre-defined filters. Rebooting the host, starting the guest with a defined USB filter and it pops up and works. One other thing I noticed is now the device driver installs in less then a 1/2 sec when you use it the first time instead of 3 seconds and crashing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use