VirtualBox

Ticket #3752 (reopened defect)

Opened 5 years ago

Last modified 4 years ago

DNS protocol problem with Vista hosts => check Shrew Soft Lightweight filter rules

Reported by: kirpi Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.2.0 Keywords: dns,bridged networking
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Hi,

With VirtualBox 2.2.0 r45846 installed on Vista 32-bit hosts, and bridged mode, DNS doesn't work. i.e. when I try to query a web site, I can't get a response.

I tried both of these systems:

  • Host: Vista Home Premium 6.0 Build 6001 Service Pack 1
  • Guest: Checkpoint SecurePlatform
  • Host interface: Intel Pro/Wireless 3945ABG.
  • Guest interface: PCnet-FAST III (Am79C973)
  • Host: Vista Ultimate 6.0 Build 6000
  • Guest: Fedora 10
  • Host interface: Intel Pro/Wireless 3945ABG
  • Guest interface: PCnet-PCI II (Am79C970A) or Intel PRO/1000 MT Desktop (82540EM)

The problem is strictly DNS. Because when I try to reach web sites over HTTP using their IP addresses I can do that. It seems every other traffic type is working but DNS. Check the output of the following commands please:

[Expert@cpmodule]# cat /etc/resolv.conf
nameserver 195.175.39.40
nameserver 195.175.39.39
[Expert@cpmodule]# ping 195.175.39.40
PING 195.175.39.40 (195.175.39.40) 56(84) bytes of data.
64 bytes from 195.175.39.40: icmp_seq=0 ttl=247 time=39.2 ms
64 bytes from 195.175.39.40: icmp_seq=1 ttl=247 time=32.4 ms

--- 195.175.39.40 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 32.410/35.849/39.288/3.439 ms, pipe 2
[Expert@cpmodule]# ping 195.175.39.39
PING 195.175.39.39 (195.175.39.39) 56(84) bytes of data.
64 bytes from 195.175.39.39: icmp_seq=0 ttl=252 time=29.5 ms
64 bytes from 195.175.39.39: icmp_seq=1 ttl=252 time=28.6 ms

--- 195.175.39.39 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1003ms
rtt min/avg/max/mdev = 28.633/29.101/29.570/0.498 ms, pipe 2
[Expert@cpmodule]# nslookup google.com
;; connection timed out; no servers could be reached

[Expert@cpmodule]# nslookup google.com 4.2.2.4
;; connection timed out; no servers could be reached

[Expert@cpmodule]# ping 74.125.67.100
PING 74.125.67.100 (74.125.67.100) 56(84) bytes of data.
64 bytes from 74.125.67.100: icmp_seq=0 ttl=242 time=167 ms
64 bytes from 74.125.67.100: icmp_seq=1 ttl=242 time=174 ms

--- 74.125.67.100 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 167.857/171.396/174.936/3.563 ms, pipe 2

Attachments

nictrace-vbox-ticket3752.pcap Download (6.8 KB) - added by czietz 5 years ago.
NIC trace while unsuccessfully trying DNS queries

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3655, fixed in SVN.

comment:2 Changed 5 years ago by kirpi

  • Status changed from closed to reopened
  • Resolution duplicate deleted

hello frank,

this is not a DHCP issue?! this is a DNS issue. my guest can't get DNS requests through the bridged network.. it has no problem obtaining an IP address from the DHCP server. As you could see in the logs, there was no problem connecting the internet other than DNS protocol.

By the way, I already checked ticket #3655. I actually have tried using  this dll that you have posted on that subject but it didn't help at all.

also, to show that this is not a DHCP problem, you can see above that DNS queries specifying a DNS server doesn't work either.

I am re-opening this ticket.

Kind regards, Kirpi

comment:3 Changed 5 years ago by frank

Kirpi, ok, I missed these facts. Are you sure that no firewall on the host is blocking some packages?

comment:4 Changed 5 years ago by kirpi

no firewalls are on. I actually used wireshark on the interface to see if any dns packets are forwarded but none are.

i also opened trace on the virtualbox guest. i'll attach the trace asap.

comment:5 Changed 5 years ago by czietz

I can reproduce this bug with VirtualBox 2.2.2 r46594. Host: Windows Vista Business Version 6.0 (Build 6001: Service Pack 1), Guest: Debian 5.0, Host interface: Intel(R) 82567LM Gigabit Network Connection, Guest interface: PCnet-FAST III.

Symptoms are exactly the same: All network traffic works except for DNS. I can ping hosts or reach them using their IP address, domain name resolution fails. (Obviously I checked that the DNS servers are set correctly in the guest OS.)

comment:6 Changed 5 years ago by frank

  • Description modified (diff)

Could you attach a network trace when doing DNS from the guest (VBoxManage modifyvm VM_NAME --nictrace1 on)?

Changed 5 years ago by czietz

NIC trace while unsuccessfully trying DNS queries

comment:7 Changed 5 years ago by czietz

@frank: You'll find a trace attached that contains all packets sent from and to the IP assigned to my VM guest. You can see that DHCP and ICMP (ping) work while there is no reply to DNS queries.

comment:8 Changed 5 years ago by czietz

PS: I forgot to mention: Host OS is a 64 bit (x64) Vista Business.

comment:9 follow-up: ↓ 10 Changed 5 years ago by frank

Thank you!

comment:10 in reply to: ↑ 9 Changed 5 years ago by tsvayer

Is there any resolution for this issue? I have Virtual Box 2.2.2,

Windows Vista 64bit as Host and Windows XP 32bit as guest with exactly the same DNS problem.

comment:11 Changed 5 years ago by tsvayer

Well, I have finally found the reason in my case. I have Shrew Soft VPN installed on Host and unchecking Shrew Soft Lightweight Filter in Network Connection Properties solved DNS problem.

comment:12 Changed 5 years ago by frank

  • Component changed from other to network/hostif

comment:13 follow-up: ↓ 14 Changed 5 years ago by czietz

tsvayer, thank you very much! Unchecking the Shrew Soft Lightweight Filter resolves the problem for me as well.

Unfortunately this is not a perfect solution since I can't permanently disable Shrew Soft VPN here.

comment:14 in reply to: ↑ 13 Changed 5 years ago by tsvayer

Well, it is not solution for me either, just a quick work around. At least we know the reason now. Hope it will be handled in the next release (or maybe it's Shrew who breaks "rules"? :S) Replying to czietz:

tsvayer, thank you very much! Unchecking the Shrew Soft Lightweight Filter resolves the problem for me as well.

Unfortunately this is not a perfect solution since I can't permanently disable Shrew Soft VPN here.

comment:15 Changed 5 years ago by tsvayer

It is the Shrew Bug. Exactly the same problem with VMWare:  http://www.shrew.net/support/ticket/6

comment:16 Changed 5 years ago by frank

  • Summary changed from DNS protocol problem with Vista hosts to DNS protocol problem with Vista hosts => check Shrew Soft Lightweight filter rules

tsvayer, thank you for investigating!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use