VirtualBox

Ticket #3743 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

segfault after connecting to virtual machine with rdesktop

Reported by: johwoesten Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.2.0 Keywords: segfault
Cc: Guest type: Windows
Host type: Linux

Description

I've set up a windows 2003 terminal server guest on a linux (CentOS 5.3) host with bridged networking on eth1. Logging in to that machine with "rdesktop" kills the guest and the following entries appear in "/var/log/messages":

   device eth1 entered promiscuous mode
   VirtualBox[2236]: segfault at 0000000000000026 rip 00000034b04758bb rsp 0000000040d9d770 error 4
   device eth1 left promiscuous mode

Attachments

VBox.log Download (39.2 KB) - added by johwoesten 5 years ago.

Change History

Changed 5 years ago by johwoesten

comment:1 Changed 5 years ago by Lelik

Unable to reproduce. Can login with rdesktop to the guest. 64 bit linux host 32 bit wik2k3 guest, just like your configuration.

comment:2 Changed 5 years ago by johwoesten

I can reproduce it on several machines (tried three different), as said with CentOS 5.3 (kernel 2.6.18-128.1.6.el5).
Right after logging in the guest crashes.
The same with bridged networking on eth0.

comment:3 Changed 5 years ago by Lelik

All three hosts were CentOS 5.3? I don't have CentOS host, tried in Ubuntu.

comment:4 Changed 5 years ago by frank

It could be the clipboard problem. Can you have a look at #3723 and try to replace the .so with the one attached to this defect?

comment:5 Changed 5 years ago by johwoesten

It was the clipboard problem. After replacing the .so the guest don't crash anymore.
Thx, Hannes.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the feedback, I will close this bug as duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use