VirtualBox

Ticket #3740 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

VBoxManage clonehd "/full_path_to/ext3disk.img" "/full_path_to/disk.vdi" doesn't work

Reported by: jors Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords: clone clonehd disk cloning
Cc: Guest type: Linux
Host type: Linux

Description

When trying to clone an ext3 image file to an VDI with the command from the subject, VirtualBox fails with the following error message:

jors@superdell:~$ VBoxManage clonehd "/full_path_to/ext3disk.img" "/full_path_to/disk.vdi" --format VDI
VirtualBox Command Line Management Interface Version 2.2.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

ERROR: Could not get the storage format of the hard disk '/full_path_to/ext3disk.img' (VERR_NOT_SUPPORTED)
Details: code VBOX_E_IPRT_ERROR (0x80bb0005), component HardDisk, interface IHardDisk, callee nsISupports
Context: "OpenHardDisk(src, AccessMode_ReadWrite, srcDisk.asOutParam())" at line 562 of file VBoxManageDisk.cpp

To discard source (ext3) filesystem problems that could lead VirtualBox to don't recognize the source filesystem type, I fsck'ed the filesystem to leave it clean before the cloning operation with no luck.

I also tried the following:

  1. Creating a 100MB file (zero-filled with dd).
  2. Formatting it to ext3.
  3. Mount it (as loopback) and copy some files in there.
  4. Sync it and unmount it.
  5. Tried to run again "VBoxManage clonehd", with same error result.

I can remember success on the same cloning action and with the same ext3 disk image with a previous version of VirtualBox (virtualbox-2.1_2.1.4-42893_Debian_lenny_amd64.deb). Also say that the source/original ext3 disk image comes from a production Xen virtual machine.

Please, do not hesitate to contact me for any other information I could provide.

Change History

comment:1 Changed 5 years ago by jors

Ok, my fault.

The right command to do this is "VBoxManage convertfromraw", not a bug.

PS. No coffe today :(

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use