VirtualBox

Ticket #3727 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Resizing windows in seamless mode not functioning properly -> fixed in SVN

Reported by: Shadowcat Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I shrink a window in seamless mode, it causes the Ubuntu Desktop to appear behind it where the window once was, and when I enlarge it, the edges of the window disappear. Guest is Ubuntu 9.04 Beta. This is causing horrible problems if I try to use Compiz with these windows, because they rectangle that draws around them with compiz effects enabled doesn't include the window border, so I can't move the windows unless I alt+click them.

Attachments

Ubuntu Studio-2009-04-14-02-23-15.log Download (65.3 KB) - added by Shadowcat 5 years ago.
Ubuntu_guest_on_Windows.png Download (184.1 KB) - added by alip 5 years ago.
Screenshot of partially cropped child window

Change History

Changed 5 years ago by Shadowcat

comment:1 Changed 5 years ago by michael

Are you talking about using both Compiz and seamless on the guest at the same time here? If so, are you also seeing problems if you disable Compiz on the guest?

comment:2 Changed 5 years ago by michael

Sorry, I just noticed that you are using a Windows host, so my question about whether Compiz is on the guest or not is a bit silly.

comment:3 Changed 5 years ago by Shadowcat

Compiz is disabled in the guest. Enabling Compiz causes more problems that I imagine are stemming from a similar source, but the problem occurs whether Compiz is enabled on the guest or not.

comment:4 Changed 5 years ago by michael

And when you are not using Compiz, does dragging seamless windows work normally?

comment:5 Changed 5 years ago by Shadowcat

No, the problem described, as I said, occurs whether Compiz is enabled on the guest or not. If I shrink the window, the Ubuntu desktop shows up behind it, and if I enlarge it, any part that leaves the window's original area of coverage is cut off, unless I leave and re-enter seamless mode. Dragging windows also causes a problem, with random pieces of windows disappearing, but that seems sporadic and I can't figure out what causes those pieces of windows to suddenly go away if I move to certain places. The places that cause it seem random.

comment:6 Changed 5 years ago by Shadowcat

Oh, do you mean, can I drag them by grabbing the window border with Compiz disabled? Yes, I can, unless I resize the window in a way that causes the border to get cut off...

comment:7 follow-up: ↓ 8 Changed 5 years ago by irontux

Hello I got a problem with seamles mode (Vista Host- Ubuntu 8.10 guest) with 2.14 versions I was able to enable/disbale seamles mode, but for this 2 last versions I could not, it seems. I had to remove guest addition and istall it the one from 2.1.4

And other times it looks like you describe it just with grey bar.

comment:8 in reply to: ↑ 7 Changed 5 years ago by irontux

Replying to irontux:

Hello I got a problem with seamles mode (Vista Host- Ubuntu 8.10 guest) with 2.14 versions I was able to enable/disbale seamles mode, but for this 2 last versions I could not, it seems. I had to remove guest addition and istall it the one from 2.1.4

And other times it looks like you describe it just with grey bar.

Just for notice, I changed manually following field from XML file to left as following (of curse the virtual box must be closed)

<ExtraDataItem name="GUI/Fullscreen" value="on"/> <ExtraDataItem name="GUI/Seamless" value="on"/> <ExtraDataItem name="GUI/AutoresizeGuest" value="on"/>

After I started mi machine, as notice just full screen was the one that it was working, so, I’ve change Fullscren using “Ctrl-F” and I did a reboot.

Now is working seamless… and the fileds are as following:

<ExtraDataItem name="GUI/Fullscreen" value="off"/> <ExtraDataItem name="GUI/Seamless" value="on"/> <ExtraDataItem name="GUI/AutoresizeGuest" value="on"/>

comment:9 Changed 5 years ago by alip

I had the same problem with Ubuntu 9.04 guest on Windows XP SP3 host. Problems started with Guest Additions 2.1.4 (could have been the upgrade of the guest from 8.10 to 9.04 too, can't remember which upgrade it actually was that broke seamless mode, sorry), upgrading to VirtualBox 2.2.2 and GA 2.2.2 did not help.

I noticed that most of the problems go away by setting the Ubuntu guest Visual Effects to "None". The only remaining problem is that application child windows do not draw completely in seamless mode. For example, if I launch Update Manager and click Settings, dragging the child window that pops up causes parts of the child window outside the area of the Update Manager parent window to be not drawn. Say the height of the child window is 100 pixels and I drag it to the right half way outside the parent window, then the left side of the child window is drawn from top to bottom, but only the top 80 pixels of the right side outside the parent window area is drawn.

Changed 5 years ago by alip

Screenshot of partially cropped child window

comment:10 Changed 5 years ago by alip

Uploaded a screenshot of cropped child window. Could be a variant of Ticket #3574. It seems only the portion of the child windows containing the "Close", "Cancel" etc. buttons are not rendered outside parent or other guest windows in the background.

comment:11 Changed 5 years ago by tholex

There is a workaround much easier than restarting seamless mode - just change the window to the desired size and switch between desktops (i.e. goto Desktop 1 and then Desktop 2).

I encountered this bug with most apps - Kate, Terminal (but not Firefox!) running guest Ubuntu 9 on Windows 7.

comment:12 Changed 5 years ago by michael

I have reproduced this (or something similar) and will have a go at fixing it.

comment:13 Changed 5 years ago by Karmaflute

I am having the exact same problem in Fedora 11 with VirtualBox 2.2.4 and the new VirtualBox 3 beta. It did not occur in the older versions of Fedora or even the Fedora 11 preview release.

The problem is reproducible out of the box. Just install Fedora 11 in VirtualBox, install the vb guest additions, and enter seamless mode.

I am using a Windows host as well, Windows 7 RC2. Here is my original thread:

 http://forums.virtualbox.org/viewtopic.php?f=3&t=18663&p=81496

comment:14 Changed 5 years ago by scott2449

This issue has occured in previous versions of Virtual Box:  http://www.virtualbox.org/ticket/808

comment:15 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.2.0 to VirtualBox 3.0.0
  • Summary changed from Resizing windows in seamless mode not functioning properly. to Resizing windows in seamless mode not functioning properly -> fixed in SVN

Fixed in SVN.

comment:16 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:17 Changed 5 years ago by scott2449

Just downloaded 3.0.2. This fix is in the changelog, but it still occurs for me. Anyone else still seeing it? Maybe its a configuration issue... will reserve a reopen for some more comments.

comment:18 Changed 5 years ago by michael

scott2449: this is a silly question, but did you update the Additions to version 3.0.2 in your guest? If you did, then a recipe to reproduce the issue would be much appreciated.

comment:19 Changed 5 years ago by Karmaflute

I thought it wasn't fixed as well on the first try. As scott2449 said, don't forget to reinstall the guest additions. This fixed it for me.

comment:20 Changed 5 years ago by scott2449

Thanks Michael, a reinstall of the guest additions fixed it. Definitely CLOSED.

comment:21 Changed 5 years ago by michael

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use