VirtualBox

Ticket #3725 (new defect)

Opened 5 years ago

Last modified 4 years ago

Display problems on Windows 2003 after reboot (4 bit color, 800x600 max), no resize

Reported by: sgventil Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.2.0 Keywords: display
Cc: Guest type: Windows
Host type: Windows

Description

I use virtual box for a while, on my laptop (windows XP SP2), and a windows 2003 server web edition guest. Some time ago, I had to restart my VM because of a source safe fix I installed. When the VM restarted, it was on 4-bit color mode and 640x480 resolution. I tried to change color and resolution, but the max I can get is 800x600 4-bit color.

Well, I updated virtualbox version three times (first to 2.1.0, then to 2.1.2, now to 2.2.0), removed additions, re-installed additions, etc., changed video memory (was 128M initially), but still the same problem.

Then I removed VirtualBox Graphics Adapter. Now I have 32-bit color mode and higher resolutions. Mouse pointer integration works fine, shared folders, etc. all works nice. The problem is that the guest display is not dynamically resizing as I resize the VM window.

After searching the forums and trying a lot of things, including re-installing virtual box, I even tried to run this VM on my desktop Mac. The VM behave exactly the same way it did on my XP laptop.

My temporary solution to work with this VM was to start it in headless mode, then connect to it via terminal services client (not to virtual box RDP, but to windows terminal services). This way, when I maximize terminal services client, I get full screen used.

Ok, this is a *temporary* solution. I'd like to have the same behavior I had before, resizing my VM window and getting it display resized accordingly. I've passed last 3 days digging in the forums, trying to find someone with the same problem, trying all solutions I could find for display problems, but nothing. It seems I am the only guy with this problem...

laptop: LG P1 Pro Express Dual
cpu: Intel Core2 T7200 @ 2.00 Ghz
ram: 3GB @ 997Mhz
graphics: ATI Mobility Radeon X1400
os: windows XP sp2
virtualbox: 2.2.0

Attachments

WIN2003BOX-2009-04-13-23-54-44.log Download (48.7 KB) - added by sgventil 5 years ago.
VM log file

Change History

Changed 5 years ago by sgventil

VM log file

comment:1 Changed 5 years ago by frank

You said you removed the VirtualBox Graphics Adapter and after that, at least the higher resolutions worked for you. Could you try to install the current VirtualBox guest additions once more if that makes any difference? If not you could remove the guest graphics adapter again of course ...

comment:2 Changed 5 years ago by sgventil

When I installed version 2.2.0, I did just that. Uninstalled old guest additions and installed current version. The problem persists. Removing VirtualBox Graphics adapter and using windows standard VGA adapter allows me to use higher resolutions and higher color depths. The problem is virtual box window resizing doesn't work.

comment:3 Changed 5 years ago by frank

Did you ever use the VBox guest additions successfully with that Win2003 guest? If so, which was the last working release?

comment:4 Changed 5 years ago by sgventil

Yes, I used this VM successfully for several weeks. Everything worked fine. During this time I've installed some software, did some reboots, never got problems. Suddenly, after installing a fix for source safe which required a reboot, the problems started.

I can't recall which VirtualBox version I had at that time, and consequently which guest additions version was installed. The only thing I am sure is the version was prior than 2.1.0, maybe 2.0.8 or 2.0.6

comment:5 Changed 5 years ago by Lelik

Can't reproduce this. Updated fresh Win2k3 installation three times: 2.1.0->2.1.2->2.1.4->2.2.0 Everything works well, resizing too. Maybe something broken in the guest...

comment:6 Changed 5 years ago by sgventil

The problem has nothing to do with VirtualBox version updates. I tried updating VirtualBox after getting the problem.

The problem maybe difficult to reproduce, since I used this VM for several weeks before the problem occurred. I you want, I can upload the VM to some place you want. It is 16GB in size.

comment:7 follow-up: ↓ 8 Changed 5 years ago by Martin von Wittich

I believe I'm having the same issue here. I'm running a Vista VM on a Ubuntu host; last night it installed the following updates:

* KB954430 (failed with "Code 643")
* KB915597 (success)
* KB954430 (this time successful)
* KB890830 (success)
* KB951847 (success)
* KB950974 (success)

None of these seem display related, but today the VM booted with 4-bit color mode and a fixed resolution of 800x600. The device manager shows no warnings; I can't find log entries in the Event Viewer that would explain this.

comment:8 in reply to: ↑ 7 Changed 5 years ago by Martin von Wittich

Nevermind, reinstalling the additions solved my problem.

comment:9 Changed 5 years ago by sgventil

well, I still have this problem. Updated to last VirtualBox version (2.2.4), moved the VM to my brand new MacBook Pro, but it's still there...

comment:10 Changed 5 years ago by axela

I had the same problem but with an WinXp guest and a linux ubuntu host. I discovered that the bug show up only if I put the memory of videocard to 128mb. If I lower the memory to 64mb or less everything work!

comment:11 Changed 5 years ago by sgventil

well, it worked! I've changed memory of videocard to 64MB, and voilà, it worked again as before. thank you.

comment:12 Changed 4 years ago by Technologov

sgventil : It is good that it worked.

Windows 2003 guests work here too. Both 32+64bit.

Host: Windows 7, x64, Core 2 Q6600, VBox 3.0.10 (and 3.1.0-BETA1). VT-x = on.

-Technologov

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use