VirtualBox

Ticket #3715 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

vboxadd-timesync sets the guest os clock ahead of host by 1 hour

Reported by: vaidyabala Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have the following configuration.

Vista 64 Host OS Ubuntu 9.0.4 Guest OS.

The guest os clock is exactly one hour ahead of host clock. Both have right time zones set and I have turned off UTC in /etc/default/rcS file (UTC=NO).

everytime i correct the date/time, after about 10 seconds, it resets the guest OS clock to be one hour ahead of host OS. I traced this problem to vboxadd-timesync. If this program is stopped, then clock stays correct.

vboxadd-timesync adds one hour to guest os clock for unknown reasons.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by frank

Please check if

  • any NTP server is running within the guest (not required)
  • the timezone is set correctly (check /etc/timezone)?

comment:2 in reply to: ↑ 1 Changed 5 years ago by fjp

Replying to frank:

Please check if

  • any NTP server is running within the guest (not required)
  • the timezone is set correctly (check /etc/timezone)?

That's not really the issue. The problem is that VirtualBox is still lacking a feature such as requested in  http://www.virtualbox.org/ticket/1310.

comment:3 Changed 5 years ago by frank

fjp, of course this is an issue. You can still fix the timezone and every modern Linux distribution allows to set the clock as local -- otherwise it wouldn't be possible to have Linux and (for instance) Windows on the same computer. I agree that VirtualBox should provide a setting like described in #1310 but with a correct guest setting, Linux guests can be successfully synchronized with the host clock even in the current state.

vaidyabala, you wrote that you set UTC=NO in /etc/default/rcS. Please set UTC=no (note the different case). The Ubuntu/Debian script handles this variable case-sensitive. After that, make sure you remove the file /etc/adjtime and then reboot the guest.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The reference ticket is solved, so closing this one.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use