VirtualBox

Ticket #3666 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows XP Professional x64 Guest will not boot up (AMD-V) -> fixed in SVN/3.0.4

Reported by: tonedef71 Owned by:
Priority: blocker Component: other
Version: VirtualBox 2.2.2 Keywords: windows xp x64 guest windows vista ultimate 64 host
Cc: Guest type: Windows
Host type: Windows

Description

Attempting to run a Windows XP Pro x64 image created with a previous version of VirtualBox fails by either hanging or BSOD. Attempts to reboot in Windows Safe Mode causes either the vm to hang after loading the C:\windows\system32\acpitabl.dat, or the BSOD with a registry error.

VirtualBox advanced settings: enable ACPI checked, enable IP APIC checked, enable VT-x/AMD-V checked, enable nested paging not checked, enable PAE/NX checked, IDE controller type PIIX4.

Guest Additions installed on the guest image are version 2.1.4.

The Host is Windows Vista Ultimate 64.

I noticed that VirtualBox 2.2.0 now offers a single installer for both i586 and x64 -- have there been any issues with the proper files being installed for the correct version of the host OS?

Attachments

VBox.log Download (47.6 KB) - added by tonedef71 5 years ago.
VBox_02.log Download (107.1 KB) - added by tonedef71 5 years ago.
Another VBox log file
just_after_reboot.png Download (31.2 KB) - added by tonedef71 5 years ago.
Screenshot after a reboot
just_before_safe_mode.png Download (48.3 KB) - added by tonedef71 5 years ago.
Screenshot: just before safe mode kicks in
just_after_safe_mode.png Download (32.8 KB) - added by tonedef71 5 years ago.
Screenshot: just after safe mode
just_before_bsod.png Download (20.3 KB) - added by tonedef71 5 years ago.
screenshot: a rare glimpse before a BSOD
bsod01.png Download (31.3 KB) - added by tonedef71 5 years ago.
screenshot: one of various BSODs
another_bsod_after_safe_with_command_prompt.png Download (31.7 KB) - added by tonedef71 5 years ago.
screenshot: another BSOD after safe mode with command prompt selected
Windows_XP_Pro_64.xml.1.7-windows.bak Download (5.9 KB) - added by tonedef71 5 years ago.
v1.7 xml config file for VM
Windows_XP_Pro_64.xml.1.6-windows.bak Download (5.9 KB) - added by tonedef71 5 years ago.
v1.6 xml config file for VM
bsod_during_install.png Download (54.4 KB) - added by tonedef71 5 years ago.
This BSOD occurs during installation of Windows XP Pro x64.
hang_during_install.png Download (35.1 KB) - added by tonedef71 5 years ago.
Windows XP Pro x64 hangs during setup
WinXpPro64_hangs_during_install.log Download (41.0 KB) - added by tonedef71 5 years ago.
VirtualBox log from when Win Xp Pro 64 installer hangs
WinXpPro64_BSOD_during_install.log Download (45.7 KB) - added by tonedef71 5 years ago.
VirtualBox log from when Win Xp Pro 64 installer BSODs
WinXpPro64_shutdown_after_hanging_during_install.log Download (52.2 KB) - added by tonedef71 5 years ago.
VirtualBox log of Win XP Pro 64 installer shut down after it hung
WinXpPro64_v2.1.4_working_correctly.log Download (48.7 KB) - added by tonedef71 5 years ago.
VirtualBox log of Win XP Pro 64 guest from working v2.1.4 installation
WinXpPro_hangs_during_install_300b2.log Download (49.4 KB) - added by tonedef71 5 years ago.
VirtualBox v3.0.0b2 log from when Win Xp Pro 64 installer hangs
WinXpPro_hangs_during_install_300final.log Download (50.3 KB) - added by tonedef71 5 years ago.
VirtualBox v3.0.0 final log from when Win Xp Pro 64 installer hangs

Change History

Changed 5 years ago by tonedef71

comment:1 follow-up: ↓ 3 Changed 5 years ago by sandervl73

Does it hang/crash during early boot?

comment:2 follow-up: ↓ 5 Changed 5 years ago by Lelik

Unable to reproduce this problem. Installed with 2.1.4 image work fine with 2.2.0. Can you post BSOD information here please?

comment:3 in reply to: ↑ 1 ; follow-up: ↓ 4 Changed 5 years ago by tonedef71

Replying to sandervl73:

Does it hang/crash during early boot?

It does one or the other. Perhaps it's a timing thing.

comment:4 in reply to: ↑ 3 Changed 5 years ago by tonedef71

Replying to tonedef71:

Replying to sandervl73:

Does it hang/crash during early boot?

It does one or the other. Perhaps it's a timing thing.

I noticed that it is more likely to hang if I restart Windows normally, and more likely to BSOD if I start with one of the safe mode options. But I've seen it both hang and BSOD for any occasion.

Changed 5 years ago by tonedef71

Another VBox log file

Changed 5 years ago by tonedef71

Screenshot after a reboot

Changed 5 years ago by tonedef71

Screenshot: just before safe mode kicks in

Changed 5 years ago by tonedef71

Screenshot: just after safe mode

Changed 5 years ago by tonedef71

screenshot: a rare glimpse before a BSOD

Changed 5 years ago by tonedef71

screenshot: one of various BSODs

Changed 5 years ago by tonedef71

screenshot: another BSOD after safe mode with command prompt selected

comment:5 in reply to: ↑ 2 Changed 5 years ago by tonedef71

Replying to Lelik:

Unable to reproduce this problem. Installed with 2.1.4 image work fine with 2.2.0. Can you post BSOD information here please?

The BSOD doesn't always show the same information -- there are at least three different variations. Also, a reboot occurs immediately after the complete blue screen appears, so I'm unable to get a good screenshot -- I've done my best to pause and snap a screenshot.

I find it hard to believe that I'm the only user having this issue. The hanging or BSOD consistently happens to me with any of my Windows XP x64 images -- the 32-bit Windows XP images do not exhibit this behavior with version 2.2.0, although they do seem noticeably slower to start up. This issue with starting Windows XP 64-bit did not occur with the previous version 2.1.4.

When trying to reproduce this issue, did you test with Windows Vista Ultimate 64-bit edition SP1 as the host OS?

comment:6 Changed 5 years ago by Lelik

Yes, Visa Business SP1 64 bit host OS.

comment:7 Changed 5 years ago by tonedef71

Would somebody please take a quick look at the my XML configuration files to see if VirtualBox 2.2.0 correctly converted them from version 1.6 to version 1.7? I will attach both 1.6 (before) and 1.7 (after) files.

Changed 5 years ago by tonedef71

v1.7 xml config file for VM

Changed 5 years ago by tonedef71

v1.6 xml config file for VM

comment:8 Changed 5 years ago by tonedef71

64-bit guest support is still broken in v2.2.2. I forgot to mention that I am running on an AMD Turion 64 x2 processor. Could this be a problem only with AMD 64-bit processors?

comment:9 Changed 5 years ago by frank

64-bit guests usually run fine on 64-bit AMD processors, must be something specific to your setup. Did you change any setting after you created the guest image with VirtualBox 2.1.4? And I assume that the guest was running fine with 2.1.4? Did you create the image on the same host or was the image created on a different host -- perhaps with a different host CPU?

comment:10 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.2.0 to VirtualBox 2.2.2

Is there any chance that you uninstall the old guest additions (booting in safe mode) or are you unable to boot that far?

comment:11 Changed 5 years ago by tonedef71

Is there any chance that you uninstall the old guest additions (booting in safe mode) or are you unable to boot that far?

I'm unable to boot that far when v2.2.0+ is installed. I could try to remove the guest additions while I have v2.1.4 installed. Would that method be just as useful?

comment:12 follow-up: ↓ 13 Changed 5 years ago by frank

Yes, indeed. Thank your for testing.

comment:13 in reply to: ↑ 12 Changed 5 years ago by tonedef71

Replying to frank:

Yes, indeed. Thank your for testing.

OK, I removed the guest additions from Windows XP Professional x64 SP2 guest, and fired up the VM. It still BSODs and reboots in an endless cycle.

I guess we can cross off preinstalled older guest additions as the culprit.

What should we try now?

comment:14 in reply to: ↑ description Changed 5 years ago by tonedef71

My Windows XP Professional x64 guest image is still not booting on VirtualBox v2.2.4. Next I will attempt to create a new Windows XP Pro x64 VDI image on v2.2.4 and see what happens. I will post my results.

Changed 5 years ago by tonedef71

This BSOD occurs during installation of Windows XP Pro x64.

Changed 5 years ago by tonedef71

Windows XP Pro x64 hangs during setup

comment:15 Changed 5 years ago by tonedef71

I am unable to create a new Windows XP Pro x64 VDI image on v2.2.4. The install hung after the setup had reached the message "Setup is starting Windows". I restarted the VM and the next time setup reached the message "Setup is starting Windows", the installer BSOD'd. Subsequent restarts result in either the hanging or the BSOD. I've attached screenshots of both possibilities.

Has anyone else with a HP Pavilion TX2110us laptop experienced this problem running VirtualBox v2.2.x on a Windows Vista Ultimate 64-bit host while trying to create a Windows XP Pro x64 guest image?

Since Virtual Box v2.2.0, I've been unable to run 64-bit Windows XP Pro guests. This problem does NOT happen with VirtualBox v2.1.4. Is there anymore information I can provide to help troubleshoot this problem? I don't want to remain on v2.1.4 forever.

Changed 5 years ago by tonedef71

VirtualBox log from when Win Xp Pro 64 installer hangs

Changed 5 years ago by tonedef71

VirtualBox log from when Win Xp Pro 64 installer BSODs

Changed 5 years ago by tonedef71

VirtualBox log of Win XP Pro 64 installer shut down after it hung

Changed 5 years ago by tonedef71

VirtualBox log of Win XP Pro 64 guest from working v2.1.4 installation

comment:16 Changed 5 years ago by tonedef71

For comparison purposes, I attached a log that was created with VirtualBox v2.1.4 running Windows XP Pro 64. Since v2.1.4 is able to boot the image, perhaps there are clues in the log file to show what is happening differently between v2.1.4 and v2.2.x installations during bootup of the guest image on my laptop.

comment:17 follow-ups: ↓ 18 ↓ 19 Changed 5 years ago by sandervl73

Does it make any difference if you change the boot order to boot from the attached hard disk first?

comment:18 in reply to: ↑ 17 Changed 5 years ago by tonedef71

Replying to sandervl73:

Does it make any difference if you change the boot order to boot from the attached hard disk first?

When trying to install XP from CD, booting from hard disk is not possible as there is no OS installed on the virtual disk yet. When I start the VM, hit F12, and boot from the virtual hard disk, the following message appears: "FATAL: No bootable medium found! System halted."

I don't think it matters about the hard disk. XP 64 installer crashes before anything gets written to the hard disk -- it crashes when it tries to run the XP x64 kernel. It may be that the kernel for a 64-bit XP guest fails on VirtualBox 2.2.x or higher when running on an AMD Turion x2 processor or perhaps on a particular chipset used with AMD Turion x2 processors.

comment:19 in reply to: ↑ 17 Changed 5 years ago by tonedef71

Replying to sandervl73:

Does it make any difference if you change the boot order to boot from the attached hard disk first?

I'm sorry -- I had misunderstood what you meant by boot order. I did find the boot order menu option and it certainly is not the same as pressing F12 and selecting the hard disk. So I changed the boot order to favor the hard disk and restarted the virtual machine. The XP installer ran from the CD and crashed at the very same place during the install ("Setup is starting Windows"). So to answer your question, it does not make any difference when booting from hard disk first.

comment:20 follow-up: ↓ 21 Changed 5 years ago by sandervl73

You can try 3.0.0 beta 2 (released later today) if you don't mind running beta software. There's a fix in there for xp 64 related timing.

comment:21 in reply to: ↑ 20 ; follow-up: ↓ 22 Changed 5 years ago by tonedef71

Replying to sandervl73:

You can try 3.0.0 beta 2 (released later today) if you don't mind running beta software. There's a fix in there for xp 64 related timing.

Yes, I would be interested in trying the new beta. When will it be released? I did not see the new beta 2 at download.virtualbox.org today.

comment:22 in reply to: ↑ 21 ; follow-up: ↓ 23 Changed 5 years ago by tonedef71

Replying to tonedef71:

Replying to sandervl73:

You can try 3.0.0 beta 2 (released later today) if you don't mind running beta software. There's a fix in there for xp 64 related timing.

Yes, I would be interested in trying the new beta. When will it be released? I did not see the new beta 2 at download.virtualbox.org today.

Ok, I've downloaded 3.0.0 beta 2. I will install it and post my findings.

comment:23 in reply to: ↑ 22 Changed 5 years ago by tonedef71

Replying to tonedef71:

Replying to tonedef71:

Replying to sandervl73:

You can try 3.0.0 beta 2 (released later today) if you don't mind running beta software. There's a fix in there for xp 64 related timing.

Yes, I would be interested in trying the new beta. When will it be released? I did not see the new beta 2 at download.virtualbox.org today.

Ok, I've downloaded 3.0.0 beta 2. I will install it and post my findings.

I was hopeful, but 3.0.0 beta 2 did not correct the issues. The XP x64 installer still BSODs or hangs at "Setup is starting Windows", and existing XP x64 virtual machines (created with v2.1.4 or earlier) still hang or BSOD at boot.

Please see the following forum topic thread for related info:  http://forums.virtualbox.org/viewtopic.php?f=2&t=18526

Changed 5 years ago by tonedef71

VirtualBox v3.0.0b2 log from when Win Xp Pro 64 installer hangs

comment:24 follow-up: ↓ 25 Changed 5 years ago by sandervl73

Try again with the final 3.0 release. We've fixed an issue on win64 hosts that would cause random guest crashes.

Changed 5 years ago by tonedef71

VirtualBox v3.0.0 final log from when Win Xp Pro 64 installer hangs

comment:25 in reply to: ↑ 24 Changed 5 years ago by tonedef71

I tried the final 3.0 release, and as I'm sure you've probably guessed, nothing has changed -- the issue still remains. I uploaded the log file from this attempt.

Replying to sandervl73:

Try again with the final 3.0 release. We've fixed an issue on win64 hosts that would cause random guest crashes.

comment:26 Changed 5 years ago by mrdak

Same problem here. Virtual box 2.1 works since 2.2 to 3 is broken. I have changed from Windows XP 64 to Windows Vista (Ultimate, Bussines no luck) AMD X2 5200 on an Asus M3n78-VM with 6GB RAM.

Do you really guys want to fix it? How can i help?

comment:27 Changed 5 years ago by nille02

I have currently an "DualCore AMD Athlon 64 X2, 2100 MHz (10.5 x 200) 4000+" on an "ASRock ALiveNF7G-HDready". I have test all available BIOS Versions since v1.2 up to the current 2.1 and since Virtual Box 2.2 all 64bit Windows Guests are Broken. The last working version is 2.1.4. I have posted the problem in the Forum loot at  http://forums.virtualbox.org/viewtopic.php?f=2&t=18526

I have now Setup the Host two times. First Vista Home Premium 64bit and Windows xp x64 and on both OS i have the same issue. If you need more Informations please say it an i try ti get it.

comment:28 Changed 5 years ago by sandervl73

  • Summary changed from Windows XP Professional x64 Guest will not boot up to Windows XP Professional x64 Guest will not boot up (AMD-V) -> fixed in SVN/3.0.4

Found and fixed the problem. The bug is timing sensitive, so it may not appear on another machine or even every time.

comment:29 Changed 5 years ago by Roger

Hi, I understand this bug is fixed in 3.0.4, when is it expected that this fixed version (binaries) can be downloaded for windows hosts? Or should I download the sources and build my own?

comment:30 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use