VirtualBox

Ticket #3665 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

New network model = degraded performance

Reported by: LeXa2 Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords: network bridge tun tap
Cc: Guest type: Windows
Host type: Linux

Description

There is severe network throughtput degradation between host and guests under linux hosts when using bridged networking since VirtualBOX changed its networking model not to use tun/tap and host-side bridging.

How to reproduce:

Sample prerequisites: Fedora 8 host, Windows XP guest, any ethernet card as eth0 on host with link up on 100MBit and any 1GBit guest NIC.

First try:

1. Set guest to use bridged networking, bridge its NIC with eth0 host interface.
2. Boot up guest and use any network channel bandwidth test utility to test network througthput between host<=>guest.
3. Result: approx. 100MBit. (95MBit in my case)

Second try:

1. Create new tap interface on host with command like:

# tunctl -t tap200
# ifconfig tap200 up

2. Create new host-side brigde:

# brctl addbr br0
# brctl addif br0 eth0
# brctl addif br0 tap200

3. Set guest to use bridged networking, bridge its NIC with tap200 host interface.
4. Boot up guest and use any network channel bandwidth test utility to test network througthput between host<=>guest.
5. Result: much more than 100MBit (approx.250MBit in my case, possible bottleneck - CPU).

Conclusion: looks like current network bridging model limits virtual NIC throughtput by the speed of physical network interface they are bridged to. It results in severe performance regression for users switching from tun/tap + host bridging model to new "one fancy click in GUI" bridging model.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Bridged/host-only networking was improved in the meantime and the difference shouldn't be that big anymore.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use