VirtualBox

Ticket #3659 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

Installation of VB 2.2.0 rolls back, ending 'premature' on WinXPsp3 host

Reported by: maxmorio Owned by:
Priority: major Component: installer
Version: VirtualBox 2.2.0 Keywords: 2.2.0 setup installer
Cc: Guest type: Linux
Host type: Windows

Description

I just tried to install VB 2.2.0 over a existing VB 2.2.0beta2 on WinXPsp3 (used this beta, because it fixed hibernation issues associoted with VTx being enabled on WinXP/IntelCoreDuo/>2GB RAM - Hosts).

Setup wizard ends up in a rollback at setup wizard (ending 'prematurely' at install procedure).

No, it is even not possible to uninstall the beta2 via Windows Systemsmanager (asking for VirtualBox-2.2.0_BETA2-r45227-MultiArch_x86.msi in C:\DOKUME~1\Max\LOKALE~1\Temp\VirtualBox\.

The file doesn't exist any more. Trying to change/repair the Beta2 installation also ends up in a failure message ('prematurely').

Rebooting does not fix anything for me, I also tried to install the 2.2.0 with Custom Setup Options it doesn't seem to play a role whether "Networking" or "USB-Support" is chosen at Custom Setup in the Setup Wizard, like reporte i.e. be MrEasy in the EndUserForum.  http://forums.virtualbox.org/viewtopic.php?f=1&t=16197&start=15#

Extracting the MSI from the Installer-EXE and executing it, like:

VirtualBox-2.2.0-45846-Win.exe -extract
msiecex /i VirtualB....x86.msi

ends up the same.

At least, the 2.2.0beta2 installation seems to work like before that installation attempt :\

Any ideas, hints or even solutions to this are appreciated.

Attachments

MSI60dff_log.zip Download (41.8 KB) - added by maxmorio 5 years ago.
MSI60dff.LOG (installer log for MSI host installer)
VBOXLOGS.zip Download (72.0 KB) - added by bigo 5 years ago.
MSI and setupapi logs
mandianme_3659_2.2.2.zip Download (110.5 KB) - added by mandianme 5 years ago.
Screenshot of installation window and MSI debug log.

Change History

Changed 5 years ago by maxmorio

MSI60dff.LOG (installer log for MSI host installer)

comment:1 Changed 5 years ago by Mikee99

Hi,

I experienced the same issue. My host system is running Vista 32-bit.

I was, however, able to fix the problem. I first repaired the Beta 2 installation. After that, I was able to uninstall beta 2. I then successfully installed VB 2.2.0.

I hope that helps.

comment:2 Changed 5 years ago by maxmorio

Sorry, does not work for me!

Attemptimg repair beta2 also ends up in asking for the VirtualBox2.2.0_BETA2-r45227-MultiArch_x86.msi in the temp-folder at local settings dir of my account

Trying the uninstall of the Beta2 ends with quitting the installation wizard and popping up a messagebox just saying critical error ("Schwerwiegender Fehler")...

comment:3 follow-up: ↓ 4 Changed 5 years ago by maxmorio

That workaround seem to be doing the thing:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=16242&p=68449&hilit=beta2+2.2.0#p68449 Removing VirtualBox program folder and renaming the VB-folders in documents and settings Installing the VB2.1.4. After that updating to 2.2.0 worked fine! Copied the old XML-files to the actual .VirtualBox folder to restore my old settings.

Had not to touch the registry manually.

It seems to be a problem with the 2.2.0beta2 installation, not the VB2.2.0 release.

comment:4 in reply to: ↑ 3 Changed 5 years ago by bigo

It seems to be a problem with the 2.2.0beta2 installation, not the VB2.2.0 release.

I don't think it's related to the 2.2.0beta2 installer.

The rollback issue did not appear to me when I tried to upgrade 2.1.4 -> 2.2.0 as the upgrade was somewhat successful. I just had networking broken so much that i thought a clean install of 2.2.0 might help. The installation process of 2.2.0 this time ended up with an error and a rollback.

comment:5 Changed 5 years ago by bigo

I looked at the msi logfile, and it seems that in my case it fails when trying to install VBOXNETFLT.INI and then proceeds to the rollback - here's the line:

DIFXAPP: ERROR: Failed to install the network driver INF C:\WINDOWS\system32\DRVSTORE\VBoxNetFlt_E338D15A243AB5CA688D32E864D488D6E556F740\VBoxNetFlt.inf. Error code 0x643

Changed 5 years ago by bigo

MSI and setupapi logs

comment:6 Changed 5 years ago by bigo

I can confirm what I wrote in last post. 2.2.0 installs fine for me provided that i choose not to install networking, so it related to the networking drivers or their installation process.

comment:7 follow-ups: ↓ 8 ↓ 10 Changed 5 years ago by misha

To all having issues with bridged interfaces not being displayed or having the install problems on windows:
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

To all not being able to uninstall VBox 2.2 on windows:
Please see my comment 6 to #3701

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 5 years ago by maxmorio

Replying to misha:

To all having issues with bridged interfaces not being displayed or having the install problems on windows:
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

To all not being able to uninstall VBox 2.2 on windows:
Please see my comment 6 to #3701

Thanks for that info. Concerning uninstall of VBox 2.2: Im my case this affecet the VBox 2.2beta2 release! Please see my comment from 2009-04-10, here. This solution worked for me. Don't know if the hints in Ticket #3701 (and #3663) are handling the exactly same issue...

The MSI60dff.LOG (installer log) i attached seems to reveal a problem with usb support, when trying to install the 2.2.0 release over an existing 2.2.0 beta.

I did not have any problems with bridged networking (compare bigos comments here, which IMHO describe another issue). Those and all others having install/uninstall issues, will appreciate your support.

comment:9 in reply to: ↑ 8 Changed 5 years ago by misha

Replying to maxmorio:

Thanks for that info. Concerning uninstall of VBox 2.2: Im my case this affecet the VBox 2.2beta2 release! Please see my comment from 2009-04-10, here. This solution worked for me. Don't know if the hints in Ticket #3701 (and #3663) are handling the exactly same issue...

Yes, the issues with 2.2 release seems to be exactly the same as was seen with 2.2beta

The MSI60dff.LOG (installer log) i attached seems to reveal a problem with usb support, when trying to install the 2.2.0 release over an existing 2.2.0 beta.

I did not have any problems with bridged networking (compare bigos comments here, which IMHO describe another issue). Those and all others having install/uninstall issues, will appreciate your support.

These install issues should be solved as well with the test build I mention, so just send me a mail at Mikhail dot Sennikovsky at sun dot com of you wish to try the fix.

comment:10 in reply to: ↑ 7 Changed 5 years ago by bigo

Replying to misha:

To all having issues with bridged interfaces not being displayed or having the install problems on windows:
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

To all not being able to uninstall VBox 2.2 on windows:
Please see my comment 6 to #3701

I have installed the test version supplied by Micha. This version did not have the rollback problem and upgraded from 2.1.4 flawlessly. Everything seems to be working normally including networking ( NAT & bridged ) and USB.

comment:11 in reply to: ↑ description Changed 5 years ago by maletin

i upgraded from 2.1 stable to 2.2. because my bridged network was not working, i deinstalled 2.2. now i can't install it again. i'm using winXPsp3 as host.

comment:12 Changed 5 years ago by The MAZZTer

I have this problem as well. I believe it occurs when you upgrade VirtualBox. I subsequent install succeeds, but requires a restart because the VBoxDrv kernel driver does not properly shut down and thus the driver cannot be replaced until next boot (nor can VirtualBox be used).

The VBoxDrv problem may actually have occurred during the previous failed install (though I never checked so I don't know). The same problem is present in 2.2.0beta2's installer/vboxdrv.

comment:13 Changed 5 years ago by pentagonik

As we gonna release a new version of VBox soon, please write me an e-mail to pentagonik at sun dot com to get the latest test version of VBox which now should be possible to install on your system. Please let me also know your host OS (Windows only!) and a short error description plus VBox version you tried to install before. Thanks!

comment:14 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please try again with 2.2.2 and reopen if necessary.

comment:15 Changed 5 years ago by maxmorio

Confirmed. After having 2.2.2 installed. Uninstall issue is gone! Thanks again.

comment:16 Changed 5 years ago by sandervl73

Thanks for the feedback!

comment:17 Changed 5 years ago by potto007

  • Status changed from closed to reopened
  • Resolution fixed deleted

I presently have VB 2.2.0 installed on a Windows XP Pro SP3 system. After upgrading from 2.1.4, the VB network adapter stopped working (I'm using NAT to overcome that). Now, attempting to upgrade to 2.2.2, the removal process rolls backs. I have tried to remove 2.2.0 first, to no avail. I have rebooted, with no affect. How do I look at the MSI logs to post here?

comment:18 follow-up: ↓ 19 Changed 5 years ago by misha

Due to some issues with VBox 2.2 installation you need to uninstall VBox 2.2 first.
In case you have problems with 2.2 uninstall please follow the instructions in  http://www.virtualbox.org/ticket/3701#comment:6 on how to fix the uninstall problem.

comment:19 in reply to: ↑ 18 Changed 5 years ago by potto007

Replying to misha:

Due to some issues with VBox 2.2 installation you need to uninstall VBox 2.2 first.
In case you have problems with 2.2 uninstall please follow the instructions in  http://www.virtualbox.org/ticket/3701#comment:6 on how to fix the uninstall problem.

That worked for me. Thank you! I was able to successfully uninstall 2.2.0 and then install 2.2.2.

comment:20 Changed 5 years ago by Tyra Misoux

I just upgraded to new version 2.2.2 (old version I was using was 2.2.0) and have this problem. After "installation" the "sun\virtulabox" folder was deleted. Everything worked pretty cool so far. My System is a windows XP - lightweight installation without any toolbars and snakeoil-virus-scanners neither executables from untrusted resources.

comment:21 Changed 5 years ago by elfring

I have tried to uninstall the previous release 2.2.0 and to install the current software. Unfortunately, it did not work. I find the following informations in the event log: "Removal failed" and "Installation failed".

comment:22 follow-up: ↓ 26 Changed 5 years ago by elfring

I have got some progress after  registry adjustments.

Unwanted effects:

comment:23 Changed 5 years ago by Tyra Misoux

Thanx misha, This "fix the uninstall problem" link did it for me! I did not realize it is a "uninstall problem". you made my day. greets from berlin

comment:24 follow-up: ↓ 25 Changed 5 years ago by mandianme

This issue has recurred on my ACER Aspire 5630 laptop with WinXP-SP3 for "VirtualBox-2.2.2-46594-Win.exe" build.
I proceeded with normal installation with all the default options.
Please see the attached MSI installation debug log file (mandianme_3659_debug.log) and the installation screen snapshot (mandianme_3659.png).

Changed 5 years ago by mandianme

Screenshot of installation window and MSI debug log.

comment:25 in reply to: ↑ 24 Changed 5 years ago by misha

Replying to mandianme, elfring, Tyra Misoux: Please see my comment 18

comment:26 in reply to: ↑ 22 ; follow-up: ↓ 27 Changed 5 years ago by misha

Replying to elfring: could you attach a  minidump for your crash?

comment:27 in reply to: ↑ 26 Changed 5 years ago by elfring

Replying to misha: I can not attach a small memory dump file for the observed crashes so far despite the system setting shows that this "feature" should be enabled.

comment:28 Changed 4 years ago by Technologov

Is this still relevant for v3.x ?

-Technologov

comment:29 Changed 4 years ago by pentagonik

  • Status changed from reopened to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use