VirtualBox

Ticket #3649 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Host interface networking crashed the host (CentOS 5.3 x86_64) => Fixed in SVN

Reported by: ps Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 2.1.4 Keywords: host interface networking crash
Cc: Guest type: other
Host type: Linux

Description

When host interface networking is used, the host crashes on guest VM startup; machine freezes, two keyboard LEDs start blinking and the host even cannot be reached from the network any more.

Host is a Core2Quad Q9400, 8 GB RAM, Mainboard is Asus P5B Deluxe, eth0 is the onboard Marvell 88E8001 Gigabit Ethernet Controller. Host OS is CentOS 5.3 x86_64, and eth0 uses the skge driver. Crash occurs with kernels 2.6.18-128.el5 and 2.6.18-128.1.6.el5.

Guest VM OS is Win2000; I have cloned this from my laptop where this setup with VirtualBox 2.1.4 (64bit) is running without a problem on Ubuntu 8.04.2 (kernel 2.6.24-23-generic). Please note: the crash also occurs if I try a CentOS 5.2 (32bit) guest VM instead, so this does not seem to be related to the guest.

After reboot, /var/log/messages has these entries as the last ones before the crash:

Apr  6 02:53:26 euler kernel: VBoxDrv: dbg - g_abExecMemory=ffffffff88d74ac0
Apr  6 02:53:26 euler kernel: vboxdrv: fAsync=0 offMin=0x488 offMax=0x1aa0
Apr  6 02:53:26 euler kernel: vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
Apr  6 02:53:26 euler kernel: VBoxNetFlt: dbg - g_abExecMemory=ffffffff88f16ce0
Apr  6 02:55:36 euler kernel: device eth0 entered promiscuous mode
Apr  6 02:59:20 euler syslogd 1.4.1: restart.

I tried the workaround (I think from tickets 2827/2829) suggested here:  http://forums.virtualbox.org/viewtopic.php?f=7&t=16082 but this did not help.

Attachments

VBox.log Download (30.6 KB) - added by ps 5 years ago.

Change History

Changed 5 years ago by ps

comment:1 Changed 5 years ago by ps

The issue still exists with VirtualBox 2.2.0. This time however, the host does not crash immediately, but very soon after guest VM startup. Judging from /var/log/messages it is even the case that the host (euler, 192.168.1.1, running sama) and the guest (win-client, 192.168.1.150) communicate with each other over the host interface link to negotiate who is master browser.

Apr  9 15:43:08 euler kernel: VBoxDrv: dbg - g_abExecMemory=ffffffff88d93d40
Apr  9 15:43:08 euler kernel: vboxdrv: fAsync=0 offMin=0x510 offMax=0x1428
Apr  9 15:43:08 euler kernel: vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
Apr  9 15:43:08 euler kernel: VBoxNetFlt: dbg - g_abExecMemory=ffffffff88f36ec0
Apr  9 15:45:56 euler kernel: device eth0 entered promiscuous mode
Apr  9 15:47:06 euler nmbd[3793]: [2009/04/09 15:47:06, 0] nmbd/nmbd_incomingdgrams.c:process_local_master_ann
ounce(309) 
Apr  9 15:47:06 euler nmbd[3793]:   process_local_master_announce: Server WIN-CLIENT at IP 192.168.1.150 is an
nouncing itself as a local master browser for workgroup ATHOME and we think we are master. Forcing election. 
Apr  9 15:47:06 euler nmbd[3793]: [2009/04/09 15:47:06, 0] nmbd/nmbd_become_lmb.c:unbecome_local_master_succes
s(149) 
Apr  9 15:47:06 euler nmbd[3793]:   ***** 
Apr  9 15:47:06 euler nmbd[3793]:    
Apr  9 15:47:06 euler nmbd[3793]:   Samba name server EULER has stopped being a local master browser for workg
roup ATHOME on subnet 192.168.1.1 
Apr  9 15:47:06 euler nmbd[3793]:    
Apr  9 15:47:06 euler nmbd[3793]:   ***** 
Apr  9 15:50:03 euler syslogd 1.4.1: restart.
Apr  9 15:50:03 euler kernel: klogd 1.4.1, log source = /proc/kmsg started.
Apr  9 15:50:03 euler kernel: Linux version 2.6.18-128.1.6.el5 (mockbuild@builder10.centos.org) (gcc version 4
.1.2 20080704 (Red Hat 4.1.2-44)) #1 SMP Wed Apr 1 09:10:25 EDT 2009

But soon after, the host crashes nevertheless. This time, I can attach guest VM log.

comment:2 Changed 5 years ago by frank

Please check if the problem is gone with VirtualBox 2.2.2. There was a small change in the netfilter code which could fix your problem.

comment:3 Changed 5 years ago by ps

Unfortunately, this bug is still present with VirtualBox 2.2.2. The host machine still crashes, with exactly the same symptoms as before. For the time being, I'm using a bridged tap/br setup instead of eth0 as a workaround; however being able to use eth0 and thus an IP address in the same subnet would be much nicer.

comment:4 Changed 5 years ago by frank

Thanks for the feedback. Which kernel version is that (sorry, no CentOS 5.3 handy here)?

comment:5 Changed 5 years ago by ps

This is the kernel version:

[ps@euler ~]$ uname -rp
2.6.18-128.1.6.el5 x86_64

comment:6 Changed 5 years ago by frank

Installed Cent OS 5.3 x86_64, WinXP guest, bridged networking: No problem so far. I fear this is somehow specific to the driver of your onboard network controller. I have only E1000 network cards here...

comment:7 Changed 5 years ago by ps

Ok, I think I will then try to file a bug against the driver in the CentOS bug tracker and get back to here if this yields some new information. Frank, thanks for your effort!

comment:8 Changed 5 years ago by frank

  • Summary changed from Host interface networking crashed the host (CentOS 5.3 x86_64) to Host interface networking crashed the host (CentOS 5.3 x86_64) => Fixed in SVN

The problem is most probably solved. See  here fox a fix. Feedback welcome.

comment:9 Changed 5 years ago by ps

I installed VB 2.2.4 and the problem is gone - everything works fine now with hostif/bridged networking setup using eth0. Thanks very much for fixing this!

comment:10 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use