VirtualBox

Ticket #3536 (closed defect: duplicate)

Opened 5 years ago

Last modified 10 months ago

AltGr key stops working on both, host and guest -> duplicate of #2537

Reported by: cokegen Owned by:
Priority: major Component: host support
Version: VirtualBox 2.1.4 Keywords: AltGr key
Cc: Guest type: Linux
Host type: Windows

Description (last modified by michael) (diff)

The AltGr key stops working some time after the virtual machine is started on both, host and guests. I've discovered a way to make the key to start working again, and is to select the VM, enter it and then press the capture key a couple of times. Doing that makes the AltGr key to start working on both again.

This is not a problem of this 2.1.4 version, as I had the same problem with older versions too.

Very annoying mostly for people with an international keyboard that has the AltGr key and need it to type a lot of useful characters.

Hope this gets solved, and of course I'll do whatever testing someone could require, just contact me.

Carlos

Change History

comment:1 Changed 5 years ago by Herbi

Same issue here. The Host-Key is Strg-Right here. AltGr stops working on my Keyboard. If you shutdown the VM, the key works again. It's really annoying. ;)

comment:2 Changed 5 years ago by terisis

Same problem here: On my config (Vista Host, Vista Guest, German Keyboard, Host-Key is "pause")

AltGR still works inside the guest, but not on the host. It helps to start another VM (dummy-VM with 4 MB RAM, no HD and stop it) to release AltGR for the host.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Cannot reproduce this problem anymore with VBox 3.2.6. Please reopen if necessary.

comment:4 Changed 4 years ago by jernejs

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same problem with VirtualBox. It doesn't always happen, but I had it with various 3.x versions (I don't remember it happening with 3.2.2-3.2.6, but I had it before that, and it just happened again with 3.2.8). My host system is Windows 7 Ultimate x64, guest is XP x64, and the problem happens when starting the VM. Keyboard layout on both host and guest is Slovenian.

I think the problem happens if I start a VM in VirtualBox, but switch to another program while the VM is starting - AltGr combinations on the host won't work until I switch to the VM and leave it.

comment:5 Changed 2 years ago by karatedog

Same problem here.
Host: Windows 7 64-bit
Guest: Debian 6 with Guest Addition (4.1.6)

Not all key combinations are affected, ie. AltGr+q (which should be "\") does not work, but AltGr+c (which is "&") works.

Restarting the Guest did not help. Pressing Host key+F helped (that took the VM out of fullscreen).

I'm currently working on how to properly reproduce the problem, but I noticed that there is a difference in 'xev' output whether the error shows up or everything is OK:

Erroneous state (pressing AltGr and releasing it):

KeyPress event, serial 33, synthetic NO, window 0x4800001,

root 0x10a, subw 0x0, time 1172803, (512,223), root:(595,321), state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x4800001,

root 0x10a, subw 0x0, time 1172803, (512,223), root:(595,321), state 0x14, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES, XKeysymToKeycode returns keycode: 92 XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

AltGr works OK:

KeyPress event, serial 33, synthetic NO, window 0x3200001,

root 0x10a, subw 0x0, time 272997, (172,-8), root:(255,90), state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES, XKeysymToKeycode returns keycode: 92 XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x3200001,

root 0x10a, subw 0x0, time 273366, (172,-8), root:(255,90), state 0x90, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES, XKeysymToKeycode returns keycode: 92 XLookupString gives 0 bytes: XFilterEvent returns: False

comment:6 Changed 2 years ago by michael

First, is anyone else subscribed to this ticket still having issues (no answer means no)? And second, karatedog, do you get any KeyRelease events at all when the problem occurs? Could you get xev output for the full AltGr+Q and AltGr+C sequences? And what keyboard layout are you using? Slovak?

comment:8 Changed 2 years ago by karatedog

I definitely get events from xev when the error occurs.
I try to reproduce the error, but of course it won't show up now :-)
I'm using Hungarian keyboard.
layout: Hungary 101/qwerty/dot/Eliminate dead keys
Keyboard model: Generic 105-key (Intl) PC keyboard model (as set up in Keyboard Preferences)

comment:9 Changed 2 years ago by karatedog

I still cannot reproduce the error any time I want, but it just happened now.
I think the problem is with the Host key which is Right Control for me.
Alt+Tab is not working within the Guest OS, but only in the Host OS, in spite of that the focus is within the Guest and normal keys are working within the Guest (I can type ASCII text).
It looks like as the Host key is stuck in a strange way (that causes keysym 0xffe3, Control_L in the xev output above).

comment:10 Changed 2 years ago by michael

I'm afraid I'm not an expert in our Windows-specific keyboard code, but it looks to me as though something prevents our keyboard handler from working properly (notably because Windows always sends funny left control key messages before an AltGr with certain keyboard layouts, and our keyboard handler removes those). The most likely reason I can think of is that some other piece of software on your system is also playing tricks with the keyboard (intercepting input) and interfering with VirtualBox. Can you think of anything on your system that might be doing that?

comment:11 Changed 2 years ago by karatedog

Indeed. The Evernote client has clipping features and tries to listen for Ctrl+Alt+some keys, but I disabled this feature. I try to quit certain apps, and try to reproduce the error and post back the results.
Then I will change the Host key as well, I'm used to have it on Super.

comment:12 Changed 2 years ago by andpro77

It happens consistently with on my Win7 x64 host. VirtualBox 4.1.8 r75467 Guest: Windows XP 32bit

Guest started automatically from .bat file in StartUp folder using

vboxmanage startvm "name" --type gui 
vboxmanage controlvm "name" setcredentials "name" "" "pwd" --allowlocallogon yes

Another Linux guest started like the Windows one, but without setting credentials.

Then AltGr doesn't work. As soon as I shutdown the Windows guest, AltGr works fine. When I start the Windows guest again from the VirtualBox GUI, AltGr continues to work fine.

Version 1, edited 2 years ago by andpro77 (previous) (next) (diff)

comment:13 Changed 2 years ago by jernejs

Also still happens with 4.1.10. I can always reproduce it by putting a VM in seamless mode, suspending it, then starting the VM and switching to another program while it's being resumed. After the VM resumes, AltGr stops working in other programs until I switch to the VM.

comment:14 Changed 2 years ago by einacio

It happens to me with 4.1.14, although randomly. It works using Host-key twice on the VM to unlock AltGr as a workaround, but it is a hassle.

comment:15 Changed 18 months ago by bullestock

I have just experienced this twice with version 4.1.22.

The first time I rebooted the host. The second time I tried the various suggestions in this ticket - the only thing that worked was Host-F.

This is on a US English Windows 7 Enterprise (x64 build 7601), Danish keyboard layout.

comment:16 Changed 18 months ago by michael

  • Description modified (diff)

I have uploaded a 4.2 test build to virtualbox.org which I hope may fix this issue. If anyone would like to give it a try, it is at

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.5-81993-Win.exe

comment:17 Changed 17 months ago by Slarti

I'm having the same problem - my colleague can re-enable the alt-gr key by giving focus to the virtual machine and then using the host key to make it lose focus but for me that does not work. One additional strange effect is that if I type alt-gr+4 (should be $ on a swedish keyboard) then some programs (e.g. aptana studio) simply produce no character at all while some (notepad++, putty) produce a 4. If I log in to the virtual machine itself then I get $ but if I log in via putty then I get 4. Win 7 64-bit with ubuntu server as guest.

If others can confirm that a new version fixes it then I may try to upgrade. However, the last time I upgraded virtual box I lost half a day to getting my networking working again on the host, so I'm not in a position to just try it, sorry.

Last edited 17 months ago by Slarti (previous) (diff)

comment:18 Changed 17 months ago by bullestock

I have installed the 4.2.5 test build, will report back in a few days.

comment:19 Changed 15 months ago by Mirar

I have the same problem intermittently (4.2.0). Windows 7 host and Crunchbang Linux guest.

AltGr is killed on the host as well. Quitting VirtualBox (including turning off guest) restores the AltGr key.

Next time it happens - I can't provoke it again - I'll run xev to see what is being sent to the guest, and try the 4.2.5.

Last edited 15 months ago by Mirar (previous) (diff)

comment:20 Changed 15 months ago by michael

See also ticket #11382.

comment:21 Changed 12 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Summary changed from AltGr key stops working on both, host and guest to AltGr key stops working on both, host and guest -> duplicate of #2613

I will close this as a duplicate of #2613. Please re-open if you disagree.

comment:22 Changed 10 months ago by michael

  • Summary changed from AltGr key stops working on both, host and guest -> duplicate of #2613 to AltGr key stops working on both, host and guest -> duplicate of #2537

Duplicate of #2537 in fact.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use