VirtualBox

Ticket #3528 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

RDP clients crash when connecting from Windows7 -> Fixed in SVN/3.0.0

Reported by: joncage Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.2.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm not too sure if it's a Windows7 problem, but I'm get frequent but seemingly random crashes when trying to connect into my VM:

 http://www.geekops.co.uk/photos/0000-00-02%20(Forum%20images)/Windows7-Remote-Desktop-Connection-Crash.PNG

The VM carries on running and you can try and connect to it again, but that frequently just drops back out again. I've had a look at the logs and each connection has a sequence along these lines:

00:56:35.164 VRDP: New connection:
00:56:35.165 VRDP: Connection closed:
00:56:35.165 VRDP: Logoff: <NULL> (<NULL>) build 0. User: [<NULL>] Domain: [<NULL>] Reason 0xFFFFFFFF.
00:56:35.193 VRDP: New connection:
00:56:35.245 VRDP: Flags 0x0000001b
00:56:35.245 VRDP: Channel: [rdpdr] [1004]. Not supported.
00:56:35.245 VRDP: Channel: [rdpsnd] [1005]. Accepted.
00:56:35.245 VRDP: Channel: [drdynvc] [1006]. Not supported.
00:56:35.245 VRDP: Channel: [cliprdr] [1007]. Accepted.
00:56:35.334 VRDP: Client seems to be MSFT.
00:56:35.334 VRDP: Logon: H2O (192.168.1.4) build 7000. User: [] Domain: [] Screen: 0
00:56:35.336 VRDPAUTH: User: []. Domain: []. Authentication type: [Null]
00:56:35.336 VRDPAUTH: Access granted.
00:56:35.337 VBVA: VRDP acceleration has been requested.
00:56:35.998 VRDP: Connection closed:
00:56:35.998 VRDP: Logoff: H2O (192.168.1.4) build 7000. User: [] Domain: [] Reason 0xFFFFFFFF.
00:56:35.998 VBVA: VRDP acceleration has been disabled.

When I first installed the guest O/S I was have problems with the mouse on the remote machine not matching up with the one on my local machine. I tried installing 'virtual-box-windows-guest-additions' from google:

 http://code.google.com/p/virtual-box-windows-guest-additions-installer/downloads/list

...but that didn't seem to help so it's been uninstalled. Any other information required? I don't know what else to try...

Attachments

VBox.log Download (65.1 KB) - added by joncage 5 years ago.
Log file

Change History

Changed 5 years ago by joncage

Log file

comment:1 in reply to: ↑ description Changed 5 years ago by Firestarter

Replying/Adding to Ticket from joncage:

Same issue, newer builds:

VirtualBox 2.2.2r46594

Connecting from windows 7 build 7100

18:52:35.487 VRDP: New connection:
18:52:35.667 VRDP: Flags 0x0000001b
18:52:35.667 VRDP: Channel: [rdpdr] [1004]. Not supported.
18:52:35.667 VRDP: Channel: [rdpsnd] [1005]. Accepted.
18:52:35.667 VRDP: Channel: [drdynvc] [1006]. Not supported.
18:52:35.667 VRDP: Channel: [cliprdr] [1007]. Accepted.
18:52:35.811 VRDP: Client seems to be MSFT.
18:52:35.811 VRDP: Logon: CLIMBATIZE (192.168.2.5) build 7100. User: [] Domain: [] Screen: 0
18:52:35.812 VRDPAUTH: User: []. Domain: []. Authentication type: [Null]
18:52:35.812 VRDPAUTH: Access granted.
18:52:35.813 VBVA: VRDP acceleration has been requested.
18:52:39.356 VRDP: Connection closed:
18:52:39.356 VRDP: Logoff: CLIMBATIZE (192.168.2.5) build 7100. User: [] Domain: [] Reason 0xFFFFFFFF.
18:52:39.356 VBVA: VRDP acceleration has been disabled.

Members on the forum said this problem was solved in version 1.6.6, but the issue is back again. Another protocol change in TS client?

Any solution or workaround available?

Please reply, Thanks.

comment:2 follow-up: ↓ 4 Changed 5 years ago by frank

So the MS RDP client of Windows 7 crashes when you connect to a VBox RDP session, correct?

Btw, why do you install the Windows guest additions someone has recompiled instead using the guest additions which are shipped with every official VBox installation package (and I saw from your log that you are using the official package)?

comment:3 Changed 5 years ago by sunlover

I've tested the "Remote Desktop Connection" client version 6.1.7100 from Windows 7. It works here. Which options do you you for the connection (display size, color quality, sound, etc..)?

comment:4 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 5 years ago by joncage

Replying to frank:

So the MS RDP client of Windows 7 crashes when you connect to a VBox RDP session, correct?

I think it happens generally as a result of certain types of interactions with the remote desktop (accessing combo boxes and running shell prompts on the virtual machine for example).

Btw, why do you install the Windows guest additions someone has recompiled instead using the guest additions which are shipped with every official VBox installation package (and I saw from your log that you are using the official package)?

Because I couldn't find them anywhere? I installed the Ubuntu 8.10 package but couldn't see any mention of the .iso the help file talks about.

comment:5 in reply to: ↑ 4 Changed 5 years ago by joncage

I just tried upgrading to v2.2.4 and have a fresh install of XP and after some initial problems getting the guest additions .iso mounted, I finally got it working. Thus far the new version seems to be working well so it looks likely it was my guest additions that were at fault.

To avoid anyone else falling in this same trap, the manual could be more helpful in stating where to find the additons for linux distributions (/usr/share/virtualbox/VBoxGuestAdditions.iso from the Ubuntu 8.10 package).

comment:6 Changed 5 years ago by joncage

Damn, scratch that, 2.2.4 (host and guest additions) still gives me the same issues. I'm using RDP client 6.1.7100 here.

With the guest additions installed on a windows XP client, try the following:

1) Open windows explorer. 2) Find another machine on your network with a share. 3) Right click on the share and select "Map network drive" 4) Click on the 'Drive' drop-down menu. 5) Watch as your RDP client connection drops :-)

I'm using very basic settings with display options of:

Resolution: 1280*1024 Colour depth: 16 bit

I've got my 'Experience' set to 10MBit

comment:7 Changed 5 years ago by sunlover

  • Version changed from VirtualBox 2.1.4 to VirtualBox 2.2.4

Thanks for the information. The problem has been reproduced and we are working on a fix.

comment:8 Changed 5 years ago by sunlover

  • Summary changed from RDP clients crash when connecting from Windows7 to RDP clients crash when connecting from Windows7 -> Fixed in SVN

Support for Windows 7 client has been added to VirtualBox 3.0.0 Beta 1. Please try the beta version and let me know if there are any remaining issues with the Windows 7 client.

comment:9 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from RDP clients crash when connecting from Windows7 -> Fixed in SVN to RDP clients crash when connecting from Windows7 -> Fixed in SVN/3.0.0
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use