VirtualBox

Ticket #3514 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

copy and/or paste sometimes stops working between guest and host

Reported by: stephanecharette Owned by:
Priority: minor Component: clipboard
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

I typically have guests up and running at a minimum of 1 week at a time at work, sometimes up and running for several weeks before I have to reboot them. But every once in a while, I need to shut down a guest and restart it partway through the week because copy and/or paste has stopped working.

Copy/paste is typically in one of these states:

  1. copy/paste works in both directions (all is fine)
  2. copy/paste works independently on host and guest, but clipboard is no longer shared between the two
  3. copy from the guest can be pasted in the host, but copy from the host does not paste in the guest. (the guest clipboard only has whatever was last copied in the guest)
  4. the reverse of 3. -- copy from host can be pasted in guest, but copy from guest doesn't make it to the host

I typically start using my shared folder and a temporary text file to transfer bits of data I need to share until such a time as I can safely restart the guest. But this is annoying to have to do.

Unfortunately, I don't know what causes this problem to happen. I figured I'd open this ticket to start a discussion with development so the next time it happens I can help debug the situation.

Change History

comment:2 Changed 5 years ago by stephanecharette

So I'm in the situation right now. Host is Ubuntu 8.04-64bit, guest is Debian Etch 4-64bit, VB 2.1.4.

I copy 2 lines of text -- about 40 chars -- from gedit running on my host.

I move to my guest and click paste in my text editor...and I get nothing. Same thing when I try CTRL+V, and also the same thing when I try SHIFT+INS. But in a 2nd copy of gedit on my host, I can paste the new text, so I know the copy worked.

The other direction is working fine. I can copy a line in my guest, and paste it into the host without any problem. The problem today is unidirectional.

Is there anything I can do to help debug this issue?

comment:3 Changed 5 years ago by michael

Fixing shared clipboard issues is on my todo list, but I'm afraid that it is not something I can look at immediately, as there are a number of other things I have to deal with first. (As usual, I'm afraid I can't give a time estimate). I will certainly get back to you when I start looking at this though.

By the way, if you do start having clipboard issues in a Linux guest, restarting the VBoxClient daemon can help. This is started under the user ID of the currently logged in user, not as root, although it is setuid vboxusers (or vboxadd, can't remember now) to access /dev/vboxadd.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this report if you can reproduce such problems with VirtualBox 2.2.2.

comment:5 Changed 5 years ago by nevil

  • Status changed from closed to reopened
  • Resolution fixed deleted

This definitely still occurs on 2.2.2. I'm having this issue all the time. Restarting the VBoxClient seems to help.

comment:6 Changed 5 years ago by frank

  • Description modified (diff)

comment:7 Changed 5 years ago by michael

You might want to try out the Guest Additions from the 3.0 beta release. Do make a backup or take a snapshot before installing them just in case (I can't be 100% sure that they will work correctly with 2.2, although I think they will), but there aren't any particularly dangerous changes in the Linux Additions.

comment:8 Changed 5 years ago by michael

Is this still an issue with 3.0.4?

comment:9 Changed 5 years ago by BUGabundo

is this a dupe of #3755 ?

comment:10 Changed 5 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

Hard to say really, but I will close it as a lot has happened to the clipboard code since the last comment here. Anyone with clipboard issues please look for a more recent ticket to add a comment to, or open a new one if you can't find a relevant ticket.

comment:11 Changed 5 years ago by nevil

I'm sorry that I can no longer confirm if this is resolved. I don't have access to the system where this occurred anymore.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use