VirtualBox

Ticket #3476 (closed enhancement: fixed)

Opened 5 years ago

Last modified 2 years ago

Host networking Issues and potential fix

Reported by: thirdorderharmonic Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Not sure if this is the right place to post this but this is a potential fix for some of the hostif networking problems under windows on an os x host.

When I install a windows XP guest on an OS X (10.5) host and select host interface networking with a virtual Intel 1000T server nic, the connection is flaky and tempermental. Certain sites connect and others don't. Local networking is hit and miss.

If i go to the intel website and download the official drivers for the pro1000t complete with intels proset util etc, and install these in the guest vm, they replace the existing drivers installed by virtualbox and/or the xp install cd.

After installing these drivers everything works perfectly.

Driver link:

 http://downloadcenter.intel.com/detail_desc.aspx?agr=Y&DwnldID=4275

Is it possible that there is a problem with the drivers installed by virtualbox and/or the xp installation media causing problems? Or does installing the official intel driver reset some other things?

Anyway, thought you might be interested in this lead, as it's solved all my problems instantly...

Cheers

Change History

comment:1 Changed 5 years ago by slebbon

I didn't see this existing ticket when I posted #3783 today, but that contains a workaround, and the cause as well: MTU settings.

More details in ticket #3783. Hopefully this info combine with your note about changing drivers working as well, will point the developers in the right direction for fixing this problem.

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I think we fixed a lot of bugs with the E1000 emulation in the meantime so this bug is probably not relevant anymore. And we are also not allowed to install such 3rd-party software, the user has to do this himself.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use