VirtualBox

Ticket #3468 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Fails to build with "VBOX_WITH_64_BITS_GUESTS="

Reported by: blueyed Owned by:
Priority: minor Component: other
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: other
Host type: other

Description

In Ubuntu the package has/had code to set VBOX_WITH_64_BITS_GUESTS according to the build system.

This fails to build. Some investigation is available at  https://bugs.launchpad.net/ubuntu/+source/virtualbox-ose/+bug/328161 and the build log is at:  http://launchpadlibrarian.net/23237526/build.log

The problem is likely in src/VBox/VMM/testcase/tstVMStructGC.cpp, where it should be 4 instead of 8 in the second case:

#ifdef VBOX_WITH_64_BITS_GUESTS
AssertCompileSize(RTGCPTR,  8);
#else
AssertCompileSize(RTGCPTR,  8);
#endif

I'm not sure at all and the Ubuntu package does not change VBOX_WITH_64_BITS_GUESTS now anymore, but wanted to notify you about this.

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks, fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use