VirtualBox

Ticket #3460 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Can't launch a vm, comes up wih 2 errors!

Reported by: wollac11 Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords: vm launch error bug guest host linux acer aspire one linpus lite
Cc: Guest type: Linux
Host type: Linux

Description

When i try t launch a virtual machine that i have created i get two error messages (see attached) and it doesn't launch.I hav tried installing DKMS like the second error message suggested but still the problem contiues. I am running virtual box on my aspire one which runs linux linpus lite (so that is my host os) i would like to be able fix this issue.

Thank You, Charlie

Attachments

errors.jpg Download (130.3 KB) - added by wollac11 5 years ago.
The two error messages (put in one pic for convenience)
Screenshot.png Download (62.8 KB) - added by Jon Burgoyne 5 years ago.

Change History

Changed 5 years ago by wollac11

The two error messages (put in one pic for convenience)

comment:1 Changed 5 years ago by frank

Which VBox package (exact file name please) did you install? There is a script /etc/init.d/vboxdrv -- is that script automatically executed when you boot the host? Is there any device /dev/vboxdrv on your system? If so, which permissions?

comment:2 Changed 5 years ago by wollac11

i have installed Virtualbox - 2.1.4_42893_fedora7-1.i386 (i don't know the file name as i don't have the install package any more) it came as an rpm file. i don't think that the script /etc/init.d/vboxdrv is launched on boot up - is there anyway to find out? should it launch or not? I don't know what you mean exacly by "Is there any device /dev/vboxdrv on your system? If so, which permissions?" but there is no folder or file named vboxdrv in the /dev directory. And i am not running as the root by default, though i do know my root password so i can run things as the root from the terminal. I am still fairly new to linux - and also virtual box so please excuse my misunderstanding.

thanks,

charlie

comment:3 Changed 5 years ago by Jon Burgoyne

First off fantastic product (I've tested it on windows)

Like charlie trying to install on Aspire One with Linpus Lite.

Fedora 7 version used for install.

Installs (install dkms as well no problem) fine but get the same problem when trying to launch a virtual machine

Followed the instructions when it fails ie run /etc/init.d/vboxdrv setup in a terminal as root

VirtualBox kernal stops ok

VirtualBox Kernal recompile fails

Message in vbox-install.log states /lib/modules/2.6.23.9lw/build and source not available

When I look in this location broken links to these folders are present and as the message states there is no source or build components.

This looks as though it is more a Linpus problem than VirtualBox issue but if anyone can help us to get this fantastic product going on Linpus it would be so appreciated.

Thanks in advance

JB

Changed 5 years ago by Jon Burgoyne

comment:4 Changed 5 years ago by Jon Burgoyne

Got it going thanks to this site

 http://macles.blogspot.com/2008/11/virtualbox-on-aspire-one-linux.html

see attachment ()screenshot for confirmation

comment:5 Changed 5 years ago by frank

wollac11, I've still no idea what went wrong with your installation. Are you still interested in solving this problem? Then download the proper package again and install it. If it still does not work, please attach the file /var/log/vbox-install.log to this defect.

comment:6 Changed 4 years ago by Technologov

No response, please close.

-Technologov

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use