VirtualBox

Ticket #3455 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

OpenSolaris Kernel Dump

Reported by: drseek Owned by:
Priority: minor Component: host support
Version: VirtualBox 2.1.4 Keywords: OpenSolaris Crash Dump
Cc: Guest type: Windows
Host type: Solaris

Description

I'm running VirtualBox 2.1.4 on OpenSolaris 101b. The guest OS is Windows XP SP3. Every time I shut down the guest OpenSolaris crashes. Maybe the cause is the same as described in ticket #2705 but I'm using an actual OpenSolaris and VirtualBox build.

The logs (/var/adm/messages and VirtualBox log) are appended to the ticket.

Here is the SCAT output of the crash:

user:		 (root:0)
release:	5.11 (32-bit)
version:	snv_101b
machine:	i86pc
node name:	cracking
system type:	i86pc
hostid:		87b92e06
dump_conflags:	0x10000 (DUMP_KERNEL) on /dev/dsk/c4d0s1(1.99G)
time of crash:	Sat Feb 28 12:14:53 CET 2009
age of system:	1 hours 5 minutes 49.06 seconds
panic CPU:	1 (2 CPUs, 1022M memory)
panic string:	BAD TRAP: type=e (#pf Page fault) rp=e4ba8e60 addr=14 occurred in module "genunix" due to a NULL pointer dereference


==== checking for trap information ====

CPU 1 had the panic


==== panic thread: 0xd7b1a600 ==== CPU: 1 ====
==== panic user (LWP_SYS) thread: 0xd7b1a600  PID: 570  on CPU: 1 ====
cmd: /usr/lib/fm/fmd/fmd
fmri: svc:/system/fmd:default
t_procp: 0xd9b639b0
  p_as: 0xdbb94cb8  size: 35139584  RSS: 11706368
  hat: 0xd246b0c8  
    cpuset: 1
  zone: global
t_stk: 0xe4ba8fac  sp: 0xe4ba8d1c  t_stkbase: 0xe4ba7000
t_pri: 59(TS)  pctcpu: 0.026998
t_lwp: 0xd7bd9300  lwp_regs: 0xe4ba8fac
  mstate: LMS_SYSTEM  ms_prev: LMS_KFAULT
  ms_state_start: 0.000020675 seconds earlier
  ms_start: 1 hours 4 minutes 29.373664131 seconds earlier
psrset: 0  last CPU: 1  
idle: 386646 ticks (1 hours 4 minutes 26.46 seconds)
start: Sat Feb 28 11:10:24 2009
age: 3869 seconds (1 hours 4 minutes 29 seconds)
syscall: #255 sys#255(, 0x0) (sysent: genunix:umount2+0x0)
tstate:	TS_ONPROC - thread is being run on a processor
tflg:	T_PANIC - thread initiated a system panic
	T_DFLTSTK - stack is default size
tpflg:	TP_TWAIT - wait to be freed by lwp_wait
	TP_MSACCT - collect micro-state accounting information
tsched:	TS_LOAD - thread is in memory
	TS_DONT_SWAP - thread/LWP should not be swapped
pflag:	SMSACCT - process is keeping micro-state accounting
	SMSFORK - child inherits micro-state accounting

pc:      unix:vpanic_common+0xab:  addl   $0x10,%esp

unix:vpanic_common+0xab()
unix:panic+0x12()
unix:die+0x93()
unix:trap+0x1422()
unix:cmntrap_pushed+0x2f()
-- panic trap data  type: 0xe (Page fault)
  addr      0x14  rp   0xe4ba8e60
  trapno      0xe (Page fault)
  err            0 (page not present,read,supervisor)
  %efl    0x10287 (carry|parity|negative|interrupt enable|resume)
  savbp 0xe4ba8f04
  savip genunix:dnlc_purge_vfsp+0x94:  movl   0x14(%ecx),%eax

  %ebp 0xe4ba8f04  %esp 0xe4ba8e98
  %eip genunix:dnlc_purge_vfsp+0x94:  movl   0x14(%ecx),%eax

  %eax 0xfec65a90  %ebx 0xd32b3748  %ecx          0  %edx          0
  %edi 0xd3006361  %esi          0
  %cs       0x158 (KCS_SEL)
  %ds  0xd3280160 (GDT unknown,KPL)  %es  0xe4ba0160 (GDT unknown,KPL)
  %fs  0xe4ba0000 (GDT unknown,KPL)  %gs       0x1b0 (KGS_SEL)
<trap>genunix:dnlc_purge_vfsp+0x94()
genunix:dounmount+0x16()
genunix:umount2_engine+0x49()
genunix:umount2+0x12d()
unix:sys_sysenter+0x106 _sysenter_done()
-- switch to user thread's user stack --


==== analyzing panic thread stack for trap frames ====

  no trap frames found

Attachments

messages.copy Download (24.5 KB) - added by drseek 5 years ago.
/var/adm/messages
VBox.log Download (46.8 KB) - added by drseek 5 years ago.
VirtualBox log
VBox.2.log Download (33.5 KB) - added by drseek 5 years ago.
Guest with enabled NAT.

Change History

Changed 5 years ago by drseek

/var/adm/messages

Changed 5 years ago by drseek

comment:1 Changed 5 years ago by ramshankar

Have you tried using NAT instead of Host Interface networking to see if it prevents the crash?

Also could please you show output of ifconfig -a from the host?

comment:2 follow-up: ↓ 3 Changed 5 years ago by drseek

I tried NAT but crashes again.

Here is the output of ifconfig -a:

lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
	inet 127.0.0.1 netmask ff000000 
vfe0: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500 index 2
	inet 10.0.0.2 netmask ff000000 broadcast 10.255.255.255
	ether 0:b:6a:9c:70:f9 
sppp0: flags=10010008d1<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST,IPv4,FIXEDMTU> mtu 1492 index 3
	inet 92.229.129.40 --> 213.191.64.143 netmask ff000000 
	ether 0:0:0:0:0:0 
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
	inet6 ::1/128 

At the moment the Windows guest doesn't have access to the internet.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 5 years ago by Hachiman

Replying to drseek:

I tried NAT but crashes again.

Could you please attach log file of crash with NAT, if possible core file.

# ulimit -c unlimited
# VirtualBox -startvm [name of your VM]

comment:4 in reply to: ↑ 3 Changed 5 years ago by Hachiman

Could you please attach log file of crash with NAT, if possible core file.

If core file available we would provide information where it could be uploaded (please contact me vasily.levchenko [at] sun [dot] com)

comment:5 Changed 5 years ago by drseek

I attached the log file of crash.

Before the crash occured I leaved the full screen mode of the guest, switch to firefox on the host and browse variouse webpages and suddenly the system crashes. At that time the guest was running in the background.

Changed 5 years ago by drseek

Guest with enabled NAT.

comment:6 Changed 5 years ago by jmcp

For submitter - could you turn on kmem_flags in /etc/system please:

set kmem_flags=0xf

regenerate your boot archive and then reboot.

Also, if you can supply the actual crash dump files (or a pointer to them) from your host that would be handy.

Finally, are you using a fixed size backing store, or expanding? (Not that I think it matters, but it's always better to have a full picture of the configuration).

comment:7 Changed 5 years ago by frank

drseek, please could you check if VirtualBox 2.2.2 changes anything for you and if not, read jmcp's advises?

comment:8 Changed 5 years ago by ramshankar

  • Priority changed from blocker to minor

comment:9 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

Please re-open if problem still persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use