VirtualBox

Ticket #3445 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Memory Leakage - Windows 7 x64 Host ; 2 x Vista SP1 x64 Guest

Reported by: TheFUG Owned by:
Priority: critical Component: other
Version: VirtualBox 2.1.4 Keywords: Memory Leakage
Cc: Guest type: Windows
Host type: Windows

Description

Hi,

I'm having memory leaks on a Windows 7 x64 (build 7000) fully patched running VirtualBox 2.1.4 with 2 x Vista SP1 x64 guests.

Before starting the guest my memory usage is stable at 1GB out of a total of 4GB. After starting the client which is configured as 512MB I see my Physical Memory Usage jump by about 600MB to 1.6GB which seems normal. However over time this number keeps getting higher.

In the attached log I was running a single guest for approx 15 mins and the Physical Memory Usage went all the way upto 2.25GB. Upon shutting down the guest the memory dropped to 1.05GB. When I run 2 x guests it ends up using all my memory. Please let me know if there is any further info I can provide.

Cheers TheFUG

Attachments

VBox.log Download (46.2 KB) - added by TheFUG 5 years ago.
Host log file

Change History

Changed 5 years ago by TheFUG

Host log file

comment:1 Changed 5 years ago by sandervl73

First you should make sure it *is* a memory leak. The host file cache will eat memory like crazy when running guests. It's very easy to misinterpret the numbers.

comment:2 Changed 5 years ago by TheFUG

How do I check this? Where is the cache file? I'm hunting around now for it. Also I notice that if I don't log into the client the memory stays pretty stable.

comment:3 Changed 5 years ago by attoparsec

There is no "cache file". There is a file cache, in RAM. Unless you have apps dying due to out-of-memory there is no sign of a memory leak. Note that unused RAM is *wasted* RAM. A file cache by designs should use all RAM it can (it will automatically return such memory to the system when needed for other tasks).

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Use  http://technet.microsoft.com/en-us/sysinternals/bb897561.aspx

This will show a significant increase of memory used by the system file cache. Please reopen the defect if required. I'm assuming for now you misinterpreted the numbers.

comment:5 Changed 5 years ago by TheFUG

Thanks for the replies guys.

I dont see any issues like this on my Home Server where I am also running VB 2.1.4 and I have 3 x Server 2008 x64 hosts. I'm still looking and comparing hosts.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use