VirtualBox

Ticket #3435 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

rc.vboxadd-timesync shell script is missing the on begin( ) function for Slackware -> fixed in SVN

Reported by: cdkyle Owned by:
Priority: trivial Component: guest additions
Version: VirtualBox 2.1.4 Keywords: Slackware vboxadd-timesync begin
Cc: Guest type: Linux
Host type: Windows

Description

After installing the Guest Additions from VirtualBox 2.1.4 on Slackware 12.2 the resulting rc.vboxadd-timesync shell script produces an error when run. The error is "begin: command not found". This is caused by the fact that the begin() function is not being defined in the Slackware section of the script.

There is thread in the end-user forum, "Slackware 12 Guest no daemon", that had similiar issues with other functions.  http://forums.virtualbox.org/viewtopic.php?t=4709

The easy fix is to place a copy of the begin() function at line 197 in /etc/rc.d/rc.vboxadd-timesync

Below is the needed code for the begin function:

begin() {
 echo -n "$1"
}

Change History

comment:1 Changed 5 years ago by michael

  • Summary changed from rc.vboxadd-timesync shell script is missing the on begin( ) function for Slackware to rc.vboxadd-timesync shell script is missing the on begin( ) function for Slackware -> fixed in SVN

Thanks for reporting this. In fact this is already fixed, but unfortunately only after 2.1.4 was release.

comment:2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use