VirtualBox

Ticket #3414 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows BSOD with Host Interface ==> fixed in SVN

Reported by: doug.dockter@… Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I'm running VirtualBox 2.1.4 on XP SP3. When I select "host interface" as the network setting and start my Windows NT 4.0 VM, I get a DRIVER_IRQL_NOT_LESS_OR_EQUAL_BSOD on the XP host. If I change the network setting to NAT, I don't have that issue.

Attachments

VBox.log Download (31.3 KB) - added by doug.dockter@… 5 years ago.
VB log
Mini022609-01.dmp Download (92.0 KB) - added by doug.dockter@… 5 years ago.

Change History

Changed 5 years ago by doug.dockter@…

VB log

comment:1 Changed 5 years ago by misha

Could you attach a  minidump with a fail here? Thanks

comment:2 Changed 5 years ago by misha

Also when exactly does the fail occurs, i.e. just on VM start or after sometime after the start or on shutdown?

comment:3 follow-up: ↓ 4 Changed 5 years ago by misha

  • Host type changed from other to Windows

comment:4 in reply to: ↑ 3 Changed 5 years ago by doug.dockter@…

Replying to misha: It happens immediately after the OS Loader screen comes up - before I even have a chance to make a selection from there.

Changed 5 years ago by doug.dockter@…

comment:5 in reply to: ↑ description ; follow-up: ↓ 6 Changed 5 years ago by andyw62

I am running an XP SP3 machine with two network cards. It ran fine with the host interface setup against the in build Intel card. I always got a BSOD with my secondary Reltek card (RTL8139/810x). A WindowsUpdate driver update for this card solved the problem. The driver was dated Jan09 so is quite recent.

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 7 Changed 5 years ago by doug.dockter@…

Replying to andyw62:

I am running an XP SP3 machine with two network cards. It ran fine with the host interface setup against the in build Intel card. I always got a BSOD with my secondary Reltek card (RTL8139/810x). A WindowsUpdate driver update for this card solved the problem. The driver was dated Jan09 so is quite recent.

I did not find that driver update in Windows Update. Dell also did not show a newer driver than the one I have installed.

comment:7 in reply to: ↑ 6 Changed 5 years ago by andyw62

Replying to doug.dockter@utgins.com:

Replying to andyw62:

I am running an XP SP3 machine with two network cards. It ran fine with the host interface setup against the in build Intel card. I always got a BSOD with my secondary Reltek card (RTL8139/810x). A WindowsUpdate driver update for this card solved the problem. The driver was dated Jan09 so is quite recent.

I did not find that driver update in Windows Update. Dell also did not show a newer driver than the one I have installed.

The driver I am using details are as follows: Driver Provider : Realtek Semiconductor Corp. Driver Date : 21/01/2009 Driver Version : 5.713.121.2009

comment:8 Changed 5 years ago by doug.dockter@…

I was able to locate the newer driver you referenced and it corrected the problem. Thanks for your help.

comment:9 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Windows BSOD with Host Interface to Windows BSOD with Host Interface -> update Realtek driver

Thanks for your feedback. We'll blame it on the Realtek driver then.

comment:10 Changed 5 years ago by misha

  • Summary changed from Windows BSOD with Host Interface -> update Realtek driver to Windows BSOD with Host Interface ==> fixed in SVN

After having another look into the minidump, this is not a Realtek driver issue, but ours.
The issue is now fixed in SVN.

In case anyone is still seeing it please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test version containing a fix for the issue.

Replying to doug.dockter@utgins.com: Thanks very much for the minidump, it helped me A LOT :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use