VirtualBox

Ticket #3408 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

X server does not start w/Guest Additions on OpenSolaris guest w/snv_107 packages => fixed in 2.2.0 BETA1

Reported by: rlk Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

With the Guest Additions installed, the X server does not start on an OpenSolaris client using snv_107 (development) packages. Worked with snv_106, and the server starts if the Guest Additions are removed. The message in Xorg.0.log indicates that the vboxvideo module does not load because of a version mismatch.

Attachments

Xorg.0.log Download (7.6 KB) - added by rlk 5 years ago.
Xorg.0.log

Change History

Changed 5 years ago by rlk

Xorg.0.log

comment:1 Changed 5 years ago by slx86

Hi,

I have a workaround for that, its not perfect but it works. Look at  http://www.opensolaris.org/jive/thread.jspa?messageID=343801&#343801

comment:2 in reply to: ↑ description Changed 5 years ago by waynel

Replying to rlk:

With the Guest Additions installed, the X server does not start on an OpenSolaris client using snv_107 (development) packages. Worked with snv_106, and the server starts if the Guest Additions are removed. The message in Xorg.0.log indicates that the vboxvideo module does not load because of a version mismatch.

This problem is not limited to 2.1.4. I first noticed the booting problem with 2.1.2, after I did an image-update from OpenSolaris build 106 to build 107.

I was able to boot into build 107 after a fresh installation from the build 107 liveCD. However, I was not able to install GA. Upgrading VBox to 2.1.4 allowed to install GA. But, again, installation of GA in 2.1.4 also resulted in failure to boot.

I am now running build 106 in Vista under VBox 2.1.4 with GA installed. Still can't boot to build 107.

comment:3 Changed 5 years ago by comay

snv_107 includes an update to version 1.5.3 of the Xorg server.

comment:4 Changed 5 years ago by alanc

Right, snv_106 and earlier used Xorg 1.3, snv_107 and later use Xorg 1.5.3, which has changed the loadable module ABI and refuses to load modules built for the wrong ABI version to avoid crashes on function mismatches.

comment:5 Changed 5 years ago by giorgio42

There have been no news on this for almost 4 weeks and the bug is not mentioned in the 2.2 Beta1 release notes. Is there are schedule for fixing the incompatibility between Solaris guest additions and Xorg 1.5.3? (affects all people testing upcoming osol-200906 inside VBox on Vista).

Crippled mouse handling and missing WUXGA support do hurt quite a bit.

Thanks Georg

comment:6 Changed 5 years ago by ramshankar

Have you tried the additions from the 2.2 Beta1 ?

comment:7 Changed 5 years ago by giorgio42

Thanks for the immediate response. Is it possible to use the 2.2 Beta 1 guest additions with 2.1.4?

comment:8 Changed 5 years ago by ramshankar

Yes you can use the latest additions from the Beta with 2.1.4. But please be aware that the Beta _is_ a beta, so you might want only the additions if you are running a production environment or don't want to upgrade at this point.

comment:9 Changed 5 years ago by giorgio42

Beta status is ok as I am only using this setup to work through the OpenSolaris bible. Installing the 2.2 Beta 1 guest additions has solved the problems mentioned above. Thanks again for that!

The most gnawing issue left right now is the extraordinary amount of CPU load caused by any use of firefox, rendering for instance, Google mail almost unusable. Right-clicking anywhere on a page results in firefox-bin and Xorg processes taking each about 35% of cpu for 20 seconds.

HW: Dell Studio 17, 4GB RAM, T8300 (2.4 GHz), Vista Home Premium, VBox 2.1.4, OpenSolaris snv109.

comment:10 Changed 5 years ago by giorgio42

Firefox performance problem is solved after installing VBox 2.2.0 Beta 1. Great!

comment:11 Changed 5 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

comment:12 Changed 5 years ago by ramshankar

  • Summary changed from X server does not start w/Guest Additions on OpenSolaris guest w/snv_107 packages to X server does not start w/Guest Additions on OpenSolaris guest w/snv_107 packages => fixed in 2.2.0 BETA1
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use