VirtualBox

Ticket #3382 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Broken installer after noit responding installer was killed

Reported by: hole2 Owned by:
Priority: major Component: installer
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: other
Host type: Windows

Description

During install of 2.1.4

  • started install
  • install stopped at network driver update
  • stopped for about 10 minutes
  • I tried to close installer ([x] clicked)
  • no response
  • I killed task
  • reboot / blue screen

after report the installer is dead. uninstall, repair, install, everything ends in a rollback.

current installation (2.1.2) still works fine.

Attachments

setupapi.log Download (27.4 KB) - added by hole2 5 years ago.
MSI6b294.LOG Download (385.9 KB) - added by hole2 5 years ago.
MSI5fe7e.zip Download (53.9 KB) - added by agry75 5 years ago.
agry75's MSI log
setupapi.zip Download (285.4 KB) - added by agry75 5 years ago.
agry75's setupapi log

Change History

Changed 5 years ago by hole2

Changed 5 years ago by hole2

comment:1 Changed 5 years ago by hole2

read "report" as "reboot"

comment:2 Changed 5 years ago by hole2

attached files show what happens if I install now.

files during the first 2.1.4-install process are gone.

comment:3 follow-up: ↓ 4 Changed 5 years ago by sandervl73

Try to uninstall 2.1.2 first. Reboot and then install 2.1.4.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 5 years ago by hole2

2.1.2 rapair runs without problems. 2.1.2 uninstall rolls back without uninstalling

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 5 years ago by misha

Replying to hole2: Try to do the following:

  1. right-click on one of your network connections, select "Properties" -> this will open the properties dialog for that network connection
  2. you should see a "Virtualbox Host Interface Networking Driver" component listed there -> select it and click the "Uninstall" button
  3. reboot (if required)
  4. try to uninstall the VBox 2.1.2
  5. if uninstall succeeds try installing 2.1.4


Please post here if you see any problems with any of the above steps.

comment:6 in reply to: ↑ 5 Changed 5 years ago by hole2

Can't uninstall.

Error message pops up and says (I translate from german to english) "the componente "virtualbox host interface networking driver" can not be uninstalled. virtualbox host interface networking driver is currently in use by the following components and can be uninstalled, if those were uninstalled: Sun xVM Virtualbox.

(Die Komponente "virtualbox host interface networking driver" konnte nicht deinstalliert werden. virtualbox host interface networking driver wird momentan von folgenden Komponente(n) benötigt und kann erst entfernt werden, wenn diese deinstalliert sind: Sun xVM Virtualbox)

comment:7 Changed 5 years ago by hole2

Problem still exists.

comment:8 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please try again with 2.2.2 and reopen if necessary.

comment:9 Changed 5 years ago by hole2

  • Status changed from closed to reopened
  • Resolution fixed deleted

Same as before. Installer 2.2.2 simply rolls back without any actions.

comment:10 Changed 5 years ago by pentagonik

@hole2: Did you try the MS Installer CleanUp utility? More info:  http://www.virtualbox.org/wiki/MSI_Logging in chapter "Cleaning Up".

comment:11 Changed 5 years ago by hole2

Sorry, I'm not very confident that another tool might solve the problem.

To me it looks like noone has a clue what is going wrong and why VB messed up. And now we take some shotgun action hoping to hit some bugs... and hoping to not hit bystanders.

comment:12 Changed 5 years ago by pentagonik

It's hard to debug and/or fix a problem one can't reproduce. So all we can do here is to request logs and asking the users to try out some things.

comment:13 Changed 5 years ago by hole2

Thats what I meant.

"Cleanup" does not log and does not find errors. It simply tries to remove the trouble maker.

So it is not clear what will be the result. Worst case: an unusable system. Or a working system but nothing about the real problem has been learned.

comment:14 follow-up: ↓ 15 Changed 5 years ago by agry75

I seem to be having similar issues to hole2.

Started off with an earlier (probably 2.2.0) release of VirtualBox installed on an XP SP3 machine and attempted to replace it with the latest 2.2.2 version. I get to the networking section of the install (successfully confirm the installation of the drivers) and then the installer hangs. It won't let me cancel, either. The only way to remove it is to kill it in Task Manager.

Interestingly, rebooting after installation and then attempting a "repair" via Add Remove Programs tries to reinstall the networking drivers but ultimately with the same result.

I tried the Windows Install Clean Up tool but that didn't seem to help at all. I can uninstall but still can't reinstall afterwards.

Any suggestions as to what to try next?

comment:15 in reply to: ↑ 14 Changed 5 years ago by misha

Replying to agry75: please attach  msi log for your hanging installation here

Changed 5 years ago by agry75

agry75's MSI log

Changed 5 years ago by agry75

agry75's setupapi log

comment:16 Changed 5 years ago by agry75

@misha: Thanks for your response.

I've attached my MSI and setupapi logs as requested.

What is curious is that I left my machine running after having tried the installation presuming that it had hung as described by other users. However when I went to shutdown the machine the installer came "back to life" during the shutdown process and seemed to complete the installation. I haven't tried trawling through the logs but perhaps some process is blocking during installation and happened to get unblocked during shutdown? On a reboot I tried VirtualBox and the NAT portion at least seems to be working: it is returning a sensible IP address and I can access the Internet through the Windows 2k3 VM I am running through VirtualBox. I haven't dared trying to uninstall reinstall or anything complicated like that(!)

I would be interested to hear your thoughts on this and if you can derive anything from the logs. It's much appreciated the support you and the team give to this excellent free application.

comment:17 Changed 4 years ago by Technologov

Is this still relevant for v3.x ?

comment:18 Changed 4 years ago by hole2

Yes.

Installer 3.0.10 can't install VB.

"Sun VirtualBox setup ended prematurely because of an error. " and so on.

comment:19 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 2.1.4 to VirtualBox 3.0.10

Attach a new setup log please.

comment:20 Changed 4 years ago by Technologov

sandervl73: As I understand him -- he has very old host with VBox v2.1.4 which refuses to uninstall.

So VBox 3.0.10 cannot install itself. If I understand it correctly, the only possible solution -- is to make v3.x future release capable to uninstalling damaged older releases or overwrite damaged installs.

-Technologov

comment:21 Changed 4 years ago by hole2

Technologov: you are right. I assumed 3.x can uninstall/repair/whatever my broken version.

comment:22 Changed 4 years ago by Technologov

Nope. The new installer calls the old uninstaller. It is dependent on it. If the old one fails, you cannot install new version, so you basically stuck.

Either v3.x future installer (optionally) must be able to overwrite any junk left in host -or- I recommend to close this bug as WONTFIX, and add to documentation how-to manually remove the old junk (old broken version of VBox).

-Technologov

comment:23 Changed 4 years ago by hole2

Closing as WONTFIX sounds good to me. MS Virtual PC works great here... :-)

But is there a working, verified way to remove old junk? Please no shotgun methode that is based on hope to hit something.

comment:24 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

It looks like your INF cache is corrupt. Could you try to uninstall VirtualBox, reboot (just for sanity), remove the %SystemRoot%\inf\INFCACHE.1 file, reboot and try to install again.

Please reopen this ticket is still relevant.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use