VirtualBox

Ticket #3373 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

installation ended prematurely

Reported by: eleguen Owned by:
Priority: major Component: installer
Version: VirtualBox 2.1.4 Keywords: prematurely network
Cc: Guest type: other
Host type: Windows

Description

I tryed to install virtualbox 2.1.2 and 2.1.4 with both I gave the same problem of installation : "installation ended prematurely" The installation of virtual network does not work. I've sent my logs to a sun developper via mail and hope he will find something interesting in it. I thing I didn't choose the good time to try this soft. I've never be able to install it at this time.

Have you the same problem with 2.1.4 ?

Attachments

vbox_setupapi.app.log Download (93.9 KB) - added by adigiuseppe 5 years ago.
VB setupapi.app.log
vbox_setupapi.dev.log Download (387.1 KB) - added by adigiuseppe 5 years ago.
eleguen_setupapi.log Download (132.9 KB) - added by eleguen 5 years ago.
eleguen_virtualbox.log.zip Download (42.2 KB) - added by eleguen 5 years ago.
h.codebilis.MSI640f.VB-2.1.4-42893-Win_amd64.LOG.zip Download (49.4 KB) - added by h.codebilis 5 years ago.
msi log for virtualbox 2.1.4 on Vista Ultimate x64
h.codebilis.VB-2.2.0-45846-Win.zip Download (54.5 KB) - added by h.codebilis 5 years ago.
install log for VB 2.2.0 only; deleted old logs before install

Change History

Changed 5 years ago by adigiuseppe

VB setupapi.app.log

comment:1 Changed 5 years ago by adigiuseppe

Tried upgrading from VB 2.1.2 to 2.1.4 on Vista Enterprise SP1; installation failed.

Uninstalled 2.1.2 and re-tried installing 2.1.4, installation failed.

Deleted all remaining VB files and combed through registry to remove all entries referencing VB.

Re-tried 2.1.4 install without success, worse still, now I cannot re-install 2.1.2!

I am dead in the water, with no way of running my VB VMs.

I thought that 2.1.4 would fix these installer issues?

(setupapi.app.log attached)

comment:2 Changed 5 years ago by adigiuseppe

WINDOWS EVENT VIEWER DATA:

Log Name: Application Source: MsiInstaller Date: 18/02/2009 9:58:59 PM Event ID: 1033 Task Category: None Level: Information Keywords: Classic User: XXX Computer: XXX Description: Windows Installer installed the product. Product Name: Sun xVM VirtualBox. Product Version: 2.1.4. Product Language: 1033. Installation success or error status: 1603. Event Xml: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="MsiInstaller" /> <EventID Qualifiers="0">1033</EventID> <Level>4</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2009-02-19T02:58:59.000Z" /> <EventRecordID>14586</EventRecordID> <Channel>Application</Channel> <Computer>XXX</Computer> <Security UserID="S-1-5-21-624298840-1373833918-314601362-4883" />

</System> <EventData>

<Data>Sun xVM VirtualBox</Data> <Data>2.1.4</Data> <Data>1033</Data> <Data>1603</Data> <Data>(NULL)</Data> <Data> </Data> <Data> </Data> <Binary>7B39464430363134372D424137452D343446352D423545382D4234463536324136323039387D</Binary>

</EventData>

</Event>

comment:3 Changed 5 years ago by misha

Could you also attach a setupapi.dev.log file that should reside in the same place as setupapi.app.log and virtualbox install log created using steps I wrote you in email?
I saw your mail with XP SP3 log files. Do you see this with XP as well?

Changed 5 years ago by adigiuseppe

comment:4 Changed 5 years ago by eleguen

I don't know misha if the question about XP is for me but I can't answear because I've not an XP installed on my PC only XP Home SP3. I tried on an XP Pro SP3 and it worked but it's not the same PC as the XP Home SP3 (hardware, software are differents) I think the problem is when VB installs the virtual network ... I don't know if it's important but I use the Windows Firewall + an other (CHX) Maybe the virtual network can't attach to these different entries in the registry or I don't know what else ... I'm administrator of my PC so it's not a problem of policies.

comment:5 Changed 5 years ago by misha

nevermind, please attch the complete set of log files here. see  http://www.virtualbox.org/ticket/1730#comment:82 for detail.

Changed 5 years ago by eleguen

Changed 5 years ago by eleguen

comment:6 Changed 5 years ago by eleguen

Did you have time to analyse my logs misha ? something interesting ?

comment:7 Changed 5 years ago by misha

I looked into your logs briefly, but can not figure out the problem root cause yet.
There seem to be some error when configuring bindings with VMWare bridge interface according to the logs.
What VMware version do you have installed?

comment:8 follow-up: ↓ 9 Changed 5 years ago by eleguen

I installed and desinstalled vmware a long time ago. There should be nothing about vmware. Do you know what I can remove about vmware ?

comment:9 in reply to: ↑ 8 Changed 5 years ago by misha

Replying to eleguen:

I installed and desinstalled vmware a long time ago. There should be nothing about vmware. Do you know what I can remove about vmware ?

Open the properties dialog for one of your network connection (rightclick on the connection in the network connection management window and select properties),
I guess there should be some VMware bridge component in the component list.
Try to uninstall it by selecting the component and clicking "Uninstall"

comment:10 Changed 5 years ago by adigiuseppe

I took a second look and found some left-over VMware devices; I uninstalled them. Tried re-installing without success.

I then went into the network adapter properties and found that the VMware bridge protocol was still present; I uninstalled them as you suggested and retried installation - SUCCESS!

Thank you - the issue was essentially a messy VMware uninstall that left cruft in the system; is there any way you can make the VB installer smarter by asking to remove the offending software, or work around it?

Thanks again,

Alessandro

comment:11 Changed 5 years ago by eleguen

I think there's a mistake misha, you didn't look at my logs but adigiuseppe's logs. I have no vmware bridge on my network interface.

comment:12 Changed 5 years ago by eleguen

As there was 2 different bugs, may I have to open a new post ? This one was mine.

comment:13 Changed 5 years ago by misha

right, there are two different issues listed here which made me confused first.
I'll have look into your logs soon, no need for a separate bug entry, sorry for taking it long..

comment:14 Changed 5 years ago by adigiuseppe

eleguen: Sorry for hijacking your bug post, I genuinely thought we shared the same issue; apologies for any confusion.

Hope they kill your bug soon.

Alessandro

comment:15 Changed 5 years ago by eleguen

no problemo Alessandro, I thought we had the same issue too (us and all who have the same message in VB 2.1.x) In my post I asked everyone if they had the same message. Now I see that we can have the same message but not the same issue. Misha has some work with us and I thank him for his help. (sorry for my probably incorrect english)

comment:16 Changed 5 years ago by eleguen

up

comment:17 Changed 5 years ago by eleguen

Hello

comment:18 follow-up: ↓ 21 Changed 5 years ago by eleguen

no news = good news ?

comment:19 Changed 5 years ago by eleguen

Thanks for all !

Kenavo.

comment:20 Changed 5 years ago by misha

Sorry for taking so long to reply. Unfortunately the setupapi log you posted provides no clue for the issue :(
The NetFlt driver installation at some point just starts rolling back for some reason.

The good news is that I was able to reproduce a problem similar to what you're seeing.
This happens on one of my dirty misconfigured systems and I'm not sure what exactly causing it for now,
but being able to reproduce it should help find a clue.

comment:21 in reply to: ↑ 18 ; follow-up: ↓ 22 Changed 5 years ago by misha

Replying to eleguen:

Your issue should be fixed finally.
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

comment:22 in reply to: ↑ 21 ; follow-up: ↓ 23 Changed 5 years ago by h.codebilis

Replying to misha:

Replying to eleguen:

Your issue should be fixed finally.
Please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing installation fixes.

I'm seeing the same failure under Vista Ultimate x64. I've tried 2.0.4, 2.1.4, and 2.2.0. All yield the same result. I was able to get the 2.2.0 install to complete by selecting "install when needed" for USB and network drivers. Unfortunately, the USB support doesn't seem to install automatically, so I dont have access to USB. I can attach the logs for the failed install attempts, but they're close to 7MB ... zipped. Any suggestions?

comment:23 in reply to: ↑ 22 ; follow-up: ↓ 24 Changed 5 years ago by misha

Replying to h.codebilis: I beleive msi log (msi*.log) should not be that big. Could you post it here first?

Changed 5 years ago by h.codebilis

msi log for virtualbox 2.1.4 on Vista Ultimate x64

comment:24 in reply to: ↑ 23 ; follow-up: ↓ 25 Changed 5 years ago by h.codebilis

Replying to misha:

Replying to h.codebilis: I beleive msi log (msi*.log) should not be that big. Could you post it here first?

My bad ... I thought you needed all the logs, including setupapi.app.log, which is approx 87MB (unzipped) on my machine. I attached the MSI log above. Thanks for the help. - John

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 5 years ago by misha

Replying to h.codebilis: Thanks, the log says you have a problem installing USB driver.
So I will need your setupapi logs. This does not have to be a complete log files. Just the last parts of them concerning the latest installs.
Alternatively you might remove (move somewhere else) your current setupapi log files and run the installation. In this case new log files will be created containing info of the latest install.

Changed 5 years ago by h.codebilis

install log for VB 2.2.0 only; deleted old logs before install

comment:26 in reply to: ↑ 25 ; follow-up: ↓ 27 Changed 5 years ago by h.codebilis

Replying to misha:

Replying to h.codebilis: Thanks, the log says you have a problem installing USB driver.
So I will need your setupapi logs. This does not have to be a complete log files. Just the last parts of them concerning the latest installs.
Alternatively you might remove (move somewhere else) your current setupapi log files and run the installation. In this case new log files will be created containing info of the latest install.

Logs attached. Thanks in advance ...

comment:27 in reply to: ↑ 26 ; follow-ups: ↓ 28 ↓ 29 Changed 5 years ago by misha

Replying to h.codebilis: There's an access denied error occuring for you while install. Do you have UAC enabled?
If yes, could you try running the installer with elevated privileges? I.e. for 2.2 installer - righclick the executable in explorer and press "Run as Administrator"

comment:28 in reply to: ↑ 27 Changed 5 years ago by h.codebilis

Replying to misha:

Replying to h.codebilis: There's an access denied error occuring for you while install. Do you have UAC enabled?
If yes, could you try running the installer with elevated privileges? I.e. for 2.2 installer - righclick the executable in explorer and press "Run as Administrator"

The logs I posted were produced using "run as administrator". I've noticed there are several virtual box files under system32: VBoxDrv.sys, VBoxDrv.cat, VBoxUSBMon.sys, and VBoxUSBMon.cat. All are stamped with file version 2.2.0. I also searched the registry for vbox* and found a number of hits; VBoxNetFlt.sys, VBoxNetFltNotify.dll, VBoxSvc.exe. Not sure if these are from v2.2 or from an older VBox install which is no longer on my machine.

comment:29 in reply to: ↑ 27 Changed 5 years ago by h.codebilis

Replying to misha:

Replying to h.codebilis: There's an access denied error occuring for you while install. Do you have UAC enabled?
If yes, could you try running the installer with elevated privileges? I.e. for 2.2 installer - righclick the executable in explorer and press "Run as Administrator"

While it would be great to know the source of this error, I decided yesterday to try re-installing Vista. This seems to have allowed the VirtualBox install to run to completion.

comment:30 Changed 5 years ago by pentagonik

As we gonna release a new version of VBox soon, please write me an e-mail to pentagonik at sun dot com to get the latest test version of VBox which now should be possible to install on your system. Please let me also know your host OS (Windows only!) and a short error description plus VBox version you tried to install before. Thanks!

comment:31 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please try again with 2.2.2 and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use