VirtualBox

Ticket #3364 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 5 years ago

Feature request: allow VM cloning from the GUI

Reported by: macias Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Maybe first of all what is the aim of that wish.

For example:

  • I have WindowsA guest, I would like to create WindowsB guest which would be initially identical to WindowsA. So I wouldn't have to install everything from scratch, but rather start from where I am with WindowsA

So, from user POV: a) I could copy .vdi and then create new guest selecting existing image -- it is not possible now, because .vdi file hold unique id and VB cannot recreate it (id) for such purpose as wished b) the whole copying could be done by VB -- clone feature. I select guest system, I click "clone", and I get functional clone which shares the same data as the source of the clone but from that point all the data, settings are separate

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Search for immutable in the user manual.

comment:2 Changed 5 years ago by sandervl73

There's a user forum where you could ask such questions before opening a defect.

comment:3 Changed 5 years ago by macias

  • Status changed from closed to reopened
  • Resolution worksforme deleted

First of all I didn't report defect, but a wish, and you didn't understand me.

I don't wish to have diff disk feature, but clone disk feature.

Easier example. a) text file A b) edit it c) copy A to B d) B is initially the same as A e) but later when you edit A and B they will start to differ more and more

As you can see both file are writeable, all changes are stored. The initial state of B is the same as A, but only initial (from clone/copy point), after a year they become completely different files.

If anything is unclear please ask, I will be glad to clarify. Reopening now.

comment:4 Changed 5 years ago by sandervl73

What is the difference? Either you store all changes to the base or you create a duplicate (clone) and use two disk images. You can't use one image for one VM and use a past/not current state as a base for the 2nd VM.

Both options are already possible. Before you open an enhancement defect it's also wise to ask for opions on the forum.

comment:5 Changed 5 years ago by macias

Oh boy, immutable disk has nothing common with cloning disk feature. The sufficient "proof" is this the first one is read-only, but after cloning it is writeable.

So my wish still stands: a) please provide way, so user would easily rewrite id b) that user could clone directly the disk

Maybe I clarify, I am talking about VirtualBox application, GUI one. Sure you can do almost everything with command line tools, but it is not user-friendly.

Example: ad.a) currently VB simply refuses to use disk with doubled id, it would be much more user-friendly and sane if instead of error, VB would display dialog "would you like to recreate id? [ yes ] [ no ]" ad.b) the same here -- delete VM, stop VM, new VM are present, why not add "copy VM", it is completely natural to add this feature

Again -- those examples refer to GUI way.

comment:6 Changed 5 years ago by sandervl73

  • Priority changed from major to minor
  • Component changed from other to GUI
  • Summary changed from ability to retake doubled vdi image or clone the image to Feature request: allow VM cloning from the GUI

Next time write down what you mean and don't leave me guessing. I'm well aware it's not possible with the GUI. You could have saved us both a lot of time.

comment:7 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

Duplicate of #2704 too.

comment:8 Changed 5 years ago by macias

Ok, I am sorry for that omission.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use