VirtualBox

Ticket #3352 (closed enhancement: invalid)

Opened 5 years ago

Last modified 4 years ago

Visopsys - Hard disk not detected

Reported by: austin987 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.1.2 Keywords: visopsys
Cc: Guest type: other
Host type: Windows

Description

Visopsys will now boot up under VirtualBox 2.1.2 without crashing (bug 144), but when install is selected, the hard disk is not selectable.

 http://visopsys.org/download/index.html

Hard disk is configured as 512MB dynamically expanding image, IDE Primary Master.

Visopsys version is 0.69.

Attachments

VBox.log Download (32.2 KB) - added by austin987 5 years ago.

Change History

Changed 5 years ago by austin987

comment:1 Changed 4 years ago by frank

  • Version changed from VirtualBox 2.1.2 to VirtualBox 3.1.2

Confirmed. Not sure if the visopsys kernel is too fussy or if the IDE emulation of VBox isn't 100% perfect.

comment:2 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to invalid

Looks like a bug in the IDE driver of the kernel to me. It assumes that interrupts are enabled for the controller which is not the case for VirtualBox (iirc the BIOS disables interrupts). Visopsys polls a variable which is set if an interrupt is asserted to wait for completion of IDENTIFY. The waiting times out after a while and an error is returned. The detect routine will skip the drive. CD-ROMs are working because the code issuing the IDENTIFY PACKET command doesn't wait for an interrupt but just waits until the busy bit in the status register is cleared.

Will close this ticket as invalid for now. If someone finds out that my findings are wrong please reopen and correct me :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use