VirtualBox

Ticket #3344 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Vista X86 Host, WinXP X86 Guest, BSOD after few days (minidump says "Probably caused by : ntkrpamp.exe")

Reported by: gaga11 Owned by:
Priority: critical Component: other
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Getting BSOD after few days:

Vista X86 Host (SP1) WinXP X86 Guest (SP2 including all updates) VirtualBox 2.1.2

minidump report:

Microsoft (R) Windows Debugger  Version 6.4.0007.2
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\Thomas\Desktop\Mini021509-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows Longhorn Kernel Version 6001 (Service Pack 1) MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 6001.18145.x86fre.vistasp1_gdr.080917-1612
Kernel base = 0x8223f000 PsLoadedModuleList = 0x82356c70
Debug session time: Sun Feb 15 15:12:05.617 2009 (GMT+1)
System Uptime: 4 days 4:23:59.029
Loading Kernel Symbols
.......................................................................................................................................................................
Loading unloaded module list
.....................
Loading User Symbols
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 18, {84768d40, 89fd3ad8, 2, 80001b8c}

Probably caused by : ntkrpamp.exe ( nt!PspThreadDelete+13a )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

REFERENCE_BY_POINTER (18)
Arguments:
Arg1: 84768d40
Arg2: 89fd3ad8
Arg3: 00000002
Arg4: 80001b8c

Debugging Details:
------------------


OVERLAPPED_MODULE:  dump_wmimmc

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  DRIVER_FAULT

BUGCHECK_STR:  0x18

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from 8244e70d to 8229088e

STACK_TEXT:  
8b373cd8 8244e70d 00000000 00000000 8a1c4570 nt!ObfDereferenceObject+0x66
8b373cec 82483617 89fd3ad8 82213110 8a1c4570 nt!PspThreadDelete+0x13a
8b373d08 822908c9 8a1c4588 00000000 8a1c4588 nt!ObpRemoveObjectRoutine+0x13d
8b373d34 822708fe 82341178 84790020 8234c9a0 nt!ObfDereferenceObject+0xa1
8b373d44 82277445 00000000 00000000 84790020 nt!PspReaper+0x5d
8b373d7c 82414b18 00000000 75cfdee8 00000000 nt!ExpWorkerThread+0xfd
8b373dc0 8226da2e 82277348 00000002 00000000 nt!PspSystemThreadStartup+0x9d
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


FOLLOWUP_IP: 
nt!PspThreadDelete+13a
8244e70d 5f               pop     edi

SYMBOL_STACK_INDEX:  1

FOLLOWUP_NAME:  MachineOwner

SYMBOL_NAME:  nt!PspThreadDelete+13a

MODULE_NAME:  nt

IMAGE_NAME:  ntkrpamp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  48d1b7fa

STACK_COMMAND:  kb

FAILURE_BUCKET_ID:  0x18_nt!PspThreadDelete+13a

BUCKET_ID:  0x18_nt!PspThreadDelete+13a

Followup: MachineOwner
---------


Attachments

Mini021509-01.dmp Download (140.1 KB) - added by gaga11 5 years ago.
minidump

Change History

Changed 5 years ago by gaga11

minidump

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use