VirtualBox

Ticket #3340 (new defect)

Opened 5 years ago

Last modified 4 years ago

Shared folder file creation/deletion not permitted on sub-folders, WinXP SP3 Guest

Reported by: ariel Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Shared folder issues with Virtualbox 2.1.2 running in a ubuntu 8.10 box, with a WinXP SP3 guest.

The guest can access the shared folder: it shows up in "My Network Neighbourhood" and it shows as \VBOXSVR\MYFOLDER

Using the File Explorer in the guest, I can select files, and do Copy/Paste to obtain a copy of the file. I can delete files with no issue.

However, when attempting to do the same in a sub-folder (e.g.: in \VBOXSVR\MYFOLDER\MISC), then I get an error message:

"Cannot copy file: cannot read from the source file or disk"

or if I attempt to delete a file I get:

"Cannot delete file: cannot read from the source file or disk"

I can edit files in sub-folders with no problems. I just can not do file operations on them.

In Linux, the folder I am sharing is in an EXT3 partition. I double checked Permissions and they look all right and they look the same for the root of the folder and its sub-folders:

/media/sda6/MYFOLDER: drwxrwx---

/media/sda6/MYFOLDER/MISC: drwxrwx---

Note: if I map the shared folder to a Drive (say X:), the same problem occurs (but the error messages are slighly different).

I believe this started happening with VBox 2.0

Attachments

VBox.log Download (61.1 KB) - added by antonio.guadagnin 5 years ago.
VBox.2.log Download (133.0 KB) - added by NoraaC 4 years ago.

Change History

comment:1 Changed 5 years ago by frank

Do I understand you correct that you can edit+save file in a subfolder but not copy/remove them? The permissions you showed look correct so far. What is your umask on the host? And please could you attach a VBox.log file of such a session when you tried such file operations which failed on a subfolder?

comment:2 Changed 5 years ago by frank

antonio, I have deleted your last comment as it was completely screwed up. Please could you use the Attach button to attach VBox.log files?

Changed 5 years ago by antonio.guadagnin

comment:3 Changed 5 years ago by antonio.guadagnin

I confirm the problem in subfolders of shared folders - Virtualbox on OpensSuse 11.0 host with winXP SP3 guest.
In root folder of a shared folder all operations are permitted ( create, copy, paste, edit+save, delete).
In subfolders only create and edit+save are ok.
Copy is slow.
Paste is possible after some attempts with windows pupup error.
Delete never.

comment:4 Changed 5 years ago by gregdavisfromnj

I am using VirtualBox 3.0.8 with an upgraded additions in my guest and I see same problem. Windows Vista Business Host, XP Pro SP3 Guest.

Using a Linux guest like Kubuntu, and the vboxsf filesystem there, I don't have this problem. In fact, I can navigate to the same file I can't delete in the XP guest, and delete it in the Kubuntu guest. So it doesn't seem like the problem has to do with the host filesystem. Also, the path plus filename length is not that long so I don't think it is a matter of path length restrictions in Windows.

comment:5 Changed 4 years ago by daban1

Same problems on VirtualBox 3.0.10 on OSX running XP SP2. Root folder of share works fine. Sub folders allow new and saving edits, but error out on delete.

comment:6 Changed 4 years ago by Tokamak

I have experienced the same problem with VirtualBox 3.1.2 on host Ubuntu 9.04 64bit with guest WinXP SP3 32bit. Using the guest's explorer one can create and edit files and folders in the vbox share, but one cannot delete any folder or files in subfolders. Additionally it takes a long time to open the exlporer's properties dialog of a filesystem object within the share.
It seems to be a problem of the explorer. In a DOS box on the same system and vbox share one can delete folders and files without any problem.

Because I need the shares I have searched for workarounds. One was to share the directories using samba on the host. This was up to 10 times slower than accessing the same files via \vboxsvr. So this was not an option.

After several tests I have found a workaround. After mapping a drive e.g. with

net use x: \vboxsvr\share

the problems stated above occur. You can create x:\text.txt and delete it with the explorer. You can create x:\folder, but cannot delete it. You can create and edit x:\folder\text.txt, but cannot delete it.

After mapping x: with subst like

subst y: x:\

one can work with y: without any problems. So y:\folder or y:\folder\text.txt can be created, edited and removed using the explorer, while the same objects cannot be removed using x:.

The workaround is very fresh. I did some tests, have installed programs on y:, without problems. It seems to work.

Maybe this gives the developers an idea where the problem have to be searched - if they care about it.

comment:7 Changed 4 years ago by daban1

I used Samba on the Mac and had decent enough speed for what I needed. We've just switched to Fedora and have the same lag/delete issues with the shared folders. I just tried your fix and wow. There is an amazing difference. Speed is much faster and delete works. I've only done a handful of tests so far, but this is a big help. Thanks.

comment:8 Changed 4 years ago by ChuckDtol

Tokamak - You are a God! I've been struggling with this problem for at least 2 months since I switched to Linux, with no workaround and no solution; then I found your post here. :}

I reproduced this bug EXACTLY as you described (root folder OK, sub-folders fail) and your work-around works for me too. (What ever made you think of the subst command?) THANK-YOU!

To help those who (should be) chasing down the bug, my config is as follows, in the hope it may be helpful. WinXP SP3 Guest on top of Ubuntu 9.10 Host (kernel 2.6.31.19 x64 version), on AMD dual core 64bit CPU. It has occurred since 2.6.31.14 (or earlier) and with VirtualBox 3.1.4 and 3.1.2 (possibly earlier) with the Windows guest addons installed (both 3.1.2 and 3.1.4).

Thanks for finding a workaround. Lets hope that the bug is fixed soon for all those who have wasted time and have not discovered the way around it.

comment:9 Changed 4 years ago by antonio.guadagnin

Yes, it works !!!!

subst z: \vboxsvr\share

comment:10 Changed 4 years ago by ChuckDtol

Hopefully the subst workaround will shed some light on the diagnosis.

The VirtualBox forum Thread at  http://forums.virtualbox.org/viewtopic.php?f=2&t=27062&start=0 shows others with the problem and adds some diagnostic information.

This bug is over a year old. It is affecting a number of people. I encourage whoever screens these bugs and actions them to stimulate a solution.

comment:11 Changed 4 years ago by leo128

Hi All!

I too have been struggling with this problem in the last two weeks. However, it's strange that I've been using virtualbox for about two years and a half without noticing this problem, and I've always been doing the same things with network and shared folders.

My scenario is as follows:

Ubuntu 9.10 (Karmic Koala) HOST, ext4 Filesystem. Windows XP Pro SP3 (GUEST) /home/leo128/mySharedFolder shared with RW access. \vboxsvr\mySharedFolder mounted at W: in the guest.

However, I only notice the problem when using the windows shell (explorer)... my batch files (or commands given in the command line) or any other application are correctly accessing / modifying the contents of the W: virtual network drive.

glad the subst workaround is working around!

Hope this helps!

comment:12 Changed 4 years ago by vboxfisch

Hey guys,

I think I know what causes the problem.

I installed windows xp (SP2) on VBOX 3.0.12 (Debian Linux 64bit) and everything was fine. Then I installed immediately Office XP and the problem occurred Word can't save files at all.

It got better by writing "127.0.0.1 vboxsvr" in the ...system32\drivers\etc\hosts but the problem was still there. With this change Word could save files, but the problems as described above occurred.

Your workaround works!

Hopefully this will be fixed soon.

comment:13 Changed 4 years ago by ChuckDtol

Update. I just installed the VirtualBox 3.1.6 (r59338) update that was released this week. I upgraded both the VirtualBox Host machine and the Windows guest VirtualBox add-ons. I then tested to see if a file in the sub-folder of the shared folder could be modified or deleted. Sadly no.

The bug as documented is, unfortunately, still not fixed. :{

Changed 4 years ago by NoraaC

comment:14 Changed 4 years ago by NoraaC

I too have this problem with WinXP & Win7 Guests on several different machines all running different versions of Ubuntu 8.04 32bit, 9.04 32bit, 9.04 64bit and 2 machines testing 10.04x32.

Right clicking on a file or folder in explorer there is a several second lag before the context menu pops up and then another lag after clicking on delete before the message "E: is not accessible"

Some programs like Quickbooks can create, delete & overwrite OK - Some like Foxpro can create and delete but not overwrite - others don't work at all.

The same operations on the same shared folder in a Win2000 VM work without a problem.

I just came across a thread in the Windows Guest forum pointing to this ticket - I tried the subst workaround and everything I have tried on this machine so far works.

I have seen this behavior on all versions of 3 up to and including 3.1.6

I have been searching the forums off and on for several months looking for someone with the same problem and was reluctant to file a bug report as it seemed like it only happened to me. I was starting to think I was missing something really simple in my setups.

Glad to see I may not be as dumb or crazy as I thought.

I will attach my latest Vbox.log on the off chance it may be of some use.

Here's hoping we can get a real fix.

comment:15 Changed 4 years ago by ChuckDtol

Update. I just installed the VirtualBox 3.1.8 (r61349) update that was released this week. I upgraded both the VirtualBox Host machine and the Windows guest VirtualBox add-ons. I then tested to see if a file in the sub-folder of the shared folder could be modified or deleted. Sadly no. The bug as documented is, unfortunately, still not fixed. :{

comment:16 Changed 4 years ago by NoraaC

Sorry to hear that. I had hopes but there wasn't anything in the changelog that sounded like this problem so not much hope.

A little more info in hopes it will help someone track this down.

I copied some data files into the shared folder from a non shared folder on the host. (Jaunty 64) Then from within the VM I attempted to copy the data files from the shared folder to a subfolder of C:\Program Files" in Win7-32. Got message about overwriting same named files in target folder and needing admin rights. After confirming overwrite and entering admin password got message saying source folder inaccessible.

This happened on both the original shared folder and the one created with subst.

I was able to copy the same files to another folder in C: not in program files then was able to copy and paste from that folder to the one in program files.

Sure seems like a real bug.

comment:17 Changed 4 years ago by StephC

Same problem here using VBox 3.1.8 on Ubuntu 10.04 running Win XP SP3.

comment:18 Changed 4 years ago by larryliu

For those of you who are running Win XP SP3 guests you need to make sure that Offline Files feature is disabled within the guest OS. Here is the instruction on how to do that.  http://www.learnfromscreenshots.com/mediawiki/index.php/Disable_Offline_Files

comment:19 Changed 4 years ago by StephC

Thanks larryliu, your workaround works and is simpler than mapping a drive. Stéphane

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use