VirtualBox

Ticket #3338 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

Crash in QRegion::cleanUp

Reported by: greenrd Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

This is with latest from SVN. At the time I had just logged in to virtual terminal 2 on the guest, and ran "startkde" with DISPLAY pointed at an X server on the host. I had then switched away from the VirtualBox VM window.

Thread 0 Crashed:
0   QtGui                               0x00b414c0 QRegion::cleanUp(QRegion::QRegionData*) + 32
1   QtGui                               0x00b41540 QRegion::operator=(QRegion const&) + 48
2   QtGui                               0x00a1a4dc QWidgetPrivate::qt_widget_event(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 4220
3   com.apple.HIToolbox                 0x9431f143 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
4   com.apple.HIToolbox                 0x9431e57d SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
5   com.apple.HIToolbox                 0x9431e3e2 SendEventToEventTargetWithOptions + 58
6   com.apple.HIToolbox                 0x94341e01 HIView::SendDraw(short, OpaqueGrafPtr*, __HIShape const*, CGContext*) + 475
7   com.apple.HIToolbox                 0x943418ee HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 734
8   com.apple.HIToolbox                 0x94341a52 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1090
9   com.apple.HIToolbox                 0x94341a52 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1090
10  com.apple.HIToolbox                 0x94341a52 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1090
11  com.apple.HIToolbox                 0x94341a52 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1090
12  com.apple.HIToolbox                 0x94341a52 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1090
13  com.apple.HIToolbox                 0x94340cec HIView::DrawComposited(short, OpaqueGrafPtr*, __HIShape const*, unsigned long, HIView*, CGContext*) + 668
14  com.apple.HIToolbox                 0x943409ff HIView::Draw(short, OpaqueGrafPtr*, unsigned long) + 83
15  com.apple.HIToolbox                 0x9434094f HIView::Render(unsigned long, CGContext*) + 45
16  com.apple.HIToolbox                 0x94348d8b FlushWindowObject(WindowData*, void**, unsigned char) + 749
17  com.apple.HIToolbox                 0x943487a2 FlushAllBuffers(__CFRunLoopObserver*, unsigned long, void*) + 168
18  com.apple.CoreFoundation            0x921739a2 __CFRunLoopDoObservers + 466
19  com.apple.CoreFoundation            0x92174bd2 CFRunLoopRunSpecific + 546
20  com.apple.CoreFoundation            0x92175cd8 CFRunLoopRunInMode + 88
21  QtGui                               0x00a077f2 QEventDispatcherMac::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 690
22  QtCore                              0x004d0e81 QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 65
23  QtCore                              0x004d0f4d QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 157
24  QtCore                              0x004d4ee1 QCoreApplication::exec() + 161
25  VirtualBoxVM                        0x00002583 TrustedMain + 1763 (main.cpp:410)
26  VirtualBoxVM                        0x00001e06 start + 54

Attachments

VBox.log Download (39.8 KB) - added by greenrd 5 years ago.
VirtualBoxVM_2009-02-14-093134_robin-greens-macbook-pro.crash Download (36.7 KB) - added by greenrd 5 years ago.

Change History

Changed 5 years ago by greenrd

comment:1 Changed 5 years ago by greenrd

I just tried again - the crash happens again at approximately the same time, but in a different part of Qt. Looks to be a memory corruption issue.

I will now try to bisect SVN to find the commit responsible.

comment:2 Changed 5 years ago by greenrd

Results of SVN bisection:

Revision 16571 appears not to exhibit this bug.

Revision 16578 reproducibly exhibits this bug (although, again, not with the same stack trace every time - appears to be a memory corruption bug).

Revisions inbetween the above two revisions could not be tested, mostly because NAT networking was broken in those revisions.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for the report, but could you please use the developer's mailinglist for such issues? The SVN tree is not an officially supported platform and things change rather quickly there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use