VirtualBox

Ticket #3331 (reopened enhancement)

Opened 5 years ago

Last modified 4 years ago

Window task bar title of VBoxSDL VMs

Reported by: olav Owned by:
Priority: trivial Component: other
Version: VirtualBox 2.1.2 Keywords: vboxsdl
Cc: Guest type: Linux
Host type: Linux

Description

When I run a virtual machine with VBoxSDL -vm Mymachine, a window is created with the title "Sun xVM VirtualBox - Mymachine". This is different from starting it from the main program, when it creates a window titled "Mymachine [Running] - Sun xVM VirtualBox". The latter is preferable because it makes it easier to recognise the window on the Gnome Panel (and, I suppose, its equivalent in KDE, Windows etc.).

When starting two or more virtual machines (with launchers I made on the desktop) and minimising them, they are now both identified as "Sun xVM VirtualBox" on the panel. Confusing.

Of course this is only a cosmetic issue and not a very big deal really, but I suspect it's less than a 5 minute job to change it. I hope one of the developers will be so kind...

Attachments

captions.png Download (119.8 KB) - added by olav 4 years ago.
clarifying screenshot
icewm.png Download (51.2 KB) - added by olav 4 years ago.
fluxbox.png Download (42.0 KB) - added by olav 4 years ago.

Change History

comment:1 Changed 4 years ago by frank

  • Summary changed from Window title of VBoxSDL to Window title of VBoxSDL => Fixed in 3.1.4

Thanks for the suggestion. This will be fixed in VBox 3.1.4 final.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 4 years ago by olav

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am now using VirtualBox 3.1.6 which I downloaded from the website. Unfortunately the problem is still the same. I am using Ubuntu 10.4 that has Gnome 2.30.0. The caption on the panel is just "Sun VirtualBox". I suppose in the nearby future this will have to become "Oracle VirtualBox". Perhaps then is also the time to fix this little usability annoyance? Thanks anyway, I really like VirtualBox regardless.

comment:4 Changed 4 years ago by Technologov

Please close, as WONTFIX.

Oracle branding is only for v3.2 and upwards.

-Technologov

Changed 4 years ago by olav

clarifying screenshot

comment:5 follow-up: ↓ 6 Changed 4 years ago by olav

Sorry Technologov for perhaps not being entirely clear. The specific product name (Sun Virtualbox or whatever) is not the issue here. I have attached a screenshot that should be more obvious than my description of this bug.

comment:6 in reply to: ↑ 5 Changed 4 years ago by olav

Just to confirm, as expected the problem is still present in 3.1.8 as well.

comment:7 Changed 4 years ago by frank

Please post again which title is shown for you and which title you expect. For VBoxSDL has the title VM_NAME - Sun VirtualBox. The word Sun will be changed to Oracle eventually but I assume this is not what you are complaining about, right?

comment:8 Changed 4 years ago by olav

Frank, thank you for your interest. However I doubt I can be much clearer than I already was, especially in the screenshot. Please take a look at it, it should answer all questions. As you can see it is just impossible to identify different VM windows on the task bar when they are minimised. Just for the record, I now realise that something has indeed changed since I first filed the bug; it's just not for the better. Previously (at the time of filing the bug) the caption on the task bar was "Sun VirtualBox - Machine Name" (where "Machine Name" would be invisible because the caption would not fit inside the button). Now it is just "Sun VirtualBox" WITHOUT the machine name, meaning you can't even rely on tooltips to reveal the full title...

Just to be extra, extra clear, if I can: the title of this bug is not accurate and may be misleading. It is not the window title that is the issue. It is the title of the button/tab on the taskbar (and the fact that it is not the same as the window title) that is the issue.

I only mentioned the name change to Oracle because I assumed that would be a good time for developers to take a look at this. If you have to change the titles anyway, might as well correct this little bug with the same effort, or so was my thinking. Because I would not want people to do any extra work to fix this small annoyance. It really is only a minor thing. Personally I have now "solved" it by starting VMs with "VBoxManage startvm machine_name". Those windows behave exactly like they were launched from the VirtualBox GUI.

comment:9 Changed 4 years ago by frank

  • Summary changed from Window title of VBoxSDL => Fixed in 3.1.4 to Window task bar title of VBoxSDL VMs

I assume this is a problem with your window manager because this works fine here for both the window title and the title displayed in the task bar.

Changed 4 years ago by olav

Changed 4 years ago by olav

comment:10 Changed 4 years ago by olav

Thank you again Frank. Yes, now that you mention it there does seem to be an interaction with the window manager or desktop environment. Following your remark I just tried IceWM and Fluxbox. In IceWM, the problem is the same as I described for Gnome (Metacity). While using my virtual machines in Fluxbox the captions on the task bar do appear correct. I attached two more screenshots.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use