VirtualBox

Ticket #3295 (closed enhancement: wontfix)

Opened 5 years ago

Last modified 5 years ago

Improvement Proposal: Attach USB Mouse or keyboard depending on Input focus of guest

Reported by: harald_nuernberg Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I would like to propose an improvement proposal for experienced users of VB. I running a guest on Mac Mini. I have a Microsoft Natural Keyboard and a Logitech G4 Mouse. The mouse needs a special driver on Windows to access special functions (like left/right wheel, etc.). Also, the keyboard has special function I would like to use on the guest.

Virtualbox has a function to route USB devices directly to the guest. But the problem is then that I cannot use the mouse and keyboard on the host. So my idea is now a setting to connect these USB devices directly to the guest only when the guest has input focus. If not these devices automatically connected to the host. This has the advantage that I can use the vendor specific drivers for the mouse and the keyboard on the guest. Of course, the guest has then to watch for key event when to give the input focus to the host and has to perform this (through the guest additions).

What is your opinion?

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

I don't think that a dynamic catch and release of USB devices makes sense because this could happen very often (user enters and leaves the window very often) and each cycle takes some time, perhaps some seconds for the guest to detect the new device. Or at least for the host to give away control for this device.

The fix you need is to extend the virtual mouse device by more functions and to pass these functions to the guest. There is another such ticket open. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use