VirtualBox

Ticket #3271 (new defect)

Opened 5 years ago

Last modified 3 years ago

TFTP Failure with WDS 2008

Reported by: DreadPirate Owned by:
Priority: major Component: network
Version: VirtualBox 2.1.2 Keywords: PXE, 2008, WDS
Cc: Guest type: Windows
Host type: Linux

Description

With a Windows 2008 Guest running the Windows Deployment Server and a second guest to deploy to, I have run into an issue where the second guest can PXE boot from the WDS server, but is never able to complete the TFTP download of the Windows boot image to use for installing the OS. The download will start, but is never able to complete. I have tried this with both an internal network and with both guests attached to the host network. No combination of settings has produced a result that works consistently.

Attachments

Win 7 Home pxe-2010-02-25-15-08-28.log Download (55.3 KB) - added by style 4 years ago.
My log about this bug
Srv2k8-2010-02-25-15-19-28.log Download (58.3 KB) - added by style 4 years ago.
Server log, Win 7 Home.log is the log of the client
travbrack_Intel_Pro1000_MT_Desktop.log Download (40.2 KB) - added by travbrack 4 years ago.
Travbrack log file

Change History

comment:1 Changed 5 years ago by bb84

I can confirm this Problem. Download interrupts...

comment:2 Changed 5 years ago by bb83

Problem still exists in 2.1.4

comment:3 Changed 5 years ago by webJose

This problem seems to affect VBox 2.2.0 as well. I am just testing the exact scenario described here, but with Windows Server 2008 R2 Beta x64.

The PXE client was able to go all the way up to the download of \Boot\Boot.sdi. When downloading this file (3 MB file), it just goes slower than a crippled turtle. I don't know at this point if the file transfer will complete or not, but even if it does, it is just an unacceptable amount of time.

comment:4 Changed 5 years ago by mike.merrett@…

I can confirm the same thing with VB 3.0.2 This was very embarrassing for me as the failure occurred in front of my customer. Vista would not deploy... I tried each of the three Intel network adapter types with similar failures. Ironically it got past the initial problems when I chose the AMD PCNET as the interface - but of course the boot image didn't contain that driver so it failed.

I guess I could have asked the sysadmin to embed the AMD_Pcnet folder that used to be present on VB Additions ISO files up to 2.0.8 into his vista image, in the hope that we could have got further. But I didn't have that ISO with me as this was all based on 3.0.2.

Why is this problem still open and unresolved after so long? I can't believe nobody has tried deploying classic and recent Windows guests using WDS from 2008 servers!

comment:5 Changed 4 years ago by klaus

No one has attached a log file, and no bug details either. Does this happen with VirtualBox OSE, or with the binary packages from virtualbox.org?

comment:6 Changed 4 years ago by mike.merrett@…

I have no files to attach - the system in question was at a customer premises [as stated above] with barely any access to their systems. However I can state that the version was binary VirtualBox downloaded from the standard distribution for Mandriva 2008.1/ x86

One day I'm going to try the same setup myself when time allows.

Changed 4 years ago by style

My log about this bug

Changed 4 years ago by style

Server log, Win 7 Home.log is the log of the client

comment:7 follow-up: ↓ 8 Changed 4 years ago by michaln

The logs aren't really all that helpful. What were the exact error messages? Was there any useful information in TFTP server logs? Does the error occur with both E1000 and PCnet NICs? Does using internal networking (instead of bridged) make any difference?

For the client VM, please try running 'VBoxManage modifyvm YourVM --biospxedebug on' to enable more logging and attach the resulting log from a failed run. If possible, also supply packet traces showing the failure. See  http://www.virtualbox.org/wiki/Network_tips

comment:8 in reply to: ↑ 7 Changed 4 years ago by style

Thanks you MichalN now it works! Solution: On the server: Intel pro/1000 (Défault card) On the client: PCnet-Fast III

And now, no problem with the Boot.sdi file!

comment:9 Changed 4 years ago by travbrack

Same thing happens to me

When I try to boot the client with any of the four Intel drivers, it starts the tftp download, bu the progress bar stays at 0 percent. Eventually it does start downloading at a rate of about 1 bar per minute, I don't have the patience to wait 2 hours to see if it fails or not. It boots great using the pcnet III driver, but no 64 bit driver exists so it would be nice to use the Intel.

*VirtualBox 3.1.6 r59338

*Host: Windows 7 64 bit

*Guest PXE server: Windows Server 2008 w/ WDS

*Guest PXE client: Windows PE 3.0

As a workaround, I'll probably boot the PE using 32 bit pcnet III for the OS install and then switch to Intel afterward. Relevant log attached.

Changed 4 years ago by travbrack

Travbrack log file

comment:10 Changed 3 years ago by aleksey

PXE boot problem with WDS was fixed in VBox 4.0.2. Can you try it?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use