VirtualBox

Ticket #3256 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

"dead keys" do not work any more -> fixed in SVN

Reported by: jkeil Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.2 Keywords: keyboard x11
Cc: Guest type: Solaris
Host type: Solaris

Description

On a SX:CE build 104 host, running VirtualBox 2.1.2, german layout usb keyboard: The accent key ( ' and ` -- to the left of the backspace key) does not work.

This key is sometimes quite important for Solaris' grub, which does not use localized keyboard keymaps and assumes an us-english keymap: on an us-english keyboard the ' / ` key corresponds to the = / + key. I can't edit the grub boot command line and add an option like "-B key=value" because there's no way to type the "=" key.

Other users have reported similar issues with Spanish and Swedish keyboard layouts:  http://forums.virtualbox.org/viewtopic.php?t=13995

Attachments

OpenSolaris 2008.11-2009-02-02-12-36-30.log Download (31.4 KB) - added by jkeil 5 years ago.
VBox.log

Change History

Changed 5 years ago by jkeil

VBox.log

comment:1 Changed 5 years ago by michael

If you switch to a US keyboard layout before starting the guest does the key work?

comment:2 Changed 5 years ago by michael

Don't bother checking, I can reproduce this myself.

comment:3 Changed 5 years ago by michael

  • Summary changed from "dead keys" do not work any more to "dead keys" do not work any more -> fixed in SVN

Fixed in SVN.

comment:4 Changed 5 years ago by jkeil

Yes, temporary switching to US keyboard layout is a workaround:

/usr/X11/bin/setxkbmap -layout us

comment:5 Changed 5 years ago by michael

jkeil: if you use this workaround then you can switch back to German layout as soon as the VM is running. VirtualBox only probes the keyboard layout during VM startup to work out which X11 keycodes correspond to which keyboard keys.

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use