VirtualBox

Ticket #3210 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

xp guest aborted

Reported by: lavin Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords: XP aborted crash
Cc: Guest type: Windows
Host type: Linux

Description

Xp guest aborted on linux ubuntu 8.10 Host, after having working correctly a certain amount (variable) amount of time, please find log joined.

Attachments

xp janvier 09-2009-01-28-13-16-43.log Download (34.7 KB) - added by lavin 5 years ago.
53.log Download (35.9 KB) - added by jpbrown 5 years ago.
jpbrown-vbox-2009-01-28-19-54.log Download (35.7 KB) - added by jpbrown 5 years ago.
vbox.log Download (47.4 KB) - added by guoguy 5 years ago.
vbox.log.2009-01-31-08-52-match.core.12926.log Download (35.9 KB) - added by jpbrown 5 years ago.
vbox.log.2009-01-31-09-03-match.core.13671.log Download (35.8 KB) - added by jpbrown 5 years ago.

Change History

Changed 5 years ago by lavin

Changed 5 years ago by jpbrown

Changed 5 years ago by jpbrown

comment:1 Changed 5 years ago by jpbrown

Added 2 additional logs 53.log and jpbrown-vbox-2009-01-28-19-54.log. Similar symptoms as described. Windows XP SP 3 guest aborts unexpectedly during boot. Same as with VB 2.1.0. VB 2.0.6 boots correctly. Uninstalled and reinstalled VB 2.1.0 and 2.1.2 multiple times. Reverting to 2.0.6 is the only way I can boot the image. No system errors reported in other logs. Attempted disabling Shared Folder with no effect either.

Host: Linux sparky 2.6.27-11-generic #1 SMP Fri Jan 23 13:58:13 UTC 2009 x86_64 GNU/Linux

Changed 5 years ago by guoguy

comment:2 Changed 5 years ago by guoguy

I also have experienced the similar problem for several times, and all occured in winxp sp3, from 2.0.6 to the current 2.1.2, in my memory. I attach the most recent vbox log, it should be useful since it's different from the previous logs of this ticket, suggesting different cause. My host os is debian lenny.

comment:3 Changed 5 years ago by frank

guoguy, your problem is different and seems to be related to the clipboard. Please could you open a separate ticket and attach your log file there? Thank you!

jpbrown, you VM seems to SEGFAULT. Please could you provide us a  core dump? Please contact me at frank _dot_ mehnert _at_ sun _dot_ com if you need some space to upload the core dump.

Changed 5 years ago by jpbrown

Changed 5 years ago by jpbrown

comment:4 Changed 5 years ago by jpbrown

Added 2 logs vbox.log.2009-01-31-08-52-match.core.12926.log and vbox.log.2009-01-31-09-03-match.core.13671.log. Core dumps associated with each of these will be uploaded when space is available (each core dump is around 110 MB).

Core.12926 was taken with the initial invocation of VB 2.1.2 after an install: 1) sudo dpkg -r virtualbox-2.0 2) sudo dpkg -i virtualbox-2.1_2.1.2-41885_Ubuntu_intrepid_amd64.deb 3) followed the settings for taking a core dump  http://www.virtualbox.org/wiki/Core_dump 4) used /usr/lib/virtualbox/VirtualBox -startvm VM_NAME to launch the vm 5) responded OK to the convert the xml files from 2.0.6 to 2.1.2 format

Core.13671 was taken several minutes after the first core dump using step 4 from above to launch the vm.

Host kernel: Linux sparky 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

Guest: Windows XP Professional Version 2002 SP3 patched current as of 1/30/2009.

comment:5 Changed 5 years ago by lavin

hello, I'm not sure problem reported by jpbrown is the same i reported at the beginning, in my case XP aborts never occured during boot but some times later.

just after rebuilding XP guest i could worked 10 or 15 minutes before crash, now it's 1 or 2 minutes only before crash !

comment:6 Changed 5 years ago by jpbrown

lavin, I tend to agree with you that my problem seemed to occur much earlier than yours -- just happened to result in the same aborted state.

I've since tried to upgrade to 2.14 and I have been successful booting the XP guest multiple times and it has been running stable for me for a day. So, I think the cause of my aborts were solved with 2.14. Have you given that version a try?

comment:7 Changed 5 years ago by lavin

To : JP Brown

hello, for the moment as i could not worked with virtualbox i come back to a dual boot solution (xp and ubuntu) so i dont try next update of virtualbox, i'm satisfied for you you could run xp with 2.14 upgrade, may be i'll tried later. Thanks

comment:8 Changed 5 years ago by excel28

Not sure if this will help anybody else, but I had the same issue. I fixed it by unblocking port 123 (NTP) on my host firewall.

comment:9 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use