VirtualBox

Ticket #3202 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Remount recently unmounted media does not mount it => Fixed in SVN

Reported by: Sasquatch Owned by:
Priority: critical Component: DVD
Version: VirtualBox 2.1.2 Keywords: remount ISO, unable to release
Cc: Guest type: other
Host type: other

Description

If you unmount an ISO from the Guest, you can't mount it again for a while. You usually have to shutdown the VM before the actual ISO is in released state, or wait a long time (an hour or more). When selecting an ISO image from the Media Manager, it will show it's state as 'attached', while the Disc Icon in the VB GUI doesn't reflect this. If a different ISO is mounted, it works, but then both ISOs are shown as mounted and as soon as the second ISO is unmounted, it too cannot be mounted again.

A probably related issue is when installing an OS (tested with Linux) that 'ejects' it's media after installation, you can't boot from it again until you shutdown the VM.

Change History

comment:1 Changed 5 years ago by frank

Which host is that? Can you provide a VBox.log file of such a session when mounting an ISO didn't work? We cannot reproduce the problem.

comment:2 Changed 5 years ago by Sasquatch

This is with Xubuntu 8.10. I didn't see anything relevant in the logs. Will check to make sure. It happens on both my PC and laptop, though they share the same VMs and settings.

comment:3 Changed 5 years ago by Sasquatch

After the VM has run, you can't release the already released ISO. You get the message if you really want to detatch <file> from <machine>. After hitting OK, it's still marked as attached to the machine. All ISO images do this, but just tested it again with the GA. There is no mentioning in the log files of an attachment of the ISO, nor detaching it.

Even after closing all VB related processes. There is no mentioning of the ISO being mounted anywhere. After a few minutes, the ISO is released, if the VM is no longer running. I don't know exactly how long it takes if the VM keeps running.

comment:4 Changed 5 years ago by tbeadle

I have seen this on VB 2.1.4 with a Linux host, Windows XP guest using VBoxManage:

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach ~/atf-scripts/sandbox/windows/sandbox.iso VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[vboxuser ~/atf-scripts/sandbox/windows]$

I then used the ISO from the guest. and then: [vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach none VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[vboxuser ~/atf-scripts/sandbox/windows]$

I modified the iso image using mkisofs, then

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach ~/ atf-scripts/sandbox/windows/sandbox.iso VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: true , basic error info present: true [!] Result Code = VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) - Object corresponding to

the supplied arguments does not exist

[!] Text = Could not find a CD/DVD image with location 'sandbox.iso' in t he media registry ('/home/vboxuser/.VirtualBox/VirtualBox.xml') [!] Component = VirtualBox, Interface: IVirtualBox, {339abca2-f47a-4302-87f5-7 bc324e6bbde} [!] Callee = IDVDDrive, {d650ef30-be9b-4dae-b463-11d5824681a5}

which is weird because I provided the full path to the ISO, which is what's contained in the xml file, but the error message only contains the basename of 'sandbox.iso'.

Further attempts give different errors:

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach ~/atf-scripts/sandbox/windows/sandbox.iso VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: true , basic error info present: true [!] Result Code = VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) - Object corresponding to the supplied arguments does not exist [!] Text = Could not find a CD/DVD image with UUID {00000000-0000-0000-0000-000000000000} in the media registry ('/home/vboxuser/.VirtualBox/VirtualBox.xml') [!] Component = VirtualBox, Interface: IVirtualBox, {339abca2-f47a-4302-87f5-7bc324e6bbde} [!] Callee = IDVDDrive, {d650ef30-be9b-4dae-b463-11d5824681a5}

Note that the UUID is all 0's.

[vboxuser ~/atf-scripts/sandbox/windows]$ grep sandbox.iso /home/vboxuser/.VirtualBox/VirtualBox.xml

<Image uuid="{c5fb2f85-150f-4b71-8718-77d2992aef74}" location="/home/vboxuser/atf-scripts/sandbox/windows/sandbox.iso"/>

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach /home/vboxuser/atf-scripts/sandbox/windows/sandbox.iso VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: false, basic error info present: false [vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach none VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach /home/vboxuser/atf-scripts/sandbox/windows/sandbox.iso VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: true , basic error info present: true [!] Result Code = VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) - Object corresponding to the supplied arguments does not exist [!] Text = Could not find a CD/DVD image with UUID {00000000-0000-0000-0000-000000000000} in the media registry ('/home/vboxuser/.VirtualBox/VirtualBox.xml') [!] Component = VirtualBox, Interface: IVirtualBox, {339abca2-f47a-4302-87f5-7bc324e6bbde} [!] Callee = IDVDDrive, {d650ef30-be9b-4dae-b463-11d5824681a5}

So here I try using the UUID of the iso directly:

[vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach c5fb2f85-150f-4b71-8718-77d2992aef74 VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: true , basic error info present: true [!] Result Code = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Text = This machine does not have any snapshots [!] Component = Machine, Interface: IMachine, {ea6fb7ea-1993-4642-b113-f29eb39e0df0} [!] Callee = IDVDDrive, {d650ef30-be9b-4dae-b463-11d5824681a5} [vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage snapshot jla0 take 'before_installing_shortcuts' VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100% [vboxuser ~/atf-scripts/sandbox/windows]$ VBoxManage controlvm jla0 dvdattach c5fb2f85-150f-4b71-8718-77d2992aef74 VirtualBox Command Line Management Interface Version 2.1.4 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

[!] FAILED calling dvdDrive->MountImage(uuid) at line 3129! [!] Primary RC = NS_ERROR_FAILURE (0x80004005) - Operation failed [!] Full error info present: false, basic error info present: false

comment:5 follow-up: ↓ 6 Changed 5 years ago by attoparsec

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Remount recently unmounted media does not mount it to Remount recently unmounted media does not mount it => Fixed in SVN

A fix related to mounting/unmounting was committed to SVN which very much looks like it could fix this report. Please reopen if necessary.

comment:6 in reply to: ↑ 5 Changed 5 years ago by tbeadle

Replying to attoparsec:

A fix related to mounting/unmounting was committed to SVN which very much looks like it could fix this report. Please reopen if necessary.

How long ago was this fix put in? Is it included in 2.2.0?

comment:7 Changed 5 years ago by attoparsec

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopen as long as a version with this fix is not officially released (simply to handle this report like we handle all others).

comment:8 Changed 5 years ago by attoparsec

This fix was put in just today and is expected to be in 2.2.

comment:9 follow-up: ↓ 10 Changed 5 years ago by attoparsec

FYI, it should be fixed with r18210 and later of the OSE. In case you want to compile it, we'd be interested in your feedback.

comment:10 in reply to: ↑ 9 Changed 5 years ago by tbeadle

Replying to attoparsec:

FYI, it should be fixed with r18210 and later of the OSE. In case you want to compile it, we'd be interested in your feedback.

Unfortunately, the server that I'm running VBox on runs in headless mode without X even installed, so I rely on the RDP functionality that is not present in the OSE edition.

comment:11 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use