VirtualBox

Ticket #3190 (new defect)

Opened 5 years ago

Last modified 3 years ago

Wrong keyboard layout when I VNC into the host from another machine

Reported by: markusl Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords: uk keyboard vnc
Cc: Guest type: Linux
Host type: Linux

Description

Tongs is a Debian Lenny machine with a UK keyboard. If I sit at tongs and run VMs, the keyboard layout is recognised correctly.

Tongs runs vnc4server. Edward is an Ubuntu machine with a UK keyboard, running xvnc4viewer. If I VNC from edward into tongs and run a VM, the keyboard layout is not recognised correctly: for example, '@' and '"' swap places. VBox.log says:

00:00:00.461 Your keyboard type does not appear to be known to VirtualBox. If 00:00:00.461 you would like to help us improve the product, please submit a bug 00:00:00.461 report, attach this logfile and provide information about what type 00:00:00.461 of keyboard you have and whether you are using a remote X server or 00:00:00.461 something similar.

This problem occurs with both Linux and Windows guests.

Attachments

VBox.log Download (40.7 KB) - added by markusl 5 years ago.

Change History

Changed 5 years ago by markusl

comment:1 Changed 5 years ago by michael

In order to fix this I would have to know which keys are wrong and what you get when you press them (I assume there are others besides the two you mentioned). Would you be able to add that information to the ticket? Thanks.

comment:2 Changed 5 years ago by markusl

Here are two columns of data. When I press the key on the left, I see the symbol on the right. In three cases, a key does nothing.

¬ =>

| =>

" => @

£ =>

# => £

~ => ¬

\ => #

| => ~

@ => "

The first | in this list is the key at the top-left key on the main keypad, combined with Alt+Gr; the second | is the key to the left of Z, combined with Shift.

comment:3 Changed 3 years ago by feathersanddown

Same issue here, keyboard spanish in a vbox with Windows Server 2003, changing keyboards settings to English match some keys, but into Host machine it mess up everything. In native host machine all keys works perfectly, inside the VM directly from the host keeps OK, but with a VNC connection the keyboard change.

I autoload the current desktop with:

x11vnc -rfbauth ~/.vnc/passwd -bg -shared -forever

then over this vnc connection run the VM Windows Server 2003.

host: opensuse 11.3, KDE 4.4 dual core 2GB ram

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use