VirtualBox

Ticket #3172 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Performance regression (2.1.2 vs previous) -> fixed in SVN/2.1.4

Reported by: sandervl73 Owned by:
Priority: critical Component: other
Version: VirtualBox 2.1.2 Keywords: performance decrease
Cc: Guest type: other
Host type: other

Description

Ticket opened for others to comment on. ( http://forums.virtualbox.org/viewtopic.php?t=13640)

Attachments

XPSP3 IE8-2009-01-26-10-00-12.log Download (42.1 KB) - added by ripla 5 years ago.
Logfile from a run where the problem occured
20090128aVBoxLogs.zip Download (41.4 KB) - added by FWNet 5 years ago.
Ziped Log files. .3=good session from v2.1.0. Other logs are subsequent sessions using v2.1.2.
V210212.zip Download (22.7 KB) - added by FWNet 5 years ago.
Zip file of two folders- xml and log files from v210 and after upgrade to v212.
VBox.log Download (44.6 KB) - added by marcox 5 years ago.
VB212 log file of a VM showing heavy perf.decrease
VBox.2.log Download (34.7 KB) - added by G. I. 5 years ago.
VBox log

Change History

comment:1 Changed 5 years ago by sandervl73

  • Keywords performance decrease added

Changed 5 years ago by ripla

Logfile from a run where the problem occured

comment:2 Changed 5 years ago by sandervl73

Does it make any difference if you use host interface networking instead of NAT? (change the network settings of the VM)

comment:3 Changed 5 years ago by Chrissss

I can confirm this issue. The performance dropped also under 2.1.2 under Ubuntu Intrepid Ibex as Host... I run

  • Windows XP Sp2 with Host-Interface
  • Ubuntu Intrepid Ibex 32-bit with Host-Interface
  • Ubuntu Intrepid Ibex 64-bit with Host-Interface
  • OpenSUSE 11.2 with NAT
  • Fedora10 with NAT

as virtual machines. Installing a new VM is pretty much impossible. When you run Fedora10 as "Live-CD" inside a VBox everything is very slow and sluggish...

comment:4 Changed 5 years ago by pacp

I can also confirm this. Using host interface networking instead of NAT in my case helps a little bit, but performance is still waaaaay worse that with 2.1.0 (which I downgraded to!). Enabling / disabling OpenGL makes no difference, and neither does adding RAM to the virtual machine. Host Ubuntu Intrepid 32-bit, problem occurs in a Windows XP SP2 guest (using host networking and SATA controller).

comment:5 Changed 5 years ago by sandervl73

  • Host type changed from Mac OS X to other
  • Summary changed from Performance regression (2.1.2/Mac OS X) to Performance regression (2.1.2 vs previous)

Attach the VBox.log from such a session please.

comment:6 Changed 5 years ago by sandervl73

  • Priority changed from major to critical

comment:7 Changed 5 years ago by ripla

I don't have a good testcase for this problem, but it seemed that changing to host interface networking made the problem worse. I'm not sure about that, but it is certain that changing didn't help.

Changed 5 years ago by FWNet

Ziped Log files. .3=good session from v2.1.0. Other logs are subsequent sessions using v2.1.2.

comment:8 Changed 5 years ago by FWNet

Confirmimg the problem on an XP system. I have sent log files before and after upgrading v2.1.0 to 2.1.2

Host= XP Home, 4GbMem Guest = XP Pro, Host-Interface and Internal Networking

comment:9 follow-up: ↓ 10 Changed 5 years ago by sandervl73

FWNet: could you describe your problem in more details? 100% CPU load after bootup, slowdown only after a while?

comment:10 in reply to: ↑ 9 Changed 5 years ago by FWNet

Replying to sandervl73:

FWNet: could you describe your problem in more details? 100% CPU load after bootup, slowdown only after a while?

Bootup is slower than usual, starting a program is slower than usual - when a program starts, the task bar display takes several seconds, I can see the individual letters of the window title being formed. Any video display is slower than usual. CPU usage gets to 100% often, very unusual. One program I use that requires substantial graphic work runs at 100% constantly, even when no other programs are running.

comment:11 Changed 5 years ago by G. I.

Just moving the mouse around in the XP SP2 guest pushes the virtual CPU to 20-80% depending on what is the foreground application. E.g. mousing on empty desktop: 20%, Adobe Fireworks: 70-80%. Unusable.

comment:12 Changed 5 years ago by frank

Please all: Append a VBox.log file of such a VBox 2.1.2 session which appears slower to you than with VBox 2.1.0. We are still trying to reproduce this problem and need some information about the host hardware and the guest. The VBox.log file contains some of these information.

Changed 5 years ago by FWNet

Zip file of two folders- xml and log files from v210 and after upgrade to v212.

comment:13 Changed 5 years ago by FWNet

The attachment files in V210212 were created as follows: Restored XP Home SP2 to a C: drive, copied in a .vdi file containing XP Pro SP2 with firefox installed.

Installed VB 210 and created a VM. When running the VM idle, no programs manually started, taskmanager showed a cpu performance of < 15% with spikes up to 25%.

Then upgraded to v212. Taskmanager then showed cpu performance of 40-60% with spikes up to 70%.

The attached files are the xml and log files from each run.

Let me know if you can use more info, these tests are easy to recreate.

Changed 5 years ago by marcox

VB212 log file of a VM showing heavy perf.decrease

comment:14 Changed 5 years ago by frank

Does it make any difference if the guest additions are installed? For checking this, please uninstall the guest additions and reboot the guest.

comment:15 Changed 5 years ago by marcox

I had already thought that the problem could lie in the GA themselves. I tried removing completely 212 Guest Additions and rebooting, but the problem was still there. I tried also reverting to 210 Guest Additions (with VB 212), as you can see in the VBox.log file I attached yesterday, but this did not work either.

comment:16 Changed 5 years ago by sandervl73

Those that want to try an internal test build that contains at least one Windows guest performance fix, should say so here.

comment:17 Changed 5 years ago by FWNet

I tried the internal test build, and its GA, as mentioned in note 2009-02-06 17:03:21 on my test drive described in note 2009-02-03 04:42:09 and observed performance similar to that of v210 on the same test drive. Can anyone else confirm that this build appears to solve the problem?

Changed 5 years ago by G. I.

VBox log

comment:18 Changed 5 years ago by de_niska

Let me try the internal test build, please! I have WIN_XP_SP2 as guest and OpenSuse 11.0 as host. I have initially installed version 2.1.2 and was "surprised" with performance. Having read about such an effect after upgrading from 2.1.0, I downgraded to it (purging uncompatible *.xml configs) and everything became fast and responsive!

comment:19 Changed 5 years ago by wolcano

I too volunteer for testrun with internal test build. I am running Debian/Lenny, 2.6.24-1-686.

comment:20 Changed 5 years ago by sandervl73

  • Summary changed from Performance regression (2.1.2 vs previous) to Performance regression (2.1.2 vs previous) -> fixed in SVN/2.1.4

I don't need any more testers for this regression. Please wait for 2.1.4 (due out soon). Thanks to all of you that provided feedback!

comment:21 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please try 2.1.4.

comment:22 Changed 5 years ago by jeffhoff

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am running 2.1.4 OpenSolaris 64 bit Host with both an XP 32 bit Guest and Fedora 10 64 bit Guest.

This problem still exists. I have tried it with and without VBox additions. I have killed the Vboxclient but still is slow.

You can really see it if you login two users onto the Fedora10 Guest Partition.

Happy to get you more info, just let me know what and how to obtain it.

comment:23 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

This ticket applies to Windows guests only and everybody has confirmed the problem has been fixed. I suggest you create a separate ticket and specify more information (VBox.log for starters).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use