VirtualBox

Ticket #3164 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Regression: main window position shift on each VB startup

Reported by: zooloo Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

Whenever I run VB 2.1.2, the main control window is shifted down by 70 pixels.

Suppose the coordinates were (x_pos, y_pos, x_len, y_len) when VB was closed. The next time VB is run, the window will be at (x_pos, y_pos+70, x_len, y_len).

As a test, I performed 10 subsequent start-quit cycles without manually moving the window around. It ended up being mostly sunk below the bottom, so I had to stop the test to avoid it going totally off-screen and thereby becoming inaccessible.

In the first run after I upgraded from 2.0.6 to 2.1.2, I observed a glitch that might be related: VB's main window was positioned at (0,0) rather than (0,44), with its handle being hidden behind the menu bar. Due to the missing handle, this looked as if the GUI switched to full-screen. I got it back to normal by hiding and then un-hiding VB.

Change History

comment:1 Changed 5 years ago by heavy

I am noticing this behavior on my Mac with version 2.2.2 as well.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There was a fix VirtualBox 3.0.0 which should solve that issue. Please reopen if this problem still appears with version 3.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use