VirtualBox

Ticket #3157 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

WinVista Network drive fails reconnecting

Reported by: harald_nuernberg Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

This might be the same problem as already mentioned in tickets #22 and #376. There it is mentioned as fixed.

I observed it with the following system: Machine: Mac Mini Intel Core2Duo 1,83; Host: Mac OS X Leopard; Guest: Windows Vista x64 SP1; Virtualbox Version 2.1.2;

I connected a drive to virtualbox shared folders. When I open it in Windows explorer, the drive symbol is shown with a red cross. But when I select the drive I can browse in the folder structure without any problems. Also programs can be started.

I recently installed a old setup program "called Wise". I opened there the file choose dialog in this program and try to select the drive. However, I got the following error message: An error occured while reconnecting S: to \vboxsvr\development. Virtualbox Shared Folders: The request is not supported. This connection has not been supported. Seems that the old file choose dialog has a problem with mapped drives. Also, in the MS explorer, it shows the red cross (Not okay), but I am able to browse???

Change History

comment:1 Changed 5 years ago by harald_nuernberg

Also there are the following problems: When I open the properties dialog of a shared folder in the Windows Explorer on the guest, it shows that all files are READ-Only. The Attribute Read-Only (Only applies to files in folders) is set (Not okay). I tried to remove this flag in the properties dialog. It seems to be applied, but when I re-opened the dialog, the flag is still set????

Might this a problem with file access rights on the host Mac OS X???

But even if the read only flag is set, I can manipulate and write files??

Also, I observed the following problem with Netbeans and Ant script: The mkdir task fails with unknown reason??? Might be because of the read only flag???

comment:2 Changed 5 years ago by harald_nuernberg

Read only attribute problem is also described in ticket #2592.

comment:3 Changed 5 years ago by harald_nuernberg

Also, I cannot start an executable from shared folder on Windows Vista x64. Vista returns with error.

Installed Version of GuestAdditions: 2.1.0.r41146

comment:4 Changed 5 years ago by sandervl73

Install the 2.1.2 guest additions first.

comment:5 Changed 5 years ago by harald_nuernberg

I installed guest additions 2.1.2r41885. Still reproducible. Win Explorer shows red cross (NOK), but files are accessible. Also, the Read only flag is set for shared folders (NOK).

Best regards Harald

comment:6 Changed 5 years ago by harald_nuernberg

I installed Windows XP 32 bit as guest on the same machine. With XP, the network drive is okay. I cannot observe the mentioned problems on XP. So seems to be only a problem of Vista x64 and the guest additions.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 2.1.4.

comment:8 Changed 5 years ago by harald_nuernberg

  • Status changed from closed to reopened
  • Resolution fixed deleted

Retested in 2.1.4. Still there.

The problem can be observed with Windows Vista x64, but not with Windows XP 32bit.

In Windows Vista x64, I use a freeware filebrowser called Idoswin free. This filebrowser shows still the red cross symbol.

But I now use a network connection via host interface. Via host interface it works for me.

comment:9 Changed 5 years ago by harald_nuernberg

This is the problematic progam - beside other problems:  http://www.idoswin.de/idosfree.htm.

Also, try to use shared folder on Win Vista x64 as project folder and user directory with Netbeans 6.5.

comment:10 Changed 5 years ago by igorgatis

As for ant problem, you might want to check issue  http://www.virtualbox.org/ticket/1870

comment:11 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use