VirtualBox

Ticket #3127 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Guru meditation (pgmPoolTrackPhysExtDerefGCPhys) on shutdown after Vbox 2.1.2 upgrade -> retry with 2.2.2

Reported by: MrViklund Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hello VirtualBOX team!

After upgrading my VirtualBOX 2.1.0 installation to 2.1.2 today, one of my virtual machines are crashing on shutdown. I haven't tested my other machines yet because I'm filing this "Bug report". The VM was Zenwalk Linux 32 bit running on a Windows Vista Sp1 32bit host.

The log can be found here.  http://pastebin.com/f740a8ff5

VirtualBOX told me to file a bug report so I thought that I could do that favour. I'm not a computer guru so I don't know if more information is required. Just ask.

Attachments

VBox.log Download (56.0 KB) - added by MrViklund 5 years ago.
The Vm's log file
VBox.2.log Download (42.6 KB) - added by MrViklund 5 years ago.
Second Log File
VBox3.log Download (122.2 KB) - added by MrViklund 5 years ago.
Log 3
Guru_screenshot.2.jpg Download (56.2 KB) - added by Maximilian 5 years ago.
Screenshot of the Guru Meditation window
Zenwalk Linux-2009-02-12-16-50-28.log Download (200.7 KB) - added by Maximilian 5 years ago.
Zenwalk Linux-2009-02-12-18-01-46.log Download (198.2 KB) - added by Maximilian 5 years ago.
Guru_screenshot.jpg Download (186.6 KB) - added by Maximilian 5 years ago.
Guru_screenshot2.jpg Download (186.6 KB) - added by Maximilian 5 years ago.
New Installation VBox.log Download (102.7 KB) - added by MrViklund 5 years ago.
New Installation VBox

Change History

comment:1 Changed 5 years ago by frank

  • Summary changed from Virtual machine crash on shutdown after Vbox 2.1.2 upgrade to Guru meditation (pgmPoolTrackPhysExtDerefGCPhys) on shutdown after Vbox 2.1.2 upgrade

Thanks for this report. Please could you attach the log file to this defect (use the attach button because the file might vanish from pastebin ...

Changed 5 years ago by MrViklund

The Vm's log file

comment:2 Changed 5 years ago by MrViklund

The log file is now attached. I didn't bother to upload the screen shot since it was just a block screen.

comment:3 Changed 5 years ago by sandervl73

Can you reproduce this easily? If so, would you be willing to try out a test build?

comment:4 Changed 5 years ago by MrViklund

It's easily reproduced in the sense that I can power on the machine, and every time I turn it off I get the same error. As I wrote above. This error was created when I upgraded the VirtualBOX installation from 2.1.0 to 2.1.2. If that was what you were looking for, yes, I'm willing to try out a test build.

comment:5 Changed 5 years ago by MrViklund

I have been testing the "VirtualBox-2009-02-03-17-11-41-w32-2.1-2.1.3-r42395.msi" version and sadly I have to report that it does not solve the problem. However. I observed something that I have not noticed before. If I shut down the Virtual Machine instantaneously after boot up. The Virtual Machine shuts down correctly. The XFCE Window Manager will briefly display a pop up warning that the session lasted shorter then 10 seconds... Probably thinking the immediate shutdown is an error. If I instead wait for about 10-15 seconds to shut it down. The same error appears again.

Changed 5 years ago by MrViklund

Second Log File

comment:6 Changed 5 years ago by MrViklund

I attached the new log file from the new build.

comment:7 Changed 5 years ago by sandervl73

I don't see the guru meditation in your latest log.

comment:8 Changed 5 years ago by MrViklund

I have to emphasize that I'm not a computer expert. With the 2.1.2 installation, I got the same error every time on shut down. With this test version, it seems to be more random. Just now I started and shut down the server 4 times. The first time, the Vbox instance crashed and the Vista error solving and reporting tool came up. The second and third time, the shut down worked perfectly fine. No error at all. The fourth time, I got the same good old error again. I will submit the log as number 3. Mind explaining also what Guru meditation is? It's present in this log.

Changed 5 years ago by MrViklund

Log 3

Changed 5 years ago by Maximilian

Screenshot of the Guru Meditation window

Changed 5 years ago by Maximilian

Changed 5 years ago by Maximilian

comment:9 Changed 5 years ago by Maximilian

Hello,

I have exactly the same problem as MrViklund. I have just upgraded to VirtualBox 2.1.2 on my two computers running Windows XP Pro SP3 and Windows Vista Home Premium SP1, respectively. Both have Zenwalk Linux 5.2 installed as guests. After the VirtualBox upgrade (one of them over the previous VirtualBox version, the other one after uninstalling the previous version), Zenwalk Linux guest crashes during shutdown, and the VirtualBox displays a Guru Mediation window (see attached screenshot). I am also attaching two VirtualBox logs. Thanks a lot for your help, and I hope you find a solution to this problem.

comment:10 Changed 5 years ago by Maximilian

I am sorry, I attached the same screenshot twice accidentally.

Changed 5 years ago by Maximilian

Changed 5 years ago by Maximilian

comment:11 Changed 5 years ago by MrViklund

Well it seems like they have given up on me and I don't see anything in the 2.1.4 that would suggest that is has been fixed. I will however install it and try it to see if it works. I can't do anything more then reporting the bug. If they don't want, or can, or know how to fix it, i can not do anything about :) Anyway. I hope it will be solved sometime.

comment:12 Changed 5 years ago by Maximilian

I think this bug is tied to Zenwalk, because my other virtual machine shuts down fine, even after the VirtualBox upgrade. I was going to try another distribution of Linux as guest, maybe Wolvix this time. I have not worked with it before, but it is also Salckware-based and has xfce ;). Good luck!

comment:13 Changed 5 years ago by MrViklund

Well. I do wonder about that. I don't think so. Zenwalk ran fine before I upgraded to 2.1.2 so something in VirtualBOX changed. I guess. I have installed the new version 2.1.4 and the error is still there. The error is random now. I don't get it very time. But it's still there. I will make a clean install of Zenwalk later to see if the error was creating due to the upgrade. I will report back later.

comment:14 Changed 5 years ago by Maximilian

I'm sorry, I did not mean that Zenwalk itself has a bug, but rather that the upgraded VirtualBox somehow does not fully accommodate Zenwalk. I think that this problem should not be too hard to fix for the VirtualBox team if they just install a copy of Zenwalk on their software and do some debugging. Maybe they think that there are not enough Zenwalk users to warrant a specific remedy for this? Anyway, good luck with the reinstall.

comment:15 Changed 5 years ago by sandervl73

I've tried to install it and failed to reproduce the problem here. If either of you want to try a VirtualBox debug build, then I can upload one. That's more or less the only way to track down the bug.

comment:16 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.1.2 to VirtualBox 2.1.4

comment:17 Changed 5 years ago by Maximilian

My problem has been solved, in the following way. I transferred my Zenwalk documents to a shared folder on the host OS, deleted the Zenwalk virtual machine, uninstalled VirtualBox 2.1.2, installed VirtualBox 2.1.4, reinstalled Zenwalk 5.2, and everything works great, no more Zenwalk shutdown crashes. One thing I was wondering about, in my previous Zenwalk I had used "netpkg, update everything" just before the Guru Meditation started appearing. Could this have messed it up? Another question is to sandervl73, what does the VirtualBox debug build do? Is it interesting? If it is, I would very much like to have a copy of it posted here. All the best.

comment:18 Changed 5 years ago by MrViklund

Are you sure the problem is gone? I just reinstalled Zenwalk Linux and set the following preferences as I always do. 32MB Graphics Memory, 3D Acceleration enabled, Enabeling VT-x/AMD-V, Activating Windows Direct Sound. I will try to uninstall the whole VirtualBOX installation, remove all Virtual Machines and install 2.1.4 and try it again. because this this, I got the error right at start up of my new Zenwalk Installation. I uploaded the Log.

comment:19 Changed 5 years ago by MrViklund

Uploading the log as "New Installation VBox"

Changed 5 years ago by MrViklund

New Installation VBox

comment:20 Changed 5 years ago by sandervl73

MrViklund: try turning on nested paging in the advanced settings tab of your VM. That should at least work around the issue.

comment:21 Changed 5 years ago by MrViklund

Thanks. I will try that.

comment:22 Changed 5 years ago by MrViklund

Ok. Here are my findings. I removed everything starting clean with 2.1.4. I installed Zenwalk Linux 5.2 and was able to start and shut it down successfully in a round of 4 attempts. Starting with VT-x/AMD-V OFF. After that initial successful run I enabled VT-x/AMD-V, but not Nested Paging. And the machine failed to shut down properly on the first test run. After that I enabled Nested Paging and successfully did a 4 round testing again. The thing here is that I don't have Nested Paging enabled in any other of my virtual machines. Only VT-x/AMD-V. And only Zenealk is giving me problems. So if it's something in Zenwalk, or VirtualBOX I have no idea.

I wonder one thing though. And I tried to read up about thing in the Manual but I don't quite get it. What's really the difference between having only VT-x/AMD-V on or VT-x/AMD-V and Nested Paging. When I read the description of it, it seems to me to be the exact same thing?

comment:23 Changed 5 years ago by sandervl73

  • Summary changed from Guru meditation (pgmPoolTrackPhysExtDerefGCPhys) on shutdown after Vbox 2.1.2 upgrade to Guru meditation (pgmPoolTrackPhysExtDerefGCPhys) on shutdown after Vbox 2.1.2 upgrade -> retry with 2.2.2

Nested paging accelerates guest paging. It's an extra feature of VT-x and AMD-V.

Please try 2.2.2. The paging code has undergone a big rewrite.

comment:24 Changed 5 years ago by MrViklund

Thanks for the info. I will sure try 2.2.2. And I really hope that VirtualBOX goes unaffected by the acquisition.

comment:25 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Closing as we believe the problem was fixed some time ago. See #3124.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use