VirtualBox

Ticket #3106 (closed defect: worksforme)

Opened 5 years ago

Last modified 15 months ago

VRDP login: external authentification mode on MacOS X host failed, VRDPAuth.dylib not found -> fixed in SVN

Reported by: lars_ Owned by:
Priority: major Component: RDP
Version: VirtualBox 3.1.2 Keywords: VRDPAuth.dylib
Cc: 2.1.0 Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

Logs:

00:02:06.339 VRDP: Client seems to be rdesktop.
00:02:06.339 VRDP: Logon: debian (192.168.1.57) build 2600. User: [vbremote] Domain: [] Screen: 0
00:02:06.340 VRDPAUTH: User: [vbremote]. Domain: []. Authentication type: [External]
00:02:06.341 VRDPAUTH: ConsoleVRDPServer::Authenticate: loading external authentication library 'VRDPAuth'
00:02:06.341 rtldrNativeLoad: dlopen('VRDPAuth.dylib', RTLD_NOW | RTLD_LOCAL) failed: dlopen(VRDPAuth.dylib, 6): image not found
00:02:06.341 VRDPAUTH: Failed to load external authentication library. Error code: VERR_FILE_NOT_FOUND
00:02:06.341 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={Could not load the external authentication library 'VRDPAuth' (VERR_FILE_NOT_FOUND)} aWarning=false, preserve=false
00:02:06.342 VRDPAUTH: Access denied.
00:02:06.342 VRDP: Connection closed:
00:02:06.342 VRDP: Logoff: debian (192.168.1.57) build 2600. User: [vbremote] Domain: [] Reason 0x0001.

Change History

comment:1 Changed 4 years ago by poetzsch

  • Version changed from VirtualBox 2.1.2 to VirtualBox 3.1.2
  • Summary changed from VRDP login: external authentification mode on MacOS X host failed, VRDPAuth.dylib not found to VRDP login: external authentification mode on MacOS X host failed, VRDPAuth.dylib not found -> fixed in SVN

This is fixed in SVN & the fix will be available with the next major update of VirtualBox.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 3 years ago by wolf0403

  • Status changed from closed to reopened
  • Resolution fixed deleted

Having this problem here. VirtualBox 4.0.6 r71344, Mac OS X 10.6.7. Started vboxwebsrv directly in terminal as:

$ /Applications/VirtualBox.app/Contents/MacOS/vboxwebsrv 

Then I've setup phpvirtualbox under ~/Sites/phpmyadmin-4.0-5/. I have put my username and password in config.php. When tried logging, vboxwebsrv reports the following on the terminal:

00:04:44.466 SQW01    rtldrNativeLoad: dlopen('VRDPAuth.dylib', RTLD_NOW | RTLD_LOCAL) failed: dlopen(VRDPAuth.dylib, 6): image not found

comment:4 follow-ups: ↓ 5 ↓ 6 Changed 3 years ago by sunlover

wolf0403, please verify if the following command will solve the problem:

VBoxManage setproperty websrvauthlibrary VBoxAuth

comment:5 in reply to: ↑ 4 Changed 3 years ago by wolf0403

Replying to sunlover:

wolf0403, please verify if the following command will solve the problem:

VBoxManage setproperty websrvauthlibrary VBoxAuth

After login with admin/admin I'm getting the same error on the vboxwebsrv terminal session.

comment:6 in reply to: ↑ 4 Changed 3 years ago by wolf0403

Replying to sunlover:

wolf0403, please verify if the following command will solve the problem:

VBoxManage setproperty websrvauthlibrary VBoxAuth

Hi, I've had a look at /Application/VirtualBox.app/Content/MacOS/ and found VBoxAuth.dylib there. So I started vboxwebsrv from within that directory and it now worked correctly. I'm not sure if this is a problem or intended behavior so I'll just put it here. Thanks!

comment:7 Changed 15 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use