VirtualBox

Ticket #309 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Crash with VirtualBox-1.3.8_rhel4-1.i586.rpm on Fedora 7 beta

Reported by: kiilerix Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

I would just let you know that it generally works on Fedora 7, but I got a crash once running a hosted XP

[root@localhost ~]# *** glibc detected *** /opt/VirtualBox-1.3.8/VirtualBox: malloc(): memory corruption (fast): 0x08cc98a6 ***
======= Backtrace: =========
/lib/libc.so.6[0x42d1984d]
/lib/libc.so.6(__libc_malloc+0x7e)[0x42d1aa4e]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QGArrayC2Ei+0x85)[0x44763c05]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QRegionC1ERK5QRectNS_10RegionTypeE+0x1ab)[0x443c118b]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QWidget6updateEiiii+0xa9)[0x443c8ae9]
/opt/VirtualBox-1.3.8/VirtualBox[0x8117ba1]
/opt/VirtualBox-1.3.8/components/VBoxC.so(_ZN7Display19handleDisplayUpdateEiiii+0xcd)[0x1e989a5]
/usr/lib/VBoxDD.so[0x46b1cbb]
/usr/lib/VBoxDD.so[0x46b2be5]
/usr/lib/VBoxDD.so[0x46b31eb]
/usr/lib/VBoxVMM.so[0x1597d2]
/usr/lib/VBoxVMM.so(TMR3TimerQueuesDo+0x72)[0x1598a6]
/usr/lib/VBoxVMM.so[0x17029d]
/usr/lib/VBoxVMM.so(EMR3ExecuteVM+0x655)[0x1709b1]
/usr/lib/VBoxVMM.so(_Z19vmR3EmulationThreadP11RTTHREADINTPv+0xe7)[0x155ab3]
/usr/lib/VBoxRT.so(rtThreadMain+0x2f)[0x4925cb]
/usr/lib/VBoxRT.so[0x49a367]
/lib/libpthread.so.0[0x4312f2db]
/lib/libc.so.6(clone+0x5e)[0x42d8120e]
======= Memory map: ========
00110000-001ce000 r-xp 00000000 fd:00 351511     /usr/lib/VBoxVMM.so
001ce000-001d0000 rwxp 000bd000 fd:00 351511     /usr/lib/VBoxVMM.so
001d0000-00307000 r-xp 00000000 fd:00 351737     /usr/lib/VBoxXPCOM.so
00307000-00311000 rwxp 00137000 fd:00 351737     /usr/lib/VBoxXPCOM.so
00311000-00313000 rwxp 00311000 00:00 0 
00313000-00314000 --xp 00313000 00:00 0 
00314000-00334000 rwxp 00314000 00:00 0 
00334000-00335000 --xp 00334000 00:00 0 
00335000-00355000 rwxp 00335000 00:00 0 
00355000-00378000 r-xp 00000000 fd:00 245806     /opt/VirtualBox-1.3.8/components/VBoxXPCOMIPCC.so
00378000-0037a000 rwxp 00023000 fd:00 245806     /opt/VirtualBox-1.3.8/components/VBoxXPCOMIPCC.so
0037a000-003ab000 r-xp 00000000 fd:00 855628     /usr/lib/kde3/plugins/styles/kthemestyle.so
003ab000-003ad000 rwxp 00030000 fd:00 855628     /usr/lib/kde3/plugins/styles/kthemestyle.so
003ad000-003c4000 r-xp 00000000 fd:00 855622     /usr/lib/kde3/plugins/styles/highcolor.so
003c4000-003c5000 rwxp 00016000 fd:00 855622     /usr/lib/kde3/plugins/styles/highcolor.so
003c5000-003c6000 rwxp 003c5000 00:00 0 
003c6000-003c7000 rwxs 00000000 00:08 217921     /dev/zero (deleted)
003c7000-003db000 r-xp 00000000 fd:00 855624     /usr/lib/kde3/plugins/styles/highcontrast.so
003db000-003dc000 rwxp 00014000 fd:00 855624     /usr/lib/kde3/plugins/styles/highcontrast.so
003dc000-003fa000 r-xp 00000000 fd:00 855630     /usr/lib/kde3/plugins/styles/light.so
003fa000-003fb000 rwxp 0001e000 fd:00 855630     /usr/lib/kde3/plugins/styles/light.so
003fb000-00438000 r-xp 00000000 fd:00 855626     /usr/lib/kde3/plugins/styles/keramik.so
00438000-0043a000 rwxp 0003d000 fd:00 855626     /usr/lib/kde3/plugins/styles/keramik.so
0043a000-00454000 rwxs 00000000 00:08 217920     /dev/zero (deleted)
00454000-00455000 rwxs 00000000 00:08 217922     /dev/zero (deleted)
00455000-00456000 rwxs 00000000 00:08 217923     /dev/zero (deleted)
00456000-00459000 rwxs 00000000 00:08 217924     /dev/zero (deleted)
00459000-0045b000 rwxs 00000000 00:08 217925     /dev/zero (deleted)
0045b000-0045c000 rwxp 0045b000 00:00 0 
0045c000-0045e000 rwxs 00000000 00:08 217942     /dev/zero (deleted)
0045e000-0045f000 rwxp 0045e000 00:00 0 
0045f000-00464000 r-xp 00000000 fd:00 350163     /usr/lib/VBoxSharedFolders.so
00464000-00465000 rwxp 00004000 fd:00 350163     /usr/lib/VBoxSharedFolders.so
00468000-004bc000 r-xp 00000000 fd:00 350126     /usr/lib/VBoxRT.so
004bc000-004bd000 rwxp 00053000 fd:00 350126     /usr/lib/VBoxRT.so
004bd000-004bf000 rwxp 004bd000 00:00 0 
004bf000-00be4000 r-xp 00000000 fd:00 351711     /usr/lib/VBoxXML.so
00be4000-00c21000 rwxp 00724000 fd:00 351711     /usr/lib/VBoxXML.so
00c21000-00c23000 rwxp 00c21000 00:00 0 
00c23000-00c43000 rwxs 00000000 00:08 217926     /dev/zero (deleted)
00c43000-00c64000 r-xp 00000000 fd:00 349651     /usr/lib/VBoxDD2.so
00c64000-00c65000 rwxp 00020000 fd:00 349651     /usr/lib/VBoxDD2.so
00c65000-00c6f000 r-xp 00000000 fd:00 17006      /lib/libnss_files-2.5.90.so
00c6f000-00c70000 r-xp 00009000 fd:00 17006      /lib/libnss_files-2.5.90.so
00c70000-00c71000 rwxp 0000a000 fd:00 17006      /lib/libnss_files-2.5.90.so
00c7e000-00ca8000 r-xp 00000000 fd:00 855632     /usr/lib/kde3/plugins/styles/plastik.so
00ca8000-00ca9000 rwxp 0002a000 fd:00 855632     /usr/lib/kde3/plugins/styles/plastik.so
00ca9000-00caa000 --xp 00ca9000 00:00 0 
00caa000-00d2a000 rwxp 00caa000 00:00 0 
00d2a000-00d2b000 --xp 00d2a000 00:00 0 
00d2b000-00d4b000 rwxp 00d2b000 00:00 0 
00d66000-00d67000 r-xp 00d66000 00:00 0          [vdso]
00d67000-00dd2000 r-xp 00000000 fd:00 350118     /usr/lib/VBoxREM.so
00dd2000-00dd7000 rwxp 0006b000 fd:00 350118     /usr/lib/VBoxREM.so
00dd7000-01263000 rwxp 00dd7000 00:00 0 
01263000-01a64000 rwxp 01263000 00:00 0 
01a64000-01a67000 rwxp 01a64000 00:00 0 
01dee000-01ec8000 r-xp 00000000 fd:00 245804     /opt/VirtualBox-1.3.8/components/VBoxC.so
01ec8000-01ec9000 rwxp 000d9000 fd:00 245804     /opt/VirtualBox-1.3.8/components/VBoxC.so
03432000-03433000 --xp 03432000 00:00 0 
0343

Change History

comment:1 Changed 7 years ago by michael

This is most likely due to the KDE themes that you are using. (It has been seen before noticeably for the Keramic/Crystal theme combination). If you can reproduce it at all, see if changing themes helps.

comment:2 Changed 7 years ago by kiilerix

So far I havent been able to crash it again ;-)

Note that I'm using a standard gnomish as-little-kde-as-possible fedora 7 beta, so it is a setup what very soon will be very common. (I heard however that another theme will be used in the next beta, so that might change it to better or worse...)

comment:3 Changed 7 years ago by kiilerix

Got it again:

[root@localhost .VirtualBox]# * glibc detected * /opt/VirtualBox-1.3.8/VirtualBox: malloc(): memory corruption (fast): 0x0968ae0e * ======= Backtrace: ========= /lib/libc.so.6[0x42d1984d] /lib/libc.so.6(libc_malloc+0x7e)[0x42d1aa4e] /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QGArrayC2Ei+0x85)[0x44763c05] /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QRegionC1ERK5QRectNS_10RegionTypeE+0x1ab)[0x443c118b] /usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QWidget6updateEiiii+0xa9)[0x443c8ae9] /opt/VirtualBox-1.3.8/VirtualBox[0x8117ba1] /opt/VirtualBox-1.3.8/components/VBoxC.so(_ZN7Display19handleDisplayUpdateEiiii+0xcd)[0x1a329a5] /opt/VirtualBox-1.3.8/components/VBoxC.so(_ZN7Display15VideoAccelFlushEv+0x1fd)[0x1a33029] /usr/lib/VBoxDD.so[0x34541eb] /usr/lib/VBoxVMM.so[0x9327d2] /usr/lib/VBoxVMM.so(TMR3TimerQueuesDo+0x72)[0x9328a6] /usr/lib/VBoxVMM.so(VMR3WaitHalted+0x6d)[0x92ebd5] /usr/lib/VBoxVMM.so(EMR3ExecuteVM+0x2f8)[0x949654] /usr/lib/VBoxVMM.so(_Z19vmR3EmulationThreadP11RTTHREADINTPv+0xe7)[0x92eab3] /usr/lib/VBoxRT.so(rtThreadMain+0x2f)[0xc5b5cb] /usr/lib/VBoxRT.so[0xc63367] /lib/libpthread.so.0[0x4312f2db] /lib/libc.so.6(clone+0x5e)[0x42d8120e] ======= Memory map: ======== 00110000-00835000 r-xp 00000000 fd:00 351711 /usr/lib/VBoxXML.so 00835000-00872000 rwxp 00724000 fd:00 351711 /usr/lib/VBoxXML.so 00872000-00874000 rwxp 00872000 00:00 0 00874000-00875000 --xp 00874000 00:00 0 00875000-00895000 rwxp 00875000 00:00 0 00895000-008b8000 r-xp 00000000 fd:00 245806 /opt/VirtualBox-1.3.8/components/VBoxXPCOMIPCC.so 008b8000-008ba000 rwxp 00023000 fd:00 245806 /opt/VirtualBox-1.3.8/components/VBoxXPCOMIPCC.so 008ba000-008bb000 rwxp 008ba000 00:00 0 008bb000-008bc000 rwxs 00000000 00:08 1101485 /dev/zero (deleted) 008bc000-008bd000 rwxs 00000000 00:08 1101486 /dev/zero (deleted) 008bd000-008be000 rwxs 00000000 00:08 1101487 /dev/zero (deleted) 008be000-008c1000 rwxs 00000000 00:08 1101488 /dev/zero (deleted) 008c1000-008c3000 rwxs 00000000 00:08 1101489 /dev/zero (deleted) 008c3000-008c5000 rwxp 008c3000 00:00 0 008c5000-008c6000 --xp 008c5000 00:00 0 008c6000-008e6000 rwxp 008c6000 00:00 0 008e6000-008e8000 rwxs 00000000 00:08 1101491 /dev/zero (deleted) 008e8000-008e9000 r-xp 008e8000 00:00 0 [vdso] 008e9000-009a7000 r-xp 00000000 fd:00 351511 /usr/lib/VBoxVMM.so 009a7000-009a9000 rwxp 000bd000 fd:00 351511 /usr/lib/VBoxVMM.so 009a9000-00ae0000 r-xp 00000000 fd:00 351737 /usr/lib/VBoxXPCOM.so 00ae0000-00aea000 rwxp 00137000 fd:00 351737 /usr/lib/VBoxXPCOM.so 00aea000-00aec000 rwxp 00aea000 00:00 0 00aec000-00b00000 r-xp 00000000 fd:00 855624 /usr/lib/kde3/plugins/styles/highcontrast.so 00b00000-00b01000 rwxp 00014000 fd:00 855624 /usr/lib/kde3/plugins/styles/highcontrast.so 00b01000-00b32000 r-xp 00000000 fd:00 855628 /usr/lib/kde3/plugins/styles/kthemestyle.so 00b32000-00b34000 rwxp 00030000 fd:00 855628 /usr/lib/kde3/plugins/styles/kthemestyle.so 00b34000-00b52000 r-xp 00000000 fd:00 855630 /usr/lib/kde3/plugins/styles/light.so 00b52000-00b53000 rwxp 0001e000 fd:00 855630 /usr/lib/kde3/plugins/styles/light.so 00b53000-00b7d000 r-xp 00000000 fd:00 855632 /usr/lib/kde3/plugins/styles/plastik.so 00b7d000-00b7e000 rwxp 0002a000 fd:00 855632 /usr/lib/kde3/plugins/styles/plastik.so 00b7e000-00b95000 r-xp 00000000 fd:00 855622 /usr/lib/kde3/plugins/styles/highcolor.so 00b95000-00b96000 rwxp 00016000 fd:00 855622 /usr/lib/kde3/plugins/styles/highcolor.so 00b96000-00bd3000 r-xp 00000000 fd:00 855626 /usr/lib/kde3/plugins/styles/keramik.so 00bd3000-00bd5000 rwxp 0003d000 fd:00 855626 /usr/lib/kde3/plugins/styles/keramik.so 00bd5000-00bef000 rwxs 00000000 00:08 1101480 /dev/zero (deleted) 00bef000-00c0f000 rwxs 00000000 00:08 1101490 /dev/zero (deleted) 00c0f000-00c30000 r-xp 00000000 fd:00 349651 /usr/lib/VBoxDD2.so 00c30000-00c31000 rwxp 00020000 fd:00 349651 /usr/lib/VBoxDD2.so 00c31000-00c85000 r-xp 00000000 fd:00 350126 /usr/lib/VBoxRT.so 00c85000-00c86000 rwxp 00053000 fd:00 350126 /usr/lib/VBoxRT.so 00c86000-00c88000 rwxp 00c86000 00:00 0 00c88000-00cf3000 r-xp 00000000 fd:00 350118 /usr/lib/VBoxREM.so 00cf3000-00cf8000 rwxp 0006b000 fd:00 350118 /usr/lib/VBoxREM.so 00cf8000-01184000 rwxp 00cf8000 00:00 0 01184000-01985000 rwxp 01184000 00:00 0 01985000-01988000 rwxp 01985000 00:00 0 01988000-01a62000 r-xp 00000000 fd:00 245804 /opt/VirtualBox-1.3.8/components/VBoxC.so 01a62000-01a63000 rwxp 000d9000 fd:00 245804 /opt/VirtualBox-1.3.8/components/VBoxC.so 01a63000-01a64000 --xp 01a63000 00:00 0 01a64000-01b64000 rwxp 01a64000 00:00 0 01b64000-01b65000 --xp 01b64000 00:00 0 01b65000-01b85000 rwxp 01b65000 00:00 0 01b85000-01b86000 --xp 01b85000 00:00 0 01b86000-01ba6000 rwxp 01b86000 00:00 0 01ba6000-01ba7000 --xp 01ba6000 00:00 0 01ba7000-01bc7000 rwxp 01ba7000 00:00 0 0215b000-02165000 r-xp 00000000 fd:00 17006 /lib/libnss_files-2.5.90.so 02165000-02166000 r-xp 00009000 fd:00 17006

comment:4 Changed 7 years ago by sandervl73

Please retry with 1.4.0

comment:5 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Closing. No reply for two months. 1.5.0 will be released soon by the way.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use