VirtualBox

Ticket #3084 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Windows NT 3.51 problem (Write.exe and IE5_16b installer)

Reported by: Sonict Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords: Windows NT 3.51 write IE5
Cc: Guest type: other
Host type: other

Description

I have a few problems to report with using Windows NT 3.51 as a guest OS under Virtual box.

The main issue I have is with programs crashing for no reason. I have at least two programs which do this and is reproducible %100 of the time for me.

First Issue: Open up Write.exe and try to type anything. Instant crash.

Steps to reproduce: Install a fresh copy of Windows NT 3.51. Login under the default admin account and load up Write from the "Main" program group. Then try typing something, the program crashes and Dr. Watson in Windows NT comes up reporting the error. See attached screen shot for details.

Second Issue: Internet Explorer 5 - 16Bit version is unable to be successfully installed since the installer crashes randomly. You can download IE5 setup from here:  http://www.hpcfactor.com/downloads/msie/ie50/

Steps to reproduce: First, update Windows NT 3.51 to SP5 although it isn't really needed to reproduce the bug. Then, download the IE5 setup and make an ISO that has the setup files on it and load up the program and try to install it. Either the wizard will crash at a random time which has a similar error message to the one above or it will show the exact same message once you see the progress bar part of it. The screen shot attached shows when the Wizard decided to crash.

I have also attached my log file.

Attachments

WinNT351_Write-exe_Crash.PNG Download (27.9 KB) - added by Sonict 5 years ago.
Windows NT 3.51 Write.exe crash
WinNT351_IE5-Setup_Crash.PNG Download (30.3 KB) - added by Sonict 5 years ago.
Windows NT 3.51 IE5 Setup crash
Windows NT 3.51 Test-2009-01-21-00-06-32.log Download (57.8 KB) - added by Sonict 5 years ago.
The VirtualBox logfile just in case

Change History

Changed 5 years ago by Sonict

Windows NT 3.51 Write.exe crash

Changed 5 years ago by Sonict

Windows NT 3.51 IE5 Setup crash

Changed 5 years ago by Sonict

The VirtualBox logfile just in case

comment:1 Changed 5 years ago by Sonict

I have figured out a workaround for this issue. I apparently needed to enable "VT-x/AMD-V" and it solved the write.exe crash when you try to type anything and the crash when trying to install internet explorer 5.0.

However, mIRC 5.91 16-bit still crashes when I try to run it. The error message it shows is similar to the "WinNT351_IE5-Setup_Crash.PNG" message.

At least I made some progress, but there are still issues left.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use