VirtualBox

Ticket #3080 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Linux Host Networking problem in VirtualBox 2.1.0 (malformed Ethernet frames?)

Reported by: corvus Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.1.0 Keywords: Ethernet
Cc: Guest type: other
Host type: other

Description

There is a problem with new network subsystem in VB 2.1.0. Something wrong happening with ethernet frames. To check it you just need to setup hostif networking and do network capture with tcpdump/wireshark. Both sniffers say that Ethernet frames are corrupted or Ethertype is not recognized.

In VB2.0.6 everything worked like a charm. But after update hostif networking doesn't work correctly.

Attachments

network.cap Download (1004 bytes) - added by corvus 5 years ago.
Sample network capture (linux host + winxpsp2 guest). Was pinging host from guest. You may see icmp echo replies but no icmp echo requests (because of ethernet frame problem).

Change History

Changed 5 years ago by corvus

Sample network capture (linux host + winxpsp2 guest). Was pinging host from guest. You may see icmp echo replies but no icmp echo requests (because of ethernet frame problem).

comment:1 follow-up: ↓ 2 Changed 5 years ago by sandervl73

Windows host or Linux host?

comment:2 in reply to: ↑ 1 Changed 5 years ago by corvus

Replying to sandervl73:

Windows host or Linux host?

Linux host.

Btw, I found where the problem is. Seems like VBox extracts IP packet from stream and tcpdump/Wireshark captures raw TCP/IP outgoing stream. When the packet goes to the Guest OS it is packed into Ethernet frame and tcpdump/Wireshark sees that Ethernet frame.

So in the file that I provided you may see IP packets mixed with Ethernet frames on the same level! I know that tun/tap interface may work both with Ethernet and IP levels but why does VBox 2.1 mixes them? It didn't take place in 2.0.6.

comment:3 Changed 5 years ago by sandervl73

  • Summary changed from Windows Host Networking problem in VirtualBox 2.1.0 (malformed Ethernet frames?) to Linux Host Networking problem in VirtualBox 2.1.0 (malformed Ethernet frames?)

comment:4 follow-up: ↓ 5 Changed 5 years ago by sandervl73

Could you try the latest version of vboxnetflt attached to #3056? The instructions are there as well. It accumulates fixes for a number of issues.

comment:5 in reply to: ↑ 4 Changed 5 years ago by corvus

Replying to sandervl73:

Could you try the latest version of vboxnetflt attached to #3056? The instructions are there as well. It accumulates fixes for a number of issues.

Thank you very much! It did work! YOu may close the bug now.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for the feedback! Closing as duplicate of #3056.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use