VirtualBox

Ticket #3071 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Guest additions CDROM image not automatically mounted

Reported by: bqbauer Owned by:
Priority: major Component: DVD
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: other

Description

This has been observed on a 32-bit XP host and 64-bit OpenSolaris host.

Guest additions under 2.1 sometimes will not attach/mount on guests for which I had previously had 100% success. In experiments I have noticed that this problem is not limited to additions, but to any ISO image. When this DOES happen, it is when another ISO has first been attached. If I unmount or eject it from the guest, then unmount it from the VB screen's Devices menu, that last step will not always succeed as it did with previous VB versions, even though the guest no longer thinks it's there. There seems no pattern I can discover other than this.

I have noticed that the Virtual Media Manager thinks the ISO image in question is attached to a guest, even though that guest can no longer see it. Every ISO image I subsequently attempt to mount to a running guest shows up as attached to that guest in the Media Manager. Using the Devices menu, I am unable to unmount or release the ISO image, even though the mount was never successful from the guest's perspective. If I shut down the OS, the media manager still thinks the ISO is attached and I still cannot detach the image from the guest that has been shut down. If I shut down all guests, stop VB, then restart VB, then all ISO images are again properly attached or detached. Restarting VB is all I need to do to "fix" the problem, but this is new with 2.1.

I have been unable to reproduce the problem at will, but have seen reports of people having intermittent problems installing the additions in VB 2.1. I have now observed this problem with the following guests: 64-bit Ubuntu, 64-bit OpenSolaris, 32-bit and 64-bit Vista.

Change History

comment:1 Changed 5 years ago by frank

  • Summary changed from Guest additions inconsistently installed to Guest additions CDROM image not automatically mounted

comment:2 Changed 5 years ago by bqbauer

So far, my tests seem to indicate this was resolved in 2.2.0. I've not run into the problem with 2.2.0 or 2.2.2.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use