VirtualBox

Opened 16 years ago

Closed 15 years ago

#3021 closed defect (duplicate)

VBoxManage fails converting .vdi images to .vmdk

Reported by: Manolo Owned by:
Component: VMM Version: VirtualBox 2.2.2
Keywords: Cc:
Guest type: other Host type: Linux

Description

The command line order for converting vdi into vmdk images, generates an image unusable with vmware (vmplayer message is: ASSERT [...]/disk.c:3868 bugNr=21838).

# VBoxManage internalcommands converthd -srcformat VDI -dstformat VMDK file.vdi file.vmdk 

But converting the same file to raw and then converting into vmdk produces good images.

# VBoxManage internalcommands  converttoraw file.vdi file.raw
# VBoxManage convertfromraw  -format VMDK file.raw file.vmdk

Attachments (1)

Hardy 32.vmdk (576 bytes ) - added by Nebojsa Sabovic 15 years ago.
Flat VMDK

Download all attachments as: .zip

Change History (7)

comment:1 by main, 15 years ago

Can confirm this problem. Bug still exists in 2.2.2 (Host: Linux 64bit)

comment:2 by Klaus Espenlaub, 15 years ago

Can you try this with a flat VMDK image too (2.2.x only)? It requires more space, but it'd allow to track down the bug relatively easily. Just specify --variant fixed. The resulting x-flat.vmdk files should be identical (if not, tell me), as they're the raw image data. The x.vmdk files are regular text files, so if you could attach them I wouldn't need sample files to track down this weird issue.

comment:3 by Klaus Espenlaub, 15 years ago

Version: VirtualBox 2.1.0VirtualBox 2.2.2

comment:4 by Nebojsa Sabovic, 15 years ago

I also have this issue, Virtualbox 3.0.0. I get the same assertion when I create a VMDK using:

VBoxManage clonehd Hardy\ 32.vdi Hardy\ 32.vmdk --format vmdk

I tried creating a flat VMDK, but VMware Fusion 2.0.5 won't import it and pops up an error "The file specified is not a virtual disk". The command was

VBoxManage clonehd Hardy\ 32.vdi Hardy\ 32.vmdk --format vmdk --variant fixed

I'll attach the resulting vmdk.

by Nebojsa Sabovic, 15 years ago

Attachment: Hardy 32.vmdk added

Flat VMDK

comment:5 by Nebojsa Sabovic, 15 years ago

Btw isn't it cute that the modification uuid reads bad baaf...

comment:6 by Klaus Espenlaub, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2723

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use